How to chroot Garuda Linux

From Grub fails after update - #3 by librewish
Some unlucky times that your system is not bootable and the only advised option is to use chroot from a Live ISO to repair the installed system (for example, to (re)install the bootloader), here is the suggested method:

steps required to chroot to your installed Garuda installation (btrfs)

  • Boot to a Garuda usb Live ISO
  • Start a terminal and
  • Find your installed system (btrfs) partition, you need the /dev/<something> part.
lsblk -f

Warning: Remember that your Live booted system partitions will be included (mounted) in the above report.

  • Mount and chroot into the installed system (example partition /dev/nvme0n1p2)
sudo mkdir -p /mnt/broken
sudo mount /dev/nvme0n1p2 /mnt/broken
sudo garuda-chroot /mnt/broken/@
  • Your terminal will enter in the installed system.

Whatever you do there is applied to the installed system.
You will have root rights/privileges, so you don't need to add sudo when you run system level commands.
Your $HOME (and other active environment variables) are those from su/root user account.

In case you want to install the bootloader

  • If the system is installed in Legacy BIOS/MBR
    Find your device that holds MBR and install grub
lsblk -no PKNAME /dev/nvme0n1p5
# nvme0n1  <== use this in next command (/dev/nvme0n1)

grub-install /dev/nvme0n1
  • If the system is installed in UEFI
    Find existing $esp partitions if more than one
parted -l | grep -iE "^Disk /|esp" | grep -B1 esp
Disk /dev/nvme0n1: 256GB
 1  1049kB  274MB   273MB   fat32   EFI system partition  boot, esp
 4  87,4GB  87,9GB  537MB   fat32   EFI system partition  boot, esp

In this example (my PC) there is /dev/nvme0n1p1, used for Windows and /dev/nvme0n1p4 used for my Linux system.
Select the proper $esp partition (you may check your /etc/fstab if you are not sure) and mount it inside chroot

mount /dev/nvme0n1p4 /boot/efi

Then install grub bootloader and update grub

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
update-grub

Do not forget to exit chroot normally, before you close the terminal

Exit the chroot session with

exit

Warning: If there were any unusual or unknown errors in this procedure, it would be better to ask for some advice in the forum, or search Archwiki or the web for info.

Now you are ready to reboot to your system!

10 Likes
I can't solve the GRUB issue
Garuda Installation failed, bootloader installation error
[Solved - kinda] Can't log in : BTRFS: error in btrfs_run_delayed_refs:2124: errno:-5 IO failure
My Screen Got Freeze Suddenly and unable to boot into Garuda
How to exit emergency mode in garuda linux
Recent update destroyed KDE and now I can't boot. Help!
Hi I was trying to install Garuda on my AMD
Garuda Linux don't boot and loop
Stuck on Black Screen after system update, cannot bring up tty, no keyboard shortcuts work. (Problems Occurrs with Gnome edition and Dragonized edition)
Grub deleted after Windows update
Garuda breaks after update
GRUB bootloader overrided by Windows Bootloader in Dual Boot System
No Keyboard & Touchpad on USB Boot - Can't Install
Grub messed up during dual boot os update
Boot Repair (the old dual boot drama)
GRUB menu not showing up after turning on the PC
Dual boot garuda linux
Dual boot garuda linux
Installation Error (KDE Dr460nized)
Unable to restore from grub timeshift
Garuda bspwm (and dragonize) stuck on loading screen after install
Installation failed dragonized (not gaming) download (partition download)
Computer doesn’t boot, boots to a black screen, or stops at a message
Garuda linux not showing up in grub
Welp my garuda install broke thanks to the latest nvidia drivers
Black screen after installing
Black screen after update
Garuda linux stuck in first boot (loading screen)
Failed to start Network Manager
Grub rescue issue can't solve
Multiple system boot issues
Garuda Linux don't boot and loop
Garuda linux won't boot with an error for intel
Can' t boot into Garuda anymore after instaling Win10
Grub replaced by windows and removed from bootmenu entries
Boot stuck on linux-zen
Windows + Garuda dual boot = broken Grub
Garuda worked flawless for months now. After update I'm being dropped to emergency shell :-( How to fix?
Documentation Contribution Request
Boot stuck on linux-zen
Need help booting Garuda after fixing MBR for Windows 10 (Grub dissappeared)
Permission/authentification failures
Garuda worked flawless for months now. After update I'm being dropped to emergency shell :-( How to fix?
Boot rescue showing all partitions as unknown file systems
FAQ and Tutorials Table of Contents
I Installed Windows to dual-boot and now garuda isn't in the boot menu
Problem with refresh rate
How to remove a particular option from grub boot loader
Automatically booting to windows; Can't boot into garuda
GRUB menu not showing after BIOS update
Stuck loading initial ramdisk