Boot rescue showing all partitions as unknown file systems

Hi all, I apologise in advance if there is an article already similar to this that I couldn't find in the end. I've looked at (Boot Repair(the old dual boot drama)) and petsam's guide to chrooting Garuda Linux.

For context, my issue seems to be that I'm stuck in boot rescue as it can't find the efi I believe to boot and when trying ls on each partition it tells me "Filesystem is unknown" and trying set root=(hd0, gpt) etc and prefix with insmod=normal then boot it doesn't work as those commands aren't found.

After using a Live USB the partition manager says that one partition (I believe the one that has the EFI in it) is FAT32 but the other two partitions are 'unknown' type. Here are my console outputs.

inxi -Faz
╭─[email protected] in ~ took 1s
╰─λ inxi -Faz
System:    Kernel: 5.12.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda 
misolabel=GARUDA_DR460NIZED_SOARING_ quiet systemd.show_status=1 driver=nonfree nouveau.modeset=0 
i915.modeset=1 radeon.modeset=1 pci=noats acpi_backlight=vendor 
Desktop: KDE Plasma 5.22.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: IT Channel Pty product: NL5xRU v: N/A serial: <filter> Chassis: type: 10 
serial: <filter> 
Mobo: IT Channel Pty model: NL5xRU serial: <filter> UEFI: INSYDE v: 1.07.08TMB1 date: 03/18/2021 
Battery:   ID-1: BAT0 charge: 29.7 Wh (63.9%) condition: 46.5/48.3 Wh (96.4%) volts: 15.2 min: 15.2 
model: Notebook BAT type: Li-ion serial: <filter> status: Discharging 
CPU:       Info: 8-Core model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 type: MCP arch: Zen 2 
family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600106 cache: L2: 4 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 31942 
Speed: 1397 MHz min/max: 1400/2000 MHz boost: enabled Core speeds (MHz): 1: 1397 2: 1388 3: 1397 
4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 
Vulnerabilities: Type: itlb_multihit status: Not affected 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir vendor: CLEVO/KAPOK driver: amdgpu v: kernel
bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300
Device-2: Chicony Chicony USB2.0 Camera type: USB driver: uvcvideo bus-ID: 3-4:3 chip-ID: 04f2:b685
class-ID: 0e02
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.12.12-zen1-1-zen LLVM 12.0.0) v: 4.6 Mesa 21.1.2
direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel
bus-ID: 05:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor
vendor: CLEVO/KAPOK driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 05:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel
v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.12.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: no
Sound Server-4: PipeWire v: 0.3.30 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK driver: r8169
v: kernel port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 2000 bus-ID: 03:00.0 chip-ID: 8086:2723
class-ID: 0280
IF: wlo1 state: up mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-3:2 chip-ID: 8087:0029
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 938.71 GiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 model: Metabox Performance 1TB PCIe NVME SSD size: 931.51 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter>
rev: ECFM53.0 scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: TDK model: LoR Platinum 3.0 size: 7.2 GiB block-size:
physical: 512 B logical: 512 B serial: <filter> rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 1.88 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 1.88 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 1.88 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 1.88 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-5: swap-5 type: zram size: 1.88 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-6: swap-6 type: zram size: 1.88 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5
ID-7: swap-7 type: zram size: 1.88 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6
ID-8: swap-8 type: zram size: 1.88 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7
Sensors:   System Temperatures: cpu: 43.8 C mobo: 43.0 C gpu: amdgpu temp: 42.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 274 Uptime: 5m wakeups: 2 Memory: 15.07 GiB used: 3.81 GiB (25.3%) Init: systemd v: 248
tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.0 Packages: pacman: 1162 lib: 289 Shell: fish
v: 3.2.2 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.04
╭─[email protected] in ~ took 29ms
[πŸ”΄] Γ— lsblk -f
NAME    FSTYPE FSVER LABEL                   UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0   squash 4.0                                                                      0   100% /run/miso/sfs/livefs
loop1   squash 4.0                                                                      0   100% /run/miso/sfs/mhwdfs
loop2   squash 4.0                                                                      0   100% /run/miso/sfs/desktopfs
loop3   squash 4.0                                                                      0   100% /run/miso/sfs/rootfs
sda     iso966 Jolie GARUDA_DR460NIZED_SOARING_
β”‚                                            2021-06-21-09-15-39-00                     0   100% /run/miso/bootmnt
β”œβ”€sda1  iso966 Jolie GARUDA_DR460NIZED_SOARING_
β”‚                                            2021-06-21-09-15-39-00
└─sda2  vfat   FAT12 MISO_EFI                6D49-D12F
zram0                                                                                            [SWAP]
zram1                                                                                            [SWAP]
zram2                                                                                            [SWAP]
zram3                                                                                            [SWAP]
zram4                                                                                            [SWAP]
zram5                                                                                            [SWAP]
zram6                                                                                            [SWAP]
zram7                                                                                            [SWAP]
nvme0n1
β”œβ”€nvme0n1p1
β”‚       vfat   FAT32 NO_LABEL                9656-73BC
β”œβ”€nvme0n1p2
β”‚
└─nvme0n1p3
swap   1                             4efd445f-7365-4073-b384-7f7ddd9e5747

Following the guide:

╭─[email protected] in ~ took 7ms
╰─λ sudo mkdir -p /mnt/broken

╭─[email protected] in ~ took 16ms
╰─λ sudo mount /dev/nvme0n1p1 /mnt/broken

╭─[email protected] in ~ took 30ms
╰─λ sudo garuda-chroot /mnt/broken/@
==> ERROR: Can't create chroot on non-directory /mnt/broken/@

╭─[email protected] in /mnt/broken/EFI/bootπŸ”’ took 5ms
╰─λ ls /mnt/broken
drwxr-xr-x - root 24 Mar 17:34 ο„• EFI

╭─[email protected] in /mnt/broken/EFIπŸ”’
╰─λ ls
drwxr-xr-x - root  9 Jul  2021 ο„• boot
drwxr-xr-x - root  9 Jul  2021 ο„• Garuda
drwxr-xr-x - root 24 Mar 17:32 ο„• Insyde
drwxr-xr-x - root 24 Mar 17:34 ο„• UpdateCapsule

╭─[email protected] in /mnt/broken/EFI/bootπŸ”’ took 3ms
╰─λ ls /mnt/broken/EFI/boot
.rwxr-xr-x 287k root  9 Jul  2021 ο…› bootx64.efi

╭─[email protected] in /mnt/broken/EFI/bootπŸ”’ took 3ms
╰─λ sudo garuda-chroot /mnt/broken/EFI
mount: /mnt/broken/EFI/proc: mount point does not exist.
==> ERROR: failed to setup API filesystems in chroot /mnt/broken/EFI
 
╭─[email protected] in /mnt/broken/EFI/bootπŸ”’ took 4ms
╰─λ ls /mnt/broken/EFI/Garuda/
.rwxr-xr-x 287k root  9 Jul  2021 ο…› grubx64.efi

╭─[email protected] in /mnt/broken/EFI/bootπŸ”’ took 4ms
╰─λ ls /mnt/broken/EFI/Insyde/

╭─[email protected] in /mnt/broken/EFI/bootπŸ”’ took 2ms
╰─λ ls /mnt/broken/EFI/UpdateCapsule/

Trying the unknown partition:

╭─[email protected] in ~ took 47ms
[⚑] Γ— sudo mkdir -p /mnt/broken2

╭─[email protected] in ~ took 14ms
╰─λ sudo mount /dev/nvme0n1p2 /mnt/broken2
mount: /mnt/broken2: wrong fs type, bad option, bad superblock on /dev/nvme0n1p2, missing codepage or helper program,or other error.

I'm at a bit of a loss on how to proceed with fixing it and getting it to boot again. I wasn't comfortable trying Boot repair without knowing what filesystem the nvme0n1p2 should be.

If I missed any information to include, let me know and I'll add it where possible.
Thanks.

garuda-inxi is the preferred diagnostic output. It is a special script for Garuda systems that provides more helpful troubleshooting details than inxi -Faz.

This command should be pointed at the partition the system is installed on (not the EFI partition). In your case I believe that will be either nvme0n1p2 or nvme0n1p3. If you are not sure which partition it is, it would be best to mount them both and run lsblk -f again to help figure it out.

Once you have the correct partition mounted, give it another shot. :slightly_smiling_face:

2 Likes

For some reason in console it doesn't recognize garuda-inxi

╭─[email protected] in ~ took 29ms
[πŸ”΄] Γ— garuda-inxi
fish: Unknown command: garuda-inxi

When trying to mount the other partition it says this:

╭─[email protected] in ~ took 4ms
╰─λ sudo mkdir -p /mnt/broken4

╭─[email protected] in ~ took 8ms
╰─λ sudo mount /dev/nvme0n1p2 /mnt/broken4╭─[email protected] in ~ took 29ms
[πŸ”΄] Γ— garuda-inxi
fish: Unknown command: garuda-inxi

mount: /mnt/broken4: wrong fs type, bad option, bad superblock on /dev/nvme0n1p2, missing codepage or helper program,or other error.

And nvme0n1p3 is the swap partition I believe.

Are you certain Garuda is on p2, and not p3?

When I try p3
╭─[email protected] in ~ ╰─λ sudo mount /dev/nvme0n1p3 /mnt/broken4 mount: /mnt/broken4: unknown filesystem type 'swap'.

p2 is about 950ish gb's so it should be p2.

Oh yes, I do see it labeled as swap in your lsblk -f.

Your mount attempt you posted above looks a little jumbled (the inxi command is pasted in there somehow). Is this the command you executed?

sudo mount /dev/nvme0n1p2 /mnt/broken4

:point_up_2: That looks right. If that is not working, you might have a corrupt filesystem. You could try:

sudo btrfs check /dev/nvme0n1p2

If errors are detected, run:

sudo btrfs check --repair /dev/nvme0n1p2

Sorry for the jumbled command, the paste came in weird. But yeah, I did execute that command and didn't seem to work.

╭─[email protected] in ~ took 25ms
[πŸ”΄] Γ— sudo btrfs check /dev/nvme0n1p2
Opening filesystem to check...
No valid Btrfs found on /dev/nvme0n1p2
ERROR: cannot open file system

╭─[email protected] in ~ took 22ms
[πŸ”΄] Γ— sudo btrfs check --repair /dev/nvme0n1p2
enabling repair mode
WARNING:

Do not use --repair unless you are advised to do so by a developer
or an experienced user, and then only after having accepted that no
fsck can successfully repair all types of filesystem corruption. Eg.
some software or hardware bugs can fatally damage a volume.
The operation will start in 10 seconds.
Use Ctrl-C to stop it.
10 9 8 7 6^C⏎               

I cancelled it as I wasn't sure if I should or not.
Not sure if it was btrfs or not. Would it be safe to try repair regardless?

Hmm, something is odd about this whole thing. Is it possible you installed Garuda with a filesystem other than btrfs?

I'm unsure what file system I used but I'm 60% sure it was btrfs. But not sure why there is a FAT32 there. I know there was a file system when it was installed but for some reason reverted or file system got an issue and now partitions are unformated. I don't want to be too careless with repairing it as there isn't a whole lot that I'd lose but lots of time wasted if it does.

That is your EFI partition, used in the boot process. It is normal for it to be FAT32.

If the system is not even detecting btrfs on the system, I'm not sure what benefit the btrfs repair will provide.

I'm kind of stumped, to be honest. One thing I wonder is if you had a newer ISO on your boot media, would you get a different result? Judging by the kernel version, I'm guessing this ISO is over a year old.

1 Like

You make a good point. I should try the latest and see if there is a difference.

I tried mounting the partition again on a fresh installation of the ISO but same error as before.
Any other suggestions possible? Should I try boot repair (if so what options)?

I'm a little confused, did you install fresh over the same drive and partition you are having issues with or on a separate drive or partition still trying to read the partition that you couldn't access before?

If you installed over the same drive and partition and still having issues my guess something about your drive might be going bad, something about your computer setup maybe a bios/UEFI settings might be causing issues or something is happening during install/initial boot corrupting the drive.

If it's a separate drive/partition at this point I would try a different Linux distribution to see if it's an issue with Garuda specifically or not. I would try a distribution with a wide support of file systems already pre-installed just so you can determine what file system is the one you are trying to access. There is a small chance that the file system you are trying to read may not be pre-installed on Garuda or an issue is causing Garuda not to see it.

Sadly at the end of the day unfortunately the drive/partition may not be recoverable or at least easily and cheaply.

Just a thought... You might want to check if there is a firmware update to your drive or even a bios update to your computer/motherboard just to make sure you are not chasing your tail over a such an issue. This is really a last ditch effort if nothing else works but worth a try.

Thank you, I'll have a look more into it regards the BIOS update and check another distribution.

I've tried testdisk and ddrescue but no luck in recovering. Tried other distributions but no luck for file types. I think it's just unrecoverable at the moment.
Not familiar with fixing partitions but should I just reinstall onto the partitions which overwrites it or should I change the partitions first?

:frowning_face: Too bad, sorry I was not able to be more helpful.

If you offer the whole disk for the installation you don't have to do anything, it will automatically delete the old stuff and re-do whatever it needs to on its own.

1 Like

Ah okay, sweet. Thanks for trying to help though. I think I know why it became like this. Basically after a certain update to the grub file the initrd command line with the amd_ucode.img and linux.img kept failing because there wasn't a space between them, there was either a ^ or something. But when separated with another initrd it would work. I think the repeated shutdown when the grub file changed and tried to boot might have corrupted it or something else. I'll just be more careful I think. Any recommendations for distributions garuda or otherwise? I tried dragonized but probably want a more lightweight/customizable one.

What made you think about this exactly? If such a thing is true, it is a very serious bug (if it is caused from a Garuda utility, or other Archlinux instruction/command).
Give more details and please write more facts and no assumptions.

1 Like

Well I don't have my computer working still so I can't get screenshots but I think in /boot/grub.d (or conf.d)/grub.cfg when it gives you the boot list options for certain kernels like zen or lts and I think between x86 or 64 (around 4 different boot options) it has initrd with amd_ucode.img^(lts-kernel). If I ran my PC with this, it would not boot. If I separated with two initrd it would run. I only use lts, not sure what version. I can't give you facts, given I am not qualified enough to have known what caused this issue in the first place. All I know is that it wouldn't boot like this. If it was a bug, I'd have figured your forum would have something on it which it didn't so I figured it was just an issue for myself.
Although whenever I changed the file to be separated lines, next update to the system with pacman -Syu it would change it back.

Hai if you have bootable garuda usb..boot into garuda linux...Go to gparted. select the hard drive where boot is located..you will receive error message saying your harddrive primary gpt parition file is corrupted, but back up is loaded...select the boot partition and do right click to get options.. in that select manage flag option...select "bios_grub" flag. you may see your harddrive getting mounted. shutdown , remove bootable usb and start into garuda linux...This worked for me. hope it works for you as well...