Chroot: how to access home directory? (after boot error)

  1. I got the same error as this recent post:
Loading Linux linux-zen

error: file/@/boot/vmlinuz-linux-zen not found.

Booting from a snapshot gets stuck after Finished setting up Additional Binary Formats.

  1. To reinstall GRUB I booted garuda from a USB and did chroot.
    I exactly followed the steps of this FAQ: How to chroot Garuda Linux
    However booting from this does not even show the Garuda Linux boot option. The boot screen only shows UEFI firmware settings and snapshots.
    So I thought I should run garuda-update from chroot which will apparently fix something according to the first link above??

  2. I do not have enough disk space to run garuda-update. (needs 3.5GB, have 1.5GB)
    I would like to delete some files from my home folder.
    However the /home/ directory is empty?
    Is there any way to access the home directory from chroot?
    Or is ther some other way to clear disk space?

  3. garuda-inxi :

  Kernel: 6.8.7-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    avail: hpet,acpi_pm parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=garuda root=miso:LABEL=GARUDA_DR460NIZED_BIRDOFPREY quiet systemd.show_status=1
    checksum=y driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
  Desktop: KDE Plasma v: ERR-101 tk: Qt v: N/A dm: N/A Distro: Garuda base: Arch Linux
  Type: Desktop Mobo: Gigabyte model: B550M DS3H AC v: x.x serial: N/A
    uuid: 035e02d8-04d3-05db-4c06-040700080009 UEFI: American Megatrends LLC. v: F15 date: 07/29/2022
  Info: model: AMD Ryzen 7 5800X socket: AM4 bits: 64 type: MT MCP arch: Zen 3+ gen: 4 level: v3
    note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25) model-id: 0x21 (33) stepping: 0
    microcode: 0xA201016
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 2300 high: 3800 min/max: 2200/4850 boost: enabled base/boost: 3800/4850
    scaling: driver: acpi-cpufreq governor: schedutil volts: 1.1 V ext-clock: 100 MHz cores: 1: 3800
    2: 2200 3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 2200 10: 2200 11: 2200 12: 2200
    13: 2200 14: 2200 15: 2200 16: 2200 bogomips: 121374
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
  Vulnerabilities: <filter>
  Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] vendor: ASUSTeK driver: nvidia v: 550.76
    non-free: 550.xx+ status: current (as of 2024-04; EOL~2026-12-xx) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s ports: active: none off: DP-1,DVI-D-1,HDMI-A-1 empty: none bus-ID: 06:00.0
    chip-ID: 10de:2187 class-ID: 0300
  Display: server: v: with: Xwayland v: 24.1.0 driver:
    gpu: nvidia,nvidia-nvswitch display-ID: :0
  Monitor-1: DP-1 model: Dell P2719H serial: <filter> built: 2020 res: 1920x1080 dpi: 82
    gamma: 1.2 size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes: max: 1920x1080
    min: 640x480
  Monitor-2: DVI-D-1 model: Dell P2719H serial: <filter> built: 2020 res: 1920x1080 dpi: 82
    gamma: 1.2 size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes: max: 1920x1080
    min: 640x480
  Monitor-3: HDMI-A-1 model: ViewSonic VX2453 Series serial: <filter> built: 2011 res: 1920x1080
    dpi: 94 gamma: 1.2 size: 520x290mm (20.47x11.42") diag: 595mm (23.4") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  API: EGL v: 1.5 platforms: device: 1 drv: swrast surfaceless: drv: swrast
    inactive: gbm,wayland,x11,device-0
  API: OpenGL v: 4.5 vendor: mesa v: 24.1.1-arch1.1 note: incomplete (EGL sourced)
    renderer: llvmpipe (LLVM 17.0.6 256 bits)
  API: Vulkan Message: No Vulkan data available.
  Device-1: NVIDIA TU116 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 06:00.1
    chip-ID: 10de:1aeb class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 08:00.4 chip-ID: 1022:1487 class-ID: 0403
  API: ALSA v: k6.8.7-zen1-2-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.7 status: off with: 1: pipewire-pulse status: off 2: wireplumber
    status: off 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:24fb class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet vendor: Gigabyte
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Info: services: No services found.
  Device-1: Intel Wireless-AC 3168 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-9:5 chip-ID: 8087:0aa7 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 5 state: down bt-service: N/A rfk-block: hardware: no
    software: no address: N/A
  Local Storage: total: 2.3 TiB used: 469.08 GiB (19.9%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 002C temp: 35.9 C
  SMART: yes health: PASSED on: 3y 85d 9h cycles: 561 read-units: 206,563,279 [105 TB]
    written-units: 158,087,280 [80.9 TB]
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD20EFRX-68EUZN0 family: Red
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B sata: 3.0 speed: 6.0 Gb/s tech: HDD
    rpm: 5400 serial: <filter> fw-rev: 0A80 temp: 33 C
  SMART: yes state: enabled health: PASSED on: 2y 242d 8h cycles: 27132
  ID-3: /dev/sdb maj-min: 8:16 model: N/A size: 14.65 GiB block-size: physical: 512 B
    logical: 512 B type: USB rev: 2.0 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
    fw-rev: 2.00
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 469.08 GiB (98.4%) fs: btrfs
    block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.51 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
  System Temperatures: cpu: 48.4 C mobo: 34.0 C
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB available: 15.52 GiB used: 4 GiB (25.8%)
  Processes: 0 Power: uptime: 1h 45m states: freeze,mem,disk suspend: deep avail: s2idle
    wakeups: 4 hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 6.17 GiB
    Init: systemd v: 255 default: graphical tool: systemctl
  Packages: 2521 pm: nix-default pkgs: 0 pm: nix-sys pkgs: 0 pm: nix-usr pkgs: 0 pm: pacman
    pkgs: 2520 libs: 530 tools: gnome-software, octopi, pamac, paru, yay pm: flatpak pkgs: 1
    Compilers: clang: 17.0.6 gcc: 14.1.1 Client: inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-06-16
  Last full system update: 2024-06-04
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager connman mkinitcpio nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:            

  1. I apologise for not keeping enough disk space, and for not updating my pc regularly.
    Any other way to fix this boot issue will be greatly appreciated, thank you!

When inside chroot, give a

pacman -Scc

And this will free up more than enough space for a garuda-update.
For the home directory, you should see it also from the live USB, not in chroot, opening /dev/nvme0n1.

  1. Hmm, am I checking diskspace correctly?
    Running df before and after running pacman -Scc still shows 1.5GB free on / :
Filesystem     1K-blocks      Used Available Use% Mounted on
/dev/nvme0n1p2 499794200 491864932   1574108 100% /
efivarfs             128        16       108  13% /sys/firmware/efi/efivars
udev             8091320         0   8091320   0% /dev
shm              8134372         0   8134372   0% /dev/shm
run              8134372         8   8134364   1% /run
tmp              8134372         8   8134364   1% /tmp
overlay         12201564   1860724  10340840  16% /etc/resolv.conf

  1. How do I access /dev/nvme0n1 ? Opening in dolphin asks me which program to use to open it, and I can’t cd into it either. Apologies for not understanding how devices work :see_no_evil:

You could try a

sudo mount -o subvol=@home /dev/nvme0n1p2 /mnt/home

PS: sorry, I wrote too quickly earlier.
-Scc and not -scc :smiling_face:
And you mount a partition (yours should be /dev/nvme0n1p2) and not open a disk…

1 Like

Thanks filo, but that gives

mount: /mnt/home: mount point does not exist.
       dmesg(1) may have more information after failed mount system call.
sudo mkdir -p /mnt/home


sudo mount -o subvol=@home /dev/nvme0n1p2 /mnt/home
1 Like
  1. Thanks filo, I cleared some space and updated. But it still doesn’t show Garuda Linux in the boot menu.
  2. The grub commands I ran were (acc to the FAQ)
mount /dev/nvme0n1p1 /boot/efi
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
  1. update-grub gave output:
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda-dr460nized/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-zen-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2024-06-16 19:35:28 | @/.snapshots/346/snapshot | post | linux-zen                                                                |
Found snapshot: 2024-06-16 19:35:08 | @/.snapshots/345/snapshot | pre  | N/A                                                                      |
Found snapshot: 2024-06-16 19:08:45 | @/.snapshots/344/snapshot | post | alsa-lib alsa-plugins ark baloo-widgets cachyos-ananicy-rules-git chromi |
Found snapshot: 2024-06-16 19:02:07 | @/.snapshots/343/snapshot | pre  | N/A                                                                      |
Found snapshot: 2024-06-16 15:03:02 | @/.snapshots/342/snapshot | post | inkscape                                                                 |
Found snapshot: 2024-06-16 15:02:59 | @/.snapshots/341/snapshot | pre  | N/A                                                                      |
Found snapshot: 2024-06-16 13:51:27 | @/.snapshots/340/snapshot | post | linux-zen                                                                |
Found snapshot: 2024-06-13 15:54:45 | @/.snapshots/338/snapshot | pre  | pacman -Su                                                               |
Found snapshot: 2024-06-04 15:58:43 | @/.snapshots/337/snapshot | post | bash-completion botan2 ccache cmake cups doxygen enchant findutils garud |
Found snapshot: 2024-06-04 15:58:30 | @/.snapshots/336/snapshot | pre  | pacman -Su                                                               |
Found snapshot: 2024-06-02 00:08:19 | @/.snapshots/335/snapshot | post | abseil-cpp adwaita-cursors adwaita-icon-theme adwaita-icon-theme-legacy  |
Found snapshot: 2024-06-01 23:56:31 | @/.snapshots/334/snapshot | pre  | pacman -Su                                                               |
Found snapshot: 2024-05-27 18:53:31 | @/.snapshots/333/snapshot | post | qt5-webkit                                                               |
Found snapshot: 2024-05-27 18:53:29 | @/.snapshots/332/snapshot | pre  | pacman -R qt5-webkit                                                     |
Found snapshot: 2024-05-27 14:22:39 | @/.snapshots/331/snapshot | post | rust                                                                     |
Found snapshot: 2024-05-27 14:22:36 | @/.snapshots/330/snapshot | pre  | pacman -S rust                                                           |
Found snapshot: 2024-05-18 06:58:15 | @/.snapshots/329/snapshot | post | abseil-cpp alsa-card-profiles attica audacious-plugins avr-gcc baloo bat |
Found snapshot: 2024-05-18 06:44:45 | @/.snapshots/328/snapshot | pre  | pacman -Su                                                               |
Found 18 snapshot(s)
Unmount /tmp/grub-btrfs.4vQQ30rcYu .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
  1. What am I doing wrong?
    Should I run sudo grub-mkconfig -o /boot/grub/grub.cfg at any point??

Try garuda-update from inside chroot.

I did that already! It didn’t fix it :frowning:

There is something very strange going on here.
The update-grub was ok and the linux-zen kernel was there.
You could try reinstalling it from inside chroot:

pacman -S linux-zen linux-zen-headers

If it doesn’t work, try the LTS kernel

pacman -S linux-lts linux-lts-headers

Just in case, make also sure that the right bootloader is used, with


Did you skip any FAQ steps?
Did you check for existing esp partitions and confirm with /etc/fstab for the correct one?

Retry chroot.
In chroot terminal, get info:

lsblk -prfo +PARTUUID
grep -v "^#" /etc/fstab | sed 's|\s\+| |g'

Post all terminal input and output here.


Boot into Garuda USB,

Open terminal and run the commands in the following order :

1.sudo mount -o subvol=@ /dev/nvme0n1p2 /mnt

2.sudo mkdir /mnt/home

3.sudo mount -o subvol=@home /dev/nvme0n1p2 /mnt/home

4.sudo mkdir /mnt/boot/efi

5.sudo mount /dev/yournvmeesppartition /mnt/boot/efi

6.sudo arch-chroot /mnt

Then run the commands in the similar recent post in the same order.

Just for the record, in the output, 2 errors appear:

( 6/11) Refreshing PackageKit ...
Error connecting: Could not connect: No such file or diretory
error: command failed to execute correctly


(10/11) Performing snapper post snapshots for the following configurations ...
fatal library error, lookup self
=> root: 348
(11/11) Syncing all file systems ...
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0000,0001,0004,0005,0002,0003,0006
Boot0000* garuda	HD(1,GPT,25b9a399-8150-5240-ad68-6d7454c58a9f,0x1000,0x96000)/\EFI\garuda\grubx64.efi
Boot0001* UEFI OS	HD(1,GPT,25b9a399-8150-5240-ad68-6d7454c58a9f,0x1000,0x96000)/\EFI\BOOT\BOOTX64.EFI0000424f
Boot0002* INTEL SSDPEKNW512G8	BBS(HD,,0x0)0000424f
Boot0003* WDC WD20EFRX-68EUZN0	BBS(HD,,0x0)0000424f
Boot0004* UEFI: VendorCoProductCode 2.00	PciRoot(0x0)/Pci(0x1,0x2)/Pci(0x0,0x0)/USB(8,0)/CDROM(1,0x537d4c,0x8000)0000424f
Boot0005* UEFI: VendorCoProductCode 2.00, Partition 2	PciRoot(0x0)/Pci(0x1,0x2)/Pci(0x0,0x0)/USB(8,0)/HD(2,MBR,0x0,0x537d4c,0x2000)0000424f
Boot0006* VendorCoProductCode 2.00	BBS(HD,,0x0)0000424f

I have been booting from 0004 for the usb drive

Also for the record, when I exit chroot it says

umount: /mnt/broken/@: target is busy.

It boots normally now, thank you!

I had re-installed linux-zen earlier, but not linux-zen-headers.
IDK if that’d what fixed it, but it boots normally to Garuda Linux now.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.