Fixing efi bootloader?


Quite new to linux as i swapped only about 2 months ago. So terminology might not be 100% correct, but i’ll give it a go.

I had a running dual boot with windows and Garuda running just fine. Recently i’ve uppgraded my PC with new motherboard, ram and CPU. Now im running AMD ryzen 7 78003x3d and MSI b650 motherboard, Old setup was a intel skylake CPU and matching motherboard.

Now that i try booting I only see my windows partition which is the only boot option that works. My drives are not changed and are working fine. I’ve tried to disable secure boot and swapped between csm and uefi + enabling legacy boot to find my linux EFI bootloader(?) that working.

I had the live image from garuda still on stick and if I boot that and detect EFI bootloader I can boot into my OS and all working fine after detecting and booting. Which is how I know that it’s not anything wrong with my drive.

Looking into the forum I’ve found to posts that are pretty similar to what i’m experiencing. Could someone with more experience confirm that reinstalling grub would work? Also assuming that if os-prober works fine that should also find my windows partition so that I can boot into that as a backup if needed.

How to chroot Garuda Linux - FAQ and Tutorials - Garuda Linux Forum

Grub fails after update - Issues & Assistance - Garuda Linux Forum

picture of BIOS settings: My "broken" computer - Album on Imgur

If i’m way off and it’s something else, then please let me know :slight_smile:

Use chroot from live ISO welcome app

sudo grub-install /dev  <-----  use EFI path, check lsblk -f
sudo update-grub
exit # chroot


update-grub again if you are in your garuda linux DE


If Windows is installed using EFI, you need to install Linux the same, not in legacy mode. The reverse is also true.

1 Like

Booted into live iso but not finding the mounting for efi. I would assume it’s nvme0n1p1 as that suits the correct size. Can it just be installed there without issues?

Ignored the whole part where you said to enter chroot which has it’s own icon and all. Ran lsblk - f from the correct tool and found efi and installed. Worked like a dream.

Thanks for the help

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.