Welp my garuda install broke thanks to the latest nvidia drivers

Yes folks my garuda system is gone now, kaput.
The issue is so bad that i can't post a log as even when I try fallback mode all I get is a black screen.
And it's not like I have an unsupported card here, its a RTX 2070 super.
I kept my system up to date and didnt install anything I could think of that could cause this.
Oh well I gave garuda a shot, it was fun while it lasted.
I dont want to try again as for all I know a reinstall may not help me and I need my system operation.
So goodbye garuda hello Kubuntu 20.04... again.
Home sweet home i guess.

Just for your info since you seem unaware we have snapshots that are taken before upgrade which can be booted into from grub and restored to previous state.


did you try to reboot from one of the timeshift snapshots?

Yes but it failed sadly, nothing happened and it still resulted in a black screen.

Yes I am aware but as i said it did not work.
And its not like I never used timeshift before but for some reason it failed.
It could be some other setting but I rather not dig in right now as I just want my linux system back without jumping through hoops.
If that means going back to Kubuntu I will take it at least until I can find the proper time to try this all again.
I just got so much to do right now, real life stuff gets in the way of my linux hobby sometimes.

Fair enough. Thanks for giving Garuda a try! Come back if you ever want to live dangerously :wink:


Nvidia work fine here,

inxi -G
Graphics:  Device-1: NVIDIA GA106 [GeForce RTX 3060] driver: nvidia v: 470.63.01 
           Display: x11 server: X.Org 1.20.13 driver: loaded: nvidia unloaded: modesetting resolution: 3840x2160~60Hz 
           OpenGL: renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01 

but you can't expect a Kubuntu guy to do a garuda-chroot or TTY to install a different kernel to get the Nvidia driver installed/updated correctly.

Check the Garuda Wiki how to restore snapshots and search in forum the post how to fix the black screen phenomenon by jonathon .


nvidia-dkms-470.74-1  nvidia-settings-470.74-1  nvidia-utils-470.74-1  opencl-nvidia-470.74-1

Lets see :slight_smile:

[sudo] Passwort für sgs:    
File: /etc/pacman.d/mirrorlist
################# Arch Linux mirrorlist generated by Reflector #################

# With:       reflector --country Germany --latest 5 --age 2 --fastest 5 --protocol https --sort rate --save /etc/pacman.d/mirrorlist
# When:       2021-09-21 08:08:49 UTC
# From:       https://archlinux.org/mirrors/status/json/
# Retrieved:  2021-09-21 08:08:42 UTC
# Last Check: 2021-09-21 07:50:03 UTC

Server = https://ftp.halifax.rwth-aachen.de/archlinux/$repo/os/$arch
Server = https://mirror.pkgbuild.com/$repo/os/$arch
Server = https://ftp.fau.de/archlinux/$repo/os/$arch
Server = https://mirror.chaoticum.net/arch/$repo/os/$arch
Server = https://mirror.f4st.host/archlinux/$repo/os/$arch
:: Paketdatenbanken werden synchronisiert …
 core                                                                       137,0 KiB   614 KiB/s 00:00 [-------------------------------------------------------------] 100%
 extra                                                                     1569,8 KiB  2,19 MiB/s 00:01 [-------------------------------------------------------------] 100%
 community                                                                    5,8 MiB  3,49 MiB/s 00:02 [-------------------------------------------------------------] 100%
 multilib                                                                   149,5 KiB   536 KiB/s 00:00 [-------------------------------------------------------------] 100%
 chaotic-aur                                                               1505,7 KiB  1238 KiB/s 00:01 [-------------------------------------------------------------] 100%
:: Vollständige Systemaktualisierung wird gestartet …
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …

Pakete (20) garuda-tools-base-git-r132.78dc500-1  garuda-tools-iso-git-r132.78dc500-1  garuda-tools-yaml-git-r132.78dc500-1  ldb-2:2.4.0-1  lib32-libxcrypt-4.4.26-1
            lib32-nvidia-utils-470.74-1  lib32-opencl-nvidia-470.74-1  lib32-vulkan-icd-loader-1.2.191-1  libcap-2.58-1  libimagequant-2.16.0-1  libxcrypt-4.4.26-1
            libxnvctrl-470.74-1  nvidia-dkms-470.74-1  nvidia-settings-470.74-1  nvidia-utils-470.74-1  opencl-nvidia-470.74-1  perl-libwww-6.57-1  samba-4.15.0-1
            smbclient-4.15.0-1  vulkan-icd-loader-1.2.191-1

Gesamtgröße des Downloads:             258,77 MiB
Gesamtgröße der installierten Pakete:  816,52 MiB
Größendifferenz der Aktualisierung:      1,45 MiB

:: Installation fortsetzen? [J/n] 
:: Pakete werden empfangen …
 opencl-nvidia-470.74-1-x86_64                                               15,4 MiB  1008 KiB/s 00:16 [-------------------------------------------------------------] 100%
 lib32-opencl-nvidia-470.74-1-x86_64                                         16,8 MiB  1004 KiB/s 00:17 [-------------------------------------------------------------] 100%
 samba-4.15.0-1-x86_64                                                        7,9 MiB  1241 KiB/s 00:07 [-------------------------------------------------------------] 100%
 lib32-nvidia-utils-470.74-1-x86_64                                          23,9 MiB  1083 KiB/s 00:23 [-------------------------------------------------------------] 100%
 nvidia-dkms-470.74-1-x86_64                                                 24,5 MiB  1091 KiB/s 00:23 [-------------------------------------------------------------] 100%
 smbclient-4.15.0-1-x86_64                                                    6,9 MiB  1261 KiB/s 00:06 [-------------------------------------------------------------] 100%
 ldb-2:2.4.0-1-x86_64                                                       215,3 KiB   628 KiB/s 00:00 [-------------------------------------------------------------] 100%
 nvidia-settings-470.74-1-x86_64                                            772,7 KiB  1223 KiB/s 00:01 [-------------------------------------------------------------] 100%
 lib32-vulkan-icd-loader-1.2.191-1-x86_64                                   120,6 KiB   406 KiB/s 00:00 [-------------------------------------------------------------] 100%
 perl-libwww-6.57-1-any                                                     137,2 KiB   445 KiB/s 00:00 [-------------------------------------------------------------] 100%
 libxcrypt-4.4.26-1-x86_64                                                   88,6 KiB   271 KiB/s 00:00 [-------------------------------------------------------------] 100%
 vulkan-icd-loader-1.2.191-1-x86_64                                         111,1 KiB   241 KiB/s 00:00 [-------------------------------------------------------------] 100%
 libcap-2.58-1-x86_64                                                        78,5 KiB   277 KiB/s 00:00 [-------------------------------------------------------------] 100%
 lib32-libxcrypt-4.4.26-1-x86_64                                             76,3 KiB   268 KiB/s 00:00 [-------------------------------------------------------------] 100%
 libimagequant-2.16.0-1-x86_64                                               42,2 KiB   149 KiB/s 00:00 [-------------------------------------------------------------] 100%
 libxnvctrl-470.74-1-x86_64                                                  76,1 KiB   262 KiB/s 00:00 [-------------------------------------------------------------] 100%
 garuda-tools-iso-git-r132.78dc500-1-x86_64                                  39,1 KiB  68,8 KiB/s 00:01 [-------------------------------------------------------------] 100%
 garuda-tools-base-git-r132.78dc500-1-x86_64                                 25,3 KiB  43,8 KiB/s 00:01 [-------------------------------------------------------------] 100%
 garuda-tools-yaml-git-r132.78dc500-1-x86_64                                  9,5 KiB  25,9 KiB/s 00:00 [-------------------------------------------------------------] 100%
 nvidia-utils-470.74-1-x86_64                                               161,6 MiB  3,53 MiB/s 00:46 [-------------------------------------------------------------] 100%
 Gesamt (20/20)                                                             258,8 MiB  5,65 MiB/s 00:46 [-------------------------------------------------------------] 100%
(20/20) Schlüssel im Schlüsselbund werden geprüft                                                       [-------------------------------------------------------------] 100%
(20/20) Paket-Integrität wird überprüft                                                                 [-------------------------------------------------------------] 100%
(20/20) Paket-Dateien werden geladen                                                                    [-------------------------------------------------------------] 100%
(20/20) Auf Dateikonflikte wird geprüft                                                                 [-------------------------------------------------------------] 100%
(20/20) Verfügbarer Festplattenspeicher wird ermittelt                                                  [-------------------------------------------------------------] 100%
:: Pre-transaction-Hooks werden gestartet …
(1/2) Creating Timeshift snapshot before upgrade...
Using system disk as snapshot device for creating snapshots in BTRFS mode
Mounted '/dev/nvme0n1p2' at '/run/timeshift/backup'
Creating new backup...(BTRFS)
Saving to device: /dev/nvme0n1p2, mounted at path: /run/timeshift/backup
Created directory: /run/timeshift/backup/timeshift-btrfs/snapshots/2021-09-21_10-10-56
Created subvolume snapshot: /run/timeshift/backup/timeshift-btrfs/snapshots/2021-09-21_10-10-56/@
Created control file: /run/timeshift/backup/timeshift-btrfs/snapshots/2021-09-21_10-10-56/info.json
BTRFS Snapshot saved successfully (0s)
Tagged snapshot '2021-09-21_10-10-56': ondemand

/dev/nvme0n1p2 is mounted at: /run/timeshift/backup, options: rw,relatime,compress=zstd:3,ssd,space_cache,autodefrag,subvolid=5,subvol=/

Removing snapshot: 2021-09-19_16-50-23
Deleting subvolume: @ (Id:478)
Deleted subvolume: @ (Id:478)

Destroying qgroup: 0/478
Destroyed qgroup: 0/478

Deleted directory: /run/timeshift/backup/timeshift-btrfs/snapshots/2021-09-19_16-50-23
Removed snapshot: 2021-09-19_16-50-23
(2/2) Remove DKMS modules
==> dkms remove --no-depmod -m nvidia -v 470.63.01 -k 5.14.6-1-cacule
==> depmod 5.14.6-1-cacule
:: Paketänderungen werden verarbeitet …
( 1/20) Aktualisiert wird libxcrypt                                                                     [-------------------------------------------------------------] 100%
( 2/20) Aktualisiert wird libcap                                                                        [-------------------------------------------------------------] 100%
( 3/20) Aktualisiert wird garuda-tools-base-git                                                         [-------------------------------------------------------------] 100%
( 4/20) Aktualisiert wird garuda-tools-yaml-git                                                         [-------------------------------------------------------------] 100%
( 5/20) Aktualisiert wird garuda-tools-iso-git                                                          [-------------------------------------------------------------] 100%
( 6/20) Aktualisiert wird ldb                                                                           [-------------------------------------------------------------] 100%
( 7/20) Aktualisiert wird lib32-libxcrypt                                                               [-------------------------------------------------------------] 100%
( 8/20) Aktualisiert wird vulkan-icd-loader                                                             [-------------------------------------------------------------] 100%
( 9/20) Aktualisiert wird nvidia-utils                                                                  [-------------------------------------------------------------] 100%
If you run into trouble with CUDA not being available, run nvidia-modprobe first.
(10/20) Aktualisiert wird lib32-vulkan-icd-loader                                                       [-------------------------------------------------------------] 100%
(11/20) Aktualisiert wird lib32-nvidia-utils                                                            [-------------------------------------------------------------] 100%
(12/20) Aktualisiert wird lib32-opencl-nvidia                                                           [-------------------------------------------------------------] 100%
(13/20) Aktualisiert wird libimagequant                                                                 [-------------------------------------------------------------] 100%
(14/20) Aktualisiert wird libxnvctrl                                                                    [-------------------------------------------------------------] 100%
(15/20) Aktualisiert wird nvidia-dkms                                                                   [-------------------------------------------------------------] 100%
(16/20) Aktualisiert wird nvidia-settings                                                               [-------------------------------------------------------------] 100%
(17/20) Aktualisiert wird opencl-nvidia                                                                 [-------------------------------------------------------------] 100%
(18/20) Aktualisiert wird perl-libwww                                                                   [-------------------------------------------------------------] 100%
(19/20) Aktualisiert wird smbclient                                                                     [-------------------------------------------------------------] 100%
(20/20) Aktualisiert wird samba                                                                         [-------------------------------------------------------------] 100%
:: Post-transaction-Hooks werden gestartet …
( 1/14) Creating system user accounts...
( 2/14) Reloading system manager configuration...
( 3/14) Creating temporary files...
( 4/14) Arming ConditionNeedsUpdate...
( 5/14) Install DKMS modules
==> dkms install --no-depmod -m nvidia -v 470.74 -k 5.14.6-1-cacule
==> depmod 5.14.6-1-cacule
( 6/14) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-cacule.preset: 'default'
  -> -k /boot/vmlinuz-linux-cacule -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-cacule.img
==> Starting build: 5.14.6-1-cacule
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-cacule.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-cacule.preset: 'fallback'
  -> -k /boot/vmlinuz-linux-cacule -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-cacule-fallback.img -S autodetect
==> Starting build: 5.14.6-1-cacule
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-cacule-fallback.img
==> Image generation successful
( 7/14) Warn about old perl modules
( 8/14) Foreign/AUR package notification
ascii-image-converter 1.7.1-1
( 9/14) Orphaned package notification...
=> No orphans found.
(10/14) Checking for .pacnew and .pacsave files...
.pac* files found:
Please check and merge
(11/14) Updating pkgfile database...
(12/14) Checking which packages need to be rebuilt
(13/14) Updating the desktop file MIME type cache...
(14/14) Syncing all file systems...
1 Like

No matter which OS you use an unrecoverable breakage can occur. That is why you need to start doing real comprehensive backups. A snapshot is not a proper backup solution. Don't blame the OS for your failure to do proper backups.


No problem at all.

inxi -G
Graphics:  Device-1: NVIDIA GA106 [GeForce RTX 3060] driver: nvidia v: 470.74 
           Display: x11 server: X.Org 1.20.13 driver: loaded: nvidia unloaded: modesetting resolution: 3840x2160~60Hz 
           OpenGL: renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74 
1 Like

Working find for me
boot to tty3 with Ctrl+Alt+F3 and get logs
Or bootup any older snapshot if the most recent snapshot is also not working

Hey all I had was a black screen, what the hell was I supposed to do?
I could not get to a ■■■■■■■ terminal, my screen WAS BLACK!!!!!!!!!!!!

How can one attempt to do anything when you dont even have a terminal interface to fall back on, magic?


I back up constantly, dont blame the end user when you dont know their habits.

Dont treat me like an idiot because I elected to go back to Kubuntu here, Im not some moron who doesnt know how this works.
This is not my first time with linux or even something arch based, my system broke and despite me backing up my system I could not get it to restore to a usable point its that simple.
If this wasnt my workhorse PC it would be different but I needed to resolve my issue, usually I can restore my system no sweat 99.9% of the time here and this happened to be one of those freak .1% occurrences.

I did try this but I honestly could not get past having a black screen, thus why I had to do something a little more drastic to get my linux system back here.

Since you are the umpteenth person with the problem so far, it is neither Garuda nor Nvidia.
The cause could be anything.

Have you also tried chroot?
Did you search for black screen in the forum?

It seems to me that you just want to fool around.

1 Like

Uh hello again I had a BLACK SCREEN

did you miss that part?

Do I have to use German here?


Again I could not even get a TTY session no matter what i tried to do.
Again dont treat me like an idiot, I dont appreciate it.
Look I know I said that ugly nasty swear word to an Linux elitist Kubuntu here but that doesnt mean I am some sort of moron!
I use Kubuntu mainly for stability reasons, not because I am some sort of idiot whos first step into linux is an Ubuntu derivative.
I have had 18 years of Linux experience here so please stop treating me like a novice!
How can one "fool around" when they cant get into even a TTY session huh?
Look I only tried Garuda for fun here, was getting a little bored with Kubuntu, saw this distro, and it interested me.
Again I feel I must point out this is not my first time with an arch derivative, I used Manjaro and even arch pure here from time to time.
Yes I fell back to Kubuntu but out of me needing my system back on track after my attempts to recover didnt work.
I only use it as an "in case of fire break glass" distro, and well yeah I had to use it to bring my system back.

Or in your case committed an act of heresy punishable by death because i didnt go back to garuda or arch.

A bit of search, and a lot of calm:

Note: If you can’t log in to a text console, use a chroot instead.


What does TTY have to do with chroot?
Why did you stray from the topic?
You can also grumble without TTY.

You think you know far more than you actually do. You can work from a live environment to restore your system. If you had made full backup images your system should always be restorable.

I've lost count of how many times you were asked to perform a chroot and ignored the advice. You only hear what you want to hear.



Look I have better things to do with my life right now than argue, I had an issue, I could not fix it, and so I had to make do with a fallback.
if I had more time I would try more but i honestly dont have the time.
If i try garuda again I will do a chroot but I honestly cant be bothered right now.
My system needs to work and I honestly dont care if I had to do my plan B approach or not.
Hey I have a life here outside of my linux hobby, I love linux but its not the only thing I center my life around.
Hedy at leasst i am not using windows here though frely admit to having a dualboot another crime against humanity depending who in the linux community you ask.

I think you are misinterpreting what others here have said. No one is upset about you going back to using Kubuntu in preference to Garuda. That is your prerogative, and no one really cares if you choose Kubuntu over Garuda.

What does become an annoyance after a while though is users that feel compelled to announce to the world that Garuda is too unreliable for them, so they're going back to distro "whatever". No one really cares which distro you use. If you decide your current Ford is too unreliable and are now switching to a Chevy do you also feel the need to announce this change to the world as well? Vehicles require you to perform proper maintence exactly the same as a rolling distro like Arch. If the correct maintence procedure is not done on both there will come a point when they will fail to start.

If you don't know how to perform a chroot to repair your system then that is hardly the distro's failing. Many users making these exit posts tend to blame the distro, yet there is often things the user could have done to correct their issue if they'd expended the effort. Users that feel compelled to knock the disro on their exit post unsurprisingly tend to leave a foul taste in the mouth of Garuda support assistants after a while. Generally these type of posts aren't well recieved by people who volunteer their time to assist others. What do you truthfully expect. Do you expect everyone is going to wail at your departure and get down on bended knees and beg you to stay?

If Garuda doesn't fit your needs simply leave, no one will think the worse of you. Simply go, don't turn your decision to depart into a big melodrama. Life will go on without you, but hopefully you will change your mind in the future.

All the best to you, and good luck with whatever distro you choose in the future.