Boot stuck on linux-zen

A few days ago my pc has been unable to boot to OS. Its currently getting stuck on

Loading Linux linux-zen
Loading initial ramdisk

Yesterday i was able to get into the OS by using a snapshot but that has sinse stopped working. Now im getting the following error when clicking on a snapshot. (below)

Error: file '/@/boot/intel-ucode.img^/@/boot/initramfs-linux-zen.img' not found. (hopefully no typos as i had to type this myself)

Does anyone have any ideas on how i can fix this? if anyone has any ideas please let me know. Warning i am still new to Linux i switched over about 2 months ago.

Also if this means anything im duel booting windows 10 and it works perfectly fine.

Hi there, welcome.
This is the reference tutorial in this case.
Most likely you can start directory with the chroot from live USB andupdate.


Windows may have messed up your boot.




The easier way to chroot is to boot into a Garuda live USB and do a grub repair from within Garuda Assistant. Then run grub-update.

You may also want to reinstall the Zen kernel from the chroot:

pacman -Syu linux-zen linux-zen-headers

when attempting sudo media/mnt I get File exists. Should I overwrite that? If so how should I do that?

When trying number 2 i get
sudogrub-probe: error cannot find grub device for /dev/sdc1. check your

Since you're doing this from the live USB, with connectivity, it would be great if you could paste here the full input / output, to get the complete picture.


When opening Chroot i get this error PrivateBin

at the bottom is when i type the following

sudo mkdir /mnt
sudo mount /dev/sdxy /mnt
sudo garuda-chroot /mnt/@

for - How to chroot Garuda Linux

One issue im having is im not sure how to find the device that holds MBR

Instead of using the chroot button, which is probably generating that error, try to follow carefully the tutorial "how to chroot garuda linux".
Boot from the live USB and open a terminal (do not use the chroot button).
sudo mkdir /mnt/broken
Otherwise /mnt alone already exists.
Do not use /dev/sdxy, that's only an example.
Check your disk with lsblk -f as instructed in the guide to identify the system partition to mount.
There are also indications to verify if your system is in UEFI or legacy mode.

Edit: looking more carefully into your privatebin, I think the chroot actually worked! You didn't need the additional commands to do it manually.
See that you were root # in your installed system partition /dev/nvme1n1p2
Do that again and proceed with the suggestions in the previous posts.


Sorry for the late reply but sadly this did not work. At this point im thinking about resetting my PC. Just one question if you don't mind, is their a way to gain access to the root folder so i can transfer the contents to another drive?

Chroot provides this access. It changes the root the shell is working in to the device you specified. Once here, you should be able to access any part of the system you like.


I did get an error when attempting pacman -Syu reinstall grub-efi-amd64 I have an intel cpu so i also changed it to intel64 but no change.

Im going back and retrying the very first solution posted here sudo reflector -a6 -f5 --save /etc/pacman.d/mirrorlist im getting a repeating error PrivateBin

as well as sudo dkms autoinstall I don't remember if i got this the first time i tried

Where did you get this? This is wrong.
Once again, try to stick to the tutorial. It worked for so many people...

Select the proper $esp partition (you may check your /etc/fstab if you are not sure) and mount it inside chroot

mount /dev/nvme0n1p4 /boot/efi

Then install grub bootloader and update grub

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck

Do not forget to exit chroot normally, before you close the terminal

Exit the chroot session

1 Like

I tried doing this yesterday but it did not solve the issue. I redid it today so i could grab the logs.

OK. So the grub installation and update-grub were succesful.
I guess you tried to reboot and got the same error?

Installing for x86_64-efi platform.
Installation finished. No error reported.
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda-dr460nized/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot: intel-ucode.img initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot: intel-ucode.img initramfs-linux-fallback.img

I've also put in bold the files which were not found.
Don't care about this. It is related to the USB drive itself...

grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your

Now you could try chrooting again and

pacman -Syu linux-zen linux-zen-headers
1 Like

If the suggestion above still does not work, I have another idea.
Your error message is:

Error: file '/@/boot/intel-ucode.img^/@/boot/initramfs-linux-zen.img' not found

While in the update-grub output I can see:

Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img

You see, there is a ^ instead of a space.
I've found something similar here:

Maybe, you could

sudo micro /boot/grub/grub.cfg

search that string and replace the ^ with a space.
If it works, this could be overwritten by the next update-grub, but we'll see that later...
The solution should be the one in the link above:

sudo micro /etc/grub.d/30_os-prober 

replace in line 213

LINITRD="`echo ${LINUX} | cut -d ':' -f 5`"


LINITRD="`echo ${LINUX} | cut -d ':' -f 5 | tr '^' ' '`"

and finally

sudo update-grub

From your log:

Error! Your kernel headers for kernel 5.15.5-zen1-1-zen cannot be found at /usr/lib/modules/5.15.5-zen1-1-zen/build or /usr/lib/modules/5.15.5-zen1-1-zen/source.
Please install the linux-headers-5.15.5-zen1-1-zen package or use the --kernelsourcedir option to tell DKMS where it's located.

Reinstall zen kernel &headers.

1 Like

this is the output from
pacman -Syu linux-zen linux-zen-headers

trying the rest rn

Encrypted, requires password^^^

I don't believe i put one, Well i have zero clue what the password is

Ill post an updated one in a few minutes

Grub.cfg doesnt have intel-ucode.img^. I replace the text in in 213 then tried updating.

I cant seem to find a way of copying the grub.cfg

I don't see anything wrong in the linux-zen and headers installation.
There are some errors for the snapshot part, but I think that's normal in the chroot.
I'd reconsider the other solution above on the ^ problem...
A PrivateBin more :slight_smile: could be for /boot/grub/grub.cfg

1 Like