Whole system runs sluggish, game are stuttering, gamesound is hicking


i don't really know how to start and i hope i can find some help here. This issue is super vague and i don't know where to start looking...

Since yesterday, out of the blue, my system started to become sluggish and slow. Kinda. I did not install anything new, no system upgrade, no new game or anything.

When i wanted to open my console, it took longer than usual. But once i openend the console and closed it, it would open as quick as usual when i tried again. Until i opened a different app. That app would take longer than usual. To conclude this. When i open e.g. Dolphin and no other dolphin session is running right now, it's slow. Like 2-3 seconds. Once i opened it and have not opened another new app in the meantime. It will open instantly. Same goes for every other app on my system right now.

But the much bigger issue, is that i observed that all my games are hicky and sluggish aswell. Regular framedrops, the sound is really stuttering.

Since then i have updated my system, rebooted multiple times, turned the PC off and pulled the powerchord for an hour or so to maybe reset some chipsets...To no avail.

I then started to go through all the apps i autostart at boot and disabled them so i start with nothing from my personal list but only system tools. No avail. I reinstalled wireplumber and pipewire because i thought those are maybe the culprit for atleast the game issues. Also no avail.

I don't really know what to do anymore. My system is kinda bloated and i use a lot of stuff...But it worked perfectly fine all the time, and all of a sudden it didn't ... so i don't think that the number of apps i use are the real issue here, but rather some new incompatibility or something.

Can someone help me troubleshoot this a bit better?

  Kernel: 5.19.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=c3ef0d61-a4ef-469b-96b1-b7a7583d021e rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 info: latte-dock, polybar
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
    serial: <superuser required> BIOS: American Megatrends v: 4801
    date: 03/02/2022
  Info: model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ gen: 2
    level: v3 built: 2018-21 process: GF 12nm family: 0x17 (23) model-id: 8
    stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 3987 high: 4003 min/max: 2200/3600 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3992 2: 3992
    3: 3992 4: 3971 5: 4000 6: 3989 7: 4003 8: 3992 9: 3977 10: 3983 11: 3983
    12: 3973 bogomips: 86234
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA104 [GeForce RTX 3070] vendor: ASUSTeK driver: nvidia
    v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current
    (as of 2022-08) arch: Ampere code: GAxxx process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 09:00.0 chip-ID: 10de:2484
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositors: 1: kwin_x11 2: Picom v: git-f70d0 driver: X: loaded: nvidia
    gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4520x1920 s-dpi: 51 s-size: 2251x301mm (88.62x11.85")
    s-diag: 2271mm (89.41")
  Monitor-1: DP-2 pos: primary,top-left res: 1080x1920 hz: 60 dpi: 92
    size: 299x531mm (11.77x20.91") diag: 609mm (23.99") modes: N/A
  Monitor-2: DP-4 pos: primary,bottom-r res: 3440x1440 dpi: 109
    size: 800x330mm (31.5x12.99") diag: 865mm (34.07") modes: N/A
  OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.65.01 direct render: Yes
  Device-1: NVIDIA GA104 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 09:00.1
    chip-ID: 10de:228b class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0c:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Sound Server-1: ALSA v: k5.19.9-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.58 running: yes
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 04:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
  Device-1: ASUSTek Broadcom BCM20702A0 Bluetooth type: USB driver: btusb
    v: 0.8 bus-ID: 3-2.1.1:4 chip-ID: 0b05:17cb class-ID: fe01 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
  Local Storage: total: 2.39 TiB used: 991.42 GiB (40.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
    model: HFM256GDHTNG-8310A size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
    rev: 80070C00 temp: 42.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:2 vendor: Samsung model: SSD 970 EVO
    250GB size: 232.89 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 1B2QEXE7
    temp: 58.9 C scheme: MBR
  ID-3: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: 033 scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SDSSDP128G
    size: 117.38 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> scheme: GPT
  ID-5: /dev/sdc maj-min: 8:32 vendor: Samsung model: HD103SI
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: N/A serial: <filter> rev: 1118 scheme: MBR
  ID-1: / raw-size: 232.88 GiB size: 232.88 GiB (100.00%) used: 129.65 GiB
    (55.7%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:3
  ID-2: /home raw-size: 232.88 GiB size: 232.88 GiB (100.00%) used: 129.65
    GiB (55.7%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:3
  ID-3: /var/log raw-size: 232.88 GiB size: 232.88 GiB (100.00%) used: 129.65
    GiB (55.7%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:3
  ID-4: /var/tmp raw-size: 232.88 GiB size: 232.88 GiB (100.00%) used: 129.65
    GiB (55.7%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:3
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.54 GiB used: 4.54 GiB (29.2%)
    priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 57.0 C mobo: 48.0 C gpu: nvidia temp: 47 C
  Fan Speeds (RPM): cpu: 1496 case-1: 1049 case-2: 0 case-3: 0 gpu: nvidia
    fan: 0%
  Power: 12v: 9.92 5v: N/A 3.3v: N/A vbat: 3.21
  Processes: 427 Uptime: 24m wakeups: 0 Memory: 15.54 GiB used: 6.55 GiB
  (42.1%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 alt: 11 clang: 14.0.6 Packages: 2163 pm: pacman
  pkgs: 2151 libs: 553 tools: pamac,paru pm: flatpak pkgs: 12 Shell: fish
  v: 3.5.1 running-in: alacritty inxi: 3.3.21
Garuda (2.6.7-1):
  System install date:     2022-09-16
  Last full system update: 2022-09-17 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:            systemd-networkd-wait-online.service

Oh also i booted into memtest86+ and let it check my system. Everything seems to be in top condition there

You could start working with this troubleshooting guide

Given that

I'd consider especially the steps focused on disk status, btrfs check, balancing, etc.
But there's also a lot of other stuff...


Alright, switching to the 5.19.9-arch1-1 kernel seems to fixed it

wondering why though. Well it runs as good as it did under zen, so i don't think i miss it? Let's see.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.