Load over the CPU is too High | SLOW Response | Freezing | Hang | Crash

  1. Even on usual daily basis, CPU Load will be too High even for very small tasks.
    And everytime, booting takes more time than usual, and after logging in it takes much more time to bring up all panels and all other stuff.
  2. Fan runs in high speed with noise all the time, even may be GPU.
  3. Ram may or may not be high everytime usually [ I can't add this in list for now, but if i get any suggestion, u r welcome :)]
  4. System Freezes more oftenly many times literally almost everytime (which i can't bear everytime, and i never face this on other version/variants/other distro...... This freezing of system was not to this extent when i was using kde ultimate, it would sometimes give latte-dock crash thats it. But now this will hit its high level everytime whenever it is when i even open or do any literally any very small process too. Sometimes either that particular process wil end automatically (and I do loose my data/progress in that) or sometimes entire system will hang for a very long time, which sometimes makes me impatient :frowning:
  5. Once the entire system went wrong to an extent that, each n everywhere i should see blur effect, it was converted to other colours (for example latte-dock panel became orange, terminal became black, similarly others..) and it never returned back to its original state wtever i tried, hence i had to reinstall system bcoz i was busy on a work and didnt had time to debug nor raise it here. And according to me, what i got as the reason was system hitting 100% and getting over loaded even for small task (example: I played a video which actually went through full screen and as i restored the size, the panel at the top became orange, but for my luck, it returned back with some seconds) Thank you for any solutions i receive below :slightly_smiling_face:

System info: Laptop | 8GB Ram | 1TB | Nvidia Graphics 4GB | Garuda KDE Dr460nized Gaming (up to date)

Hi,

This is quite normal as things like ZRAM and preload are used.

Often suggested as first step is changing kernel by installing linux-lts for example to cross out the kernel being culprit. In fact I recently found out that current kernel versions cause incredible annoying graphic bugs for me.
Also we could need proper system information given by inxi as the current specs you posted could be literally anything.

1 Like

Changing kernels is one of the easiest troubleshooting steps you can perform and it resolves far more issues than you'd ever expect. Whenever you start to experience unusual issues with your system, the first thing you should do is test at least three alternate kernels. For those experiencing severe system freezes/crashes testing out alternate kernels should always be your fist step.

You can install an alternate kernel from the terminal using any of the following commands:

sudo pacman -Syu linux-lts linux-lts-headers
sudo pacman -Syu linux linux-headers
sudo pacman -Syu linux-zen linux-zen-headers
sudo pacman -Syu linux-mainline linux-mainline-headers
sudo pacman -Syu linux-hardened linux-hardened-headers
sudo pacman -Syu linux-rt linux-rt-headers

I would suggest starting at the top of the list and working your way down if your issues haven't improved.

You can switch to a newly installed kernel after a reboot via the grub "Advanced" boot menu. Simply choose the kernel you wish to boot into from the choices listed. You only need to select the fallback kernel choice if your other other installed kernels are severely problematic. After installing a new kernel it is best not to uninstall your old kernel. It is always best to have at least two kernels installed in case one kernel experiences a problem booting. The LTS kernel is the recommended choice to keep installed as a backup kernel.

It would be best to perform an extensive search of the forum for other solutions if a kernel change does not fix your problem.

Note:

For those that have tested multiple different kernels and they are still experiencing freezes there is one more thing you could try. Sometimes a kernel change alone will not resolve some stubborn freezing problems. In these cases it is a good idea to also test out different I/O schedulers. Some kernel versions come preconfigured with custom I/O schedulers, or you can manully change this your self.

4 Likes

Look at the output of top (or htop) to see which applications are using large amounts of CPU time.

If you play a 1080p video from YouTube without hardware acceleration then that will use a large amount of CPU time.

This is not useful information. Post the output of inxi -Fxxxz (as text) to provide useful information.

You might also want to do some quick research around troubleshooting Linux performance issues as these are useful skills to learn.

2 Likes

well, i too don't wanted to raise ram as a issue for now:)

sure, I'll try this.
And wt if i have many kernels, as u said to keep 2, and wt if i get issue solved after trying many and keep all!?

I've seen, but i couldn't make out what was the actual thing which caused high usage, bcoz each n everytime i do any new task, it hits the high and its not just bcoz of any single thing which i can find it out.

i got this issue for videos that are in my disk. But this happened not just for video, but freezed also other tasks.

inxi -Fxxxz
System:
  Kernel: 5.10.15-120-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.1
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM
  Distro: Garuda Linux
Machine:
  Type: Laptop System: LENOVO product: 80YL v: Lenovo ideapad 520-15IKB
  serial: <filter> Chassis: type: 10 v: Lenovo ideapad 520-15IKB serial: <filter>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40688 WIN serial: <filter> UEFI: LENOVO
  v: 4WCN46WW date: 12/30/2019
Battery:
  ID-1: BAT0 charge: 19.8 Wh condition: 24.6/35.3 Wh (70%) volts: 7.5/7.6
  model: CPT-COS L16C2PB1 type: Li-poly serial: <filter> status: Discharging
CPU:
  Info: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP
  arch: Amber/Kaby Lake note: check rev: 9 L2 cache: 4 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23220
  Speed: 400 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 400 2: 400 3: 401
  4: 400
Graphics:
  Device-1: Intel HD Graphics 620 vendor: Lenovo driver: i915 v: kernel
  bus ID: 00:02.0 chip ID: 8086:5916 class ID: 0300
  Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Lenovo driver: nvidia v: 460.39
  bus ID: 01:00.0 chip ID: 10de:134d class ID: 0302
  Device-3: Syntek EasyCamera type: USB driver: uvcvideo bus ID: 1-8:4
  chip ID: 174f:241a class ID: 0e02
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver:
  loaded: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa
  resolution: 1920x1080~60Hz s-dpi: 96
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.4
  direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel
  v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 class ID: 0403
  Sound Server: ALSA v: k5.10.15-120-tkg-bmq
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo
  driver: r8169 v: kernel port: 3000 bus ID: 02:00.0 chip ID: 10ec:8168
  class ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
  vendor: Lenovo driver: ath10k_pci v: kernel port: 3000 bus ID: 03:00.0
  chip ID: 168c:003e class ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-3: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb
  bus ID: 1-7:3 chip ID: 0cf3:e300 class ID: e001
Bluetooth:
  Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb v: 0.8
  bus ID: 1-7:3 chip ID: 0cf3:e300 class ID: e001
  Message: Required tool hciconfig not installed. Check --recommends
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0
  port: 5060 bus ID: 00:17.0 chip ID: 8086.282a rev: 21
Drives:
  Local Storage: total: 931.51 GiB used: 19.08 GiB (2.0%)
  ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-08Z10 size: 931.51 GiB
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A05 scheme: GPT
Partition:
  ID-1: / size: 150 GiB used: 19.05 GiB (12.7%) fs: btrfs dev: /dev/sda7
  ID-2: /boot/efi size: 96 MiB used: 25.8 MiB (26.8%) fs: vfat dev: /dev/sda1
  ID-3: /home size: 150 GiB used: 19.05 GiB (12.7%) fs: btrfs dev: /dev/sda7
  ID-4: /var/log size: 150 GiB used: 19.05 GiB (12.7%) fs: btrfs dev: /dev/sda7
  ID-5: /var/tmp size: 150 GiB used: 19.05 GiB (12.7%) fs: btrfs dev: /dev/sda7
Swap:
  ID-1: swap-1 type: zram size: 1.89 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram0
  ID-2: swap-2 type: zram size: 1.89 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram1
  ID-3: swap-3 type: zram size: 1.89 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram2
  ID-4: swap-4 type: zram size: 1.89 GiB used: 0 KiB (0.0%) priority: 32767
  dev: /dev/zram3
Sensors:
  System Temperatures: cpu: 44.5 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 229 Uptime: 20m wakeups: 1 Memory: 7.56 GiB used: 3.14 GiB (41.5%)
  Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 1585 Shell: fish
  v: 3.1.2 running in: alacritty inxi: 3.3.01

Remove auto-cpufreq

sudo pacman -R auto-cpufreq-git

And reboot

Since your laptop has base frequency of 400mhz

On powersave governor it crawls

Auto-cpufreq sets governor to powersave on battery

Sure I'll try it now asap

Well, I just did it, and after boot and logging in, it still took more than 30seconds to show up everything else than desktop background, and still when i opened browser, it went upto 80%load over cpu and when i opened another, it almost hit 100% again n came back after some seconds

well, its not just on battery but also freezes while on AC power

Please try changing the brtfs mount parameters in /etc/fstab, for me this solved the problem! Have a nice day! (from commit=120 0 2 to 15 0 2 for all brtfs partitions)

1 Like

i didnt get how its related here, nor wt to do clearly!

literally i'm not getting any thoughts on what to do exactly, by seeing everything all these n researches made me confused a lot:(
I'd be really thankful if anybody can explain me n give me a clear cut straightforward solutions:)

BTW these r not at all found in pacman.

There are no such thing as a "magic solution" to an ill-defined or transient issue.

Are you running Garuda?

Keep in mind that this is an international forum and people will use translation software. "1337speek" or "textspeak" creates artificial barriers to people understanding you. This is forum software, not chat or text messaging, so you are free to use full words to make yourself easily understood.

8 Likes

Not only that, but full words and complete sentences illustrate that you are treating the problem(s) in a rational manner. In my humble opinion, others may be more stimulated to help you if you do so.

What I like about our forums are that we can have fun where appropriate, or help trouble-shoot singular or common issues in a calm, non-mechanical manner.

Most often problems and resolutions are already known, so it is just a matter of pointing to them. Sometimes it is a process of, "Try A, try B, try C" etcetera until something finally works.

So please, everyone new to Garuda or Linux: We are a self-supporting group. We like helping others to experience Linux because that is how Linux-loving people operate. We like self-starters best, but we can accommodate anyone--to a point.

And sometimes I wish I could better practice what I preach. :wink:

8 Likes

well i too dont know whats doing so, nor i have any idea to find more about it, but if there is more info that i can give, then I'll for sure if asked for...

Ofcourse, this can never be a question for whoever posting issues in garuda forum :joy: :sweat_smile:
and i did mention my os :slight_smile:

and sorry for the inconvinience with my language, I'll surely use the needful goin on :slight_smile:

and what i now experienced is, whenever i start any game, though it didnt touch 100% cpu load but still all the blur effect were mismatched :frowning:
and sometimes yet cpu touches 100% when i open any new tasks and then too this blur effect will mismatch by taking other colours

Thanks for this, Ive been experiencing some freezes too,
when an application freezes (defunct), I tried to kill the process, but then the terminal freezes.
Revolting in a cold reboot.

But will check it out with another Kernel.

By the way you forgot to put some - between linux-lts and headers

sudo pacman -Syu linux-lts linux-lts-headers
sudo pacman -Syu linux-zen linux-zen-headers

Ya thanks, that was more likely my phones spell checker. It often messes with anything using a "-".

I will edit out the syntax errors where they occur.

Had the same problem, did the fix provided by @ServoGamer and it worked really well. I use to open one Chromium Tab and the complete system would enter in disk-sleep state. Now, on mid loads, like opening 5+ tabs at the same time does have a ~1 second freeze but it is nothing that feels ugly as before.

2 Likes

Thanks for posting back the information that fix helped.

4 Likes