Unscheduled reboots/crashes and unsure how to diagnose issues without trends/patterns

I've been using Garuda for a few months. Its amazing in every way. The only issue I've had with anything out of the box is a mysterious and infrequent bug where my pc reboots or crashes(ie no post or wakeup possible) when I'm away from the computer. I've never actively caught it rebooting so I theorize that the issue is with the sleep settings? I'm mostly reaching here though. I've been saving the journalctl logs each time it happens to find trends/patterns but have had no luck.

I have not tried much at all to resolve the issue, as I feel silly trying to fix a problem I can't wholly identify. But have tried
1.) Installing xscreensaver and adjusting a few settings to prove if it was a sleep issue. No luck.
2.) Posting on reddit how to ask for help with such limited knowledge. It was removed immediately due to help flair I suppose.
3.) Daily garuda-update with prayers each time.
4.) I have done fresh reinstalls a few times already because the first few times I encountered the issue, I assumed I had tampered with config files too much. My current install I have been very careful to not alter much of anything so I feel less guilty for the situation.

I am primarily looking for advice on how to structure a path toward diagnosing the issue. It blows my mind at how far I've pushed this machine on garuda (lots of gaming) with no crashes, but somehow idling just breaks the whole thing and forces a reboot. My motherboard being 5 years old shouldn't raise suspicions, right? I really prefer fixing ish myself, but have been stuck here with no ideas going forward for a few days now...

I am willing to investigate any and all ideas with great appreciation!

╰─λ garuda-inxi
System:
Kernel: 5.18.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=3cd49b86-109a-414c-83ab-7284e660632f rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=aed0cb22-d9f7-4fe6-82c6-fbbe92d2b4f6 loglevel=3
Desktop: KDE Plasma v: 5.25.2 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: AB350M-HDV serial: <superuser required>
UEFI-[Legacy]: American Megatrends v: P1.30 date: 03/20/2017
CPU:
Info: model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen
built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1 stepping: 1
microcode: 0x800110E
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3002 high: 3559 min/max: 1550/3200 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3005 2: 2935
3: 2806 4: 2731 5: 2726 6: 2891 7: 3027 8: 2956 9: 3316 10: 3230 11: 2848
12: 3559 bogomips: 76657
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: PNY driver: nvidia
v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-06) arch: Pascal process: TSMC 16nm
built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
speed: 8 GT/s bus-ID: 0a:00.0 chip-ID: 10de:1b81 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x342mm (23.70x13.46")
s-diag: 692mm (27.26")
Monitor-1: DP-0 res: 2560x1440 hz: 60 dpi: 109
size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2
v: 4.6.0 NVIDIA 515.48.07 direct render: Yes
Audio:
Device-1: NVIDIA GP104 High Definition Audio vendor: PNY
driver: snd_hda_intel v: kernel bus-ID: 1-7:3 pcie: chip-ID: 1532:0510
gen: 3 class-ID: 0300 serial: <filter> speed: 8 GT/s lanes: 16
bus-ID: 0a:00.1 chip-ID: 10de:10f0 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 12:00.3
chip-ID: 1022:1457 class-ID: 0403
Device-3: Razer USA Kraken 7.1 V2 type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.18.7-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter driver: wl
v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 08:00.0 chip-ID: 14e4:43a0 class-ID: 0280
IF: wls1 state: dormant mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 09:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 698.65 GiB used: 114.74 GiB (16.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 250GB
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 4B6Q scheme: MBR
Partition:
ID-1: / raw-size: 448.62 GiB size: 448.62 GiB (100.00%)
used: 114.74 GiB (25.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-2: /home raw-size: 448.62 GiB size: 448.62 GiB (100.00%)
used: 114.74 GiB (25.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-3: /var/log raw-size: 448.62 GiB size: 448.62 GiB (100.00%)
used: 114.74 GiB (25.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-4: /var/tmp raw-size: 448.62 GiB size: 448.62 GiB (100.00%)
used: 114.74 GiB (25.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.58 GiB used: 1.8 MiB (0.0%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.13 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdb2 maj-min: 8:18
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 57 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 324 Uptime: 7h 32m wakeups: 0 Memory: 15.58 GiB
used: 4.12 GiB (26.4%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1897
lib: 544 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.19
Garuda (2.6.4-2):
System install date:     2022-06-23
Last full system update: 2022-06-30 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

Try running a memtest.

Edit: Also look into your bluetooth settings. There is a failed unit reporting there.

2 Likes

I don't have a Bluetooth adapter of anykind, so I'm assuming that failed unit will simply stay in a failed state no matter what.

I am currently researching memtest as I noticed there are 3 version to chose from in octopi

No memtest in grub?

1 Like

No its there I forgot you have to reboot to get to that lool
Trying it now

1 Like

disable this with the garuda assistant under system components

2 Likes

Will turn off bluetooth after memtest and see what the highest uptime I can achieve.

Is a memtest supposed to take longer than 30 min? No errors yet, but I'm nervous why it's taking so long lol

1 Like

memtest is slow.... no worries.

2 Likes

The first things to test are a bios update and different kernels.

Here's some more troubleshooting ideas for you:

5 Likes

I let memtest run for a little over 10 hours. 4 passes and 0 errors reported. I think this is good enough for now. I will run longer if necessary though

I am moving on to bios troubleshooting. I cannot lie, I have very little experience with this and will probably be moving a little slow so as to not make more problems, because occasional crash is much better than more reinstalls lol

1 Like

Are there updates for your 2017 BIOS?

BIOS updates tend to fix/repair/reset a myriad of hardware issues.

That is why they exist.

3 Likes

I assumed bios updates weren't an issue because I was using Windows on this machine until January of this year and I figured Windows was updating it for me. :clown_face:

I've been trying to reboot into my bios, but now I don't get a post at all lol my monitor powers on but nothing else...

Yeah I'm at a new stage of troubleshooting I guess. My new goal is to get pretty much anything but a blank screen to show up on power up. I'm also leaning towards just reinstalling windows if I can't get a post soon

1 Like

I booted into the bios setup interface but did not find any options for updates at all. So I'm currently on the search for how to update a 2017 BIOS from Asrock but not really finding any info worth trying.

I did finally get my monitor to post by unplugging/replugging the power to the display monitor but I have broken more things. The bottom drawer of apps is gone and the windows key doesn't activate anything now lol I think that was the latte-dock.

Krunner opens with alt+F2 so I guess I'll use that instead for the time being.

1 Like

Read
(How to Update)

Each problem needs own thread, but if you search in forum you will find solutions for missing latte dock and how to fix the M$ button to open the app launcher.

8 Likes

Every BIOS manufacturer seems to have a different means of accessing and updating. @SGS has just shown you a valuable tool. If it were me, I'd run with it. :wink:

6 Likes

I have to go into work early on fridays so I'm already late, but I will be firing the cannons on both of these recs soon I promise. THank you for the legwork friend, I am silly and thought asrock would be all proprietary no disclosure/help type

2 Likes

And I could be all wrong. It may not be the BIOS. But I learned one troubleshooting tool in the 50 years since I became a journeyman electrician. Go to where it stops and where it starts; the problem lies somewhere in between. That has never failed me. Your machine is new enough that a BIOS update would be in my first list of candidates. By the process of elimination, we can solve anything solvable. (Or so they told me.)

I was also a journeyman plumber but I'd rather forget those days. Shit runs downhill, payday is Friday. And never chew your fingernails. They forgot to tell me that last one. I suspect it was for a reason.

6 Likes

It seems I was correct and asrock is as useless as I thought. I followed both procedures to update bios but was rife with failure at every attempt. No matter what I tried, I ended up stuck at the Instant flash step with the error message 'No image file detected.' Seems this is my sad trip to the store to buy another windows usb stick....

I do appreciate everyone's help though :nerd_face:

Proof that I had the files on the correctly fat32 formatted USB both extracted and unextracted but same error occured no matter what USB port I used:

2 Likes

Are you sure you are not supposed to unzip that file first? What format is it expecting to find? What did the "How To Update" say to do? What were the specific instructions?

EDITED

You did not follow the instructions. Extract (unzip) the file, etc.
https://www.asrock.com/support/BIOSIG.asp?cat=BIOS10

### Method 1:

1. Please extract the zip file after downloading the BIOS rom file from ASRock website.
2. Save the BIOS files on a FAT32 formatted USB disk.
3. Press [F2] during POST to get into BIOS setup menu.
4. Select the Instant Flash utility under [Tool] menu to execute it.
3 Likes

The image posted in my last reply was my way of showing I included the extracted (unzipped) file named 'AB35HDV6.20'

To be specific, I tried both F2 and F6 methods listed in asrock link as well.