System constantly crashing

I used to not have this problem, but my system now crashes about 5x a day. It even crashed in the middle of an update which completely changed the overall layout of my terminal. My terminal is now completely plain, just like after a vanilla arch install. If I run neofetch, I get the G in colors that resemble the Indian flag. Orange, white, and green.

Secondary issue that might be related, after input of sudo pacman -Syu, I get this

error: failed retrieving file 'chaotic-aur.db' from : Failed to connect to port 443 after 47 ms: Connection refused

THIRD ISSUE, after my system crashes and restarts, my laptop stops charging. I have to shut the computer down, unplug the cable, and plug it back in when my computer is off, THEN turn it back on. Otherwise it will not charge. My computer is a Dell XPS 15 9500.

 λ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 chaotic-aur                          1706.3 KiB  2.52 MiB/s 00:01 [------------------------------------] 100%
error: failed retrieving file 'chaotic-aur.db' from : Failed to connect to port 443 after 35 ms: Connection refused
:: Starting full system upgrade...
 there is nothing to do

EDIT: here's the textual output

λ garuda-inxi
  Kernel: 5.17.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=5d0daf37-2fd1-4f15-983f-f88071f25b91 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 15 9500 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 05XYW7 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.11.0 date: 11/12/2021
  ID-1: BAT0 charge: 75.7 Wh (96.3%) condition: 78.6/84.3 Wh (93.2%)
    volts: 12.9 min: 11.4 model: SMP DELL 70N2F95 type: Li-poly
    serial: <filter> status: charging
  Info: model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake
    family: 6 model-id: 0xA5 (165) stepping: 2 microcode: 0xEC
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 800 min/max: 800/5000 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 9: 800 10: 800 11: 800 12: 800 bogomips: 62399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Dell driver: i915
    v: kernel ports: active: eDP-1 empty: DP-1,DP-2,DP-3 bus-ID: 00:02.0
    chip-ID: 8086:9bc4 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Dell
    driver: nvidia v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 3
    speed: 8 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:1f95 class-ID: 0302
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-11:5 chip-ID: 0c45:6d14 class-ID: 0e02
  Device-4: USB C Video Adaptor type: USB driver: N/A bus-ID: 1-4.3:6
    chip-ID: 25a4:9311 class-ID: 1100 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.00x12.48")
    s-diag: 599mm (23.57")
  Monitor-1: eDP-1 model: Sharp 0x14d1 built: 2020 res: 1920x1200 hz: 60
    dpi: 145 gamma: 1.2 size: 336x210mm (13.23x8.27") diag: 396mm (15.6")
    ratio: 16:10 modes: 1920x1200
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 22.0.1
    direct render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:06c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.1-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.49 running: yes
  Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-14:7 chip-ID: 8087:0026 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
  Local Storage: total: 476.94 GiB used: 27.46 GiB (5.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN730 NVMe WDC 512GB size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 11170012 temp: 35.9 C scheme: GPT
  ID-1: / raw-size: 211.83 GiB size: 211.83 GiB (100.00%)
    used: 27.36 GiB (12.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 650 MiB size: 646 MiB (99.38%)
    used: 103.9 MiB (16.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 211.83 GiB size: 211.83 GiB (100.00%)
    used: 27.36 GiB (12.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 211.83 GiB size: 211.83 GiB (100.00%)
    used: 27.36 GiB (12.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-5: /var/tmp raw-size: 211.83 GiB size: 211.83 GiB (100.00%)
    used: 27.36 GiB (12.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-2: swap-2 type: zram size: 15.37 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 53.0 C pch: 43.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0 fan-2: 0
  Processes: 299 Uptime: 17m wakeups: 4245 Memory: 15.38 GiB
  used: 3.21 GiB (20.9%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1274 lib: 339 Shell: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.1-1):
  System install date:     2022-02-22
  Last full system update: 2022-04-13 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper (maybe)
  Failed units:

Hi there, welcome.
First of all, we'll need the textual output of your garuda-inxi, as per new topic template.
Second, you could try garuda-update rather than sudo pacman -Syu, since it executes a lot of other useful tasks, like refreshing your mirrors.
Finally, you should try to focus on an issue per topic, otherwise it gets more and more complicated


Hi there and welcome to the Garuda Forum :smiley:

...and @filo has already taken my words out from my mouth :rofl:


Welcome :slight_smile:

I just edit your post.

Please read

BTW, I use ~~~ instead ``` its easier on my keyboard. :slight_smile:


It might be easier to roll back to a snapshot than to try to get out of your interrupted-upgrade brokenness.

The trick is trying to identify what changed between then and now. If you are having that many crashes per day and you aren't doing anything odd with your computer my first suspicion would be hardware.

Try to work through TBG's link and make notes as you investigate. Update the thread with your notes, even if your discoveries do not reveal the problem--you never know when a seemingly innocuous detail might stand out to another person in the forum.


What exactly do you mean by "crash"? Does the session freeze, do you get sent back to login screen, does screen turn black, is caps lock blinking, do you lose power entirely etc.

Could you try a different charger or battery?


My screen will go black and the computer will restart. I lose power entirely. I don't think it's the charger or battery. This computer is only a year old. If I simply unplug and plug the charger back in while Garuda is running, it won't charge. I have to turn the computer off, then plug the charger in, and then it works fine. It's something software related, as opposed to hardware.

Thanks. Sorry, I'm new here. I tried garuda-update multiple times and it seemingly refreshed the mirrors but I'm still having the issue with chaotic-aur.

Wacky. Have you enabled any performance or powersave tweaks in the Garuda assistant? That might be a long shot, but worth checking if any are causing problems.

Does using a different kernel change the behavior at all? (Garuda Settings Manager will handle this, try linux-lts first probably.)

Do you recall changing anything in your BIOS? Could be something there interfering if you've made a recent change.

Not really sure on this, does the "refresh databases" option in Pamac do anything different? The Assistant also has some other options, refreshing the keyrings specifically might be something to try. Maybe just taking a look at /etc/pacman.d/chaotic-mirrorlist to see if anything stands out, or removing the specific entry pacman is failing to pull? Like I said, not sure.

No sweat! IMO, the learning experience is one of the most valuable parts of Linux if you take it as such, and people are usually happy to help if you're also working at it! As mentioned, the guide linked by tbg is very good, and the recommendation by BluishHumility of taking notes as you go is, at least for me, one of the most important practices/tools when going at an issue like this. I do find it hard to keep straight sometimes with longer troubleshooting endeavors so I'll split it into two - one rambling log, newline for each step, no formatting, paste relevant links, and then another where I go through what I've tried recently from time to time and pare it down to brief, specific notes. This way, I've got something readable to bring to the forum. Not necessary to go fancy with it, but :person_shrugging:

Keep at it, keep us updated, and welcome to the forum!


Do you have charging related settings in UEFI like flexicharge? Can you disable that?

1 Like

This sounds more like a hardware issue. The easiest way to discount hardware is to boot from a Garuda live disk and see if the issue is present. If the issue is still present, boot from an Ubuntu disk. If the issue is present only with Garuda then it is likely a kernel or Garuda configuration problem. If the issue presents on both a Garuda and Ubuntu live environment then that points to hardware being the cause.


I have windows, arch, and garuda all installed on this laptop. Admittedly, these issues didn't arise until after I re-installed garuda (due to having issues with the chaotic-aur thing). After I installed garuda the second time, I started having these issues. I will hang out in arch for a few days and see if the system crashes or has issues with not charging.

I don't think so. The only things I changed in the bios were that I disabled secure boot and changed the storage format to AHCI. I haven't tampered with the charge settings in any way. I only have charging issues after the system crashes. When it crashes I have to shut the computer off a 2nd time and plug the cable in while it's off, then it starts charging again.

UPDATE: after hanging out in arch for a day, my system crashed. It is an issue with my computer/configuration and not a problem with Garuda. Sorry everyone. It looks like my only remaining unsolved problem is that I can't get the chaotic-aur mirror to work.

Run an Ubuntu live disk for a day or two. If an Ubuntu based distro crashes as well, then your power supply, (or other component) may be faulty.

1 Like

yeah something about my computer is messed up. I hung out in Arch Linux for a couple days and still had crashes, and it turns out that other people with my computer are reporting having the same issues. So the crashes and charging issue are unrelated to Garuda. The only issue I haven't been able to resolve is the chaotic-aur mirror not working.

1 Like