Rebooting during full update after fresh install

Just did a fresh install of the Garuda KDE Dr460nize gamers’ addition on an old Toshiba Satellite with an Intel core i7, 16G of ram, Intel HD graphics 4600 and a 1 T SSD sata drive. It had another Arch on it w/ much trouble, but it’s a backup system, so I don’t use it much these days.

During the install process, I had a several random reboots, but after a number of attempts and perhaps by dumb luck alone, I was able to get the system installed.

Now I’m trying to do a full system update which is 1096 pkgs, and after installing 120 or so pkgs the system spontaneously reboots. I normally use yay, but I get the same results when I click threw a gui button which seems to be running pacman.

Similar issues in the past have been resolved by switching kernels, so I’ve tried just updating the kernel which works w/out causing a spontaneous reboot, but I have same problem on the full update. Also, I tried installing linux-lts, and get the same problem. This issue seems to be different in so far as it’s always happening during the update process, rather than randomly.

Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=232d069d-1f53-47ae-9e6f-690963b3c3d8 rw rootflags=subvol=@
quiet rd.luks.uuid=a02be8a1-6c6c-4d76-ad3c-3807906ae11d
resume=/dev/mapper/luks-f544acde-6aad-44df-bb25-64765ad93474 loglevel=3
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: TOSHIBA product: Satellite S55t-B v: PSPRDU-008004
serial: <superuser required>
Mobo: Type2 - Board Vendor Name1 model: Type2 - Board Product Name1
v: Type2 - Board Version serial: <superuser required> UEFI: INSYDE v: 1.90
date: 10/08/2014
Info: model: Intel Core i7-4710HQ bits: 64 type: MT MCP arch: Haswell
gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 3248 high: 3500 min/max: 800/3500 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2494 2: 3500 3: 2494
4: 3500 5: 3500 6: 3500 7: 3500 8: 3500 bogomips: 39907
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Toshiba
driver: i915 v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports:
active: eDP-1 empty: HDMI-A-1,VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0416
class-ID: 0300
Device-2: Chicony [] driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
lanes: 1 mode: 2.0 bus-ID: 3-10:5 chip-ID: 04f2:b446 class-ID: 0e02
Display: wayland server: v: with: Xwayland v: 23.2.2
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: 0
Monitor-1: eDP-1 res: 1366x768 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel crocus platforms: device: 0 drv: crocus
device: 1 drv: swrast surfaceless: drv: crocus wayland: drv: crocus x11:
drv: crocus inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 4600 (HSW
GT2) device-ID: 8086:0416 memory: 1.46 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.269 layers: 9 device: 0 type: integrated-gpu name: Intel
HD Graphics 4600 (HSW GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:0416 surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
vendor: Toshiba driver: snd_hda_intel v: kernel bus-ID: 00:03.0
chip-ID: 8086:0c0c class-ID: 0403
Device-2: Intel 8 Series/C220 Series High Definition Audio
vendor: Toshiba 8 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:8c20 class-ID: 0403
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 07:00.0 chip-ID: 8086:08b3 class-ID: 0280
IF: wlp7s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Toshiba driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 08:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp8s0 state: down mac: <filter>
Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-9:4 chip-ID: 8087:07dc
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 4.0
lmp-v: 6 status: discoverable: no pairing: no class-ID: 7c010c
Local Storage: total: 931.51 GiB used: 12.54 GiB (1.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: Ultra II 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 10WD scheme: GPT
ID-1: / raw-size: 914.12 GiB size: 914.12 GiB (100.00%)
used: 12.54 GiB (1.4%) fs: btrfs dev: /dev/dm-1 maj-min: 254:1
mapped: luks-a02be8a1-6c6c-4d76-ad3c-3807906ae11d
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 720 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 914.12 GiB size: 914.12 GiB (100.00%)
used: 12.54 GiB (1.4%) fs: btrfs dev: /dev/dm-1 maj-min: 254:1
mapped: luks-a02be8a1-6c6c-4d76-ad3c-3807906ae11d
ID-4: /var/log raw-size: 914.12 GiB size: 914.12 GiB (100.00%)
used: 12.54 GiB (1.4%) fs: btrfs dev: /dev/dm-1 maj-min: 254:1
mapped: luks-a02be8a1-6c6c-4d76-ad3c-3807906ae11d
ID-5: /var/tmp raw-size: 914.12 GiB size: 914.12 GiB (100.00%)
used: 12.54 GiB (1.4%) fs: btrfs dev: /dev/dm-1 maj-min: 254:1
mapped: luks-a02be8a1-6c6c-4d76-ad3c-3807906ae11d
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 17.1 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/dm-0 maj-min: 254:0
mapped: luks-f544acde-6aad-44df-bb25-64765ad93474
ID-2: swap-2 type: zram size: 15.54 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
System Temperatures: cpu: 55.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 238 Uptime: 49m wakeups: 1 Memory: total: 16 GiB
available: 15.54 GiB used: 2.89 GiB (18.6%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1777 libs: 522 tools: octopi,paru Shell: fish v: 3.6.1
running-in: konsole inxi: 3.3.30
Garuda (2.6.17-1):
System install date:     2024-03-19
Last full system update: 2024-03-19
Is partially upgraded:   Yes
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:            systemd-backlight@leds:toshiba::kbd_backlight.service

What ISO? The old Gamers Edition is too old. Skip it, use the latest dr4gonized ISO instead.

That’s not going to end with a good install.


A little off topic

So if i have installed garuda gamer almost one year ago, is there any way to do full upgrade to latest version? You said that gamer edition is too old ??

If you are in the situation to reinstall, why don’t you try the testing builds that already start with KDE6, so the amount of packages to update will be much less?

I would start with Grauda Dr60nized (non-gaming). Then from there, when everything is installed, updated and working, there is a tool to add all the gaming stuff.
You’ll see in the thread that there are major issues still under investigation (after installation someone fails to boot), but I understand that the cases are limited to only some AMD systems.
If you don’t want to try the testing builds, or if you encounter the same issue there, you could work your way through this tutorial.
I know, it’s long and “demanding”, but also quite comprehensive.


Garuda employs a “rolling release” model. As long as you have kept your installation regularly updated, you are running the latest version, minus any theming changes, etc., which you can easily do yourself.

But I find @filo’s suggestion intriguing and might take it if I had the hardware. :slight_smile:


ok that’s what i thought, but wanted to be sure, thx Bro

1 Like

Sounds like a good, idea… and in fact I don’t need the gamers’ edition on my old laptop which is a backup machine. I’m downloading the normal plasma version of the test release from link above now. Let’s see how it goes.

Just tried sudo dd if=garuda-dr460nized-linux-zen-240321.iso of=/dev/sdb status=progress and got the same results. It booted into the live environment senproblemo, but then shutdown in the middle of the install. Like I said, it’s an old laptop, so I don’t think we can rule out a hardware problem. However, I did have some other Arch on it prior to trying Garuda, so it could also be a Garuda issue. Shall I try some other distro, just to see what happens, or is there some other diagnostic info that I could gather? As, I’ve now got Garuda up and running on my main machine, it’s no hurry and I can bang on this some more, if it would be helpful.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.