Random system freeze


Lately, I encountered many random system freeze where the system completely stops even the mouse cursor does not move and it requires force shut down and start again to function again.

What could be the reason? and how to fix it?

Kernel: 6.9.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d6be05e8-7ce0-4f9c-826c-98d4c5faf2b7 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.1.1 tk: Qt v: N/A info: frameworks v: 6.3.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: Razer product: Blade Pro 17 (Early 2021) - RZ09-0368
v: 6.04 serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: Razer model: DA760 v: 4 serial: <superuser required>
part-nu: RZ09-0368AEA2 uuid: <superuser required> UEFI: Razer v: 1.01
date: 01/05/2021
ID-1: BAT0 charge: 68.7 Wh (100.0%) condition: 68.7/70.6 Wh (97.3%)
volts: 17.5 min: 15.4 model: Razer Blade type: Unknown serial: <filter>
status: full
Info: model: Intel Core i7-10875H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 2 microcode: 0xFA
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 881 high: 2100 min/max: 800/5100 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 800
5: 800 6: 800 7: 800 8: 800 9: 800 10: 2100 11: 800 12: 800 13: 800
14: 800 15: 800 16: 800 bogomips: 73598
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Razer USA
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:9bc4
class-ID: 0300
Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q]
vendor: Razer USA driver: nvidia v: 550.90.07 alternate: nouveau,nvidia_drm
non-free: 550.xx+ status: current (as of 2024-06; EOL~2026-12-xx)
arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-2023 pcie:
gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
active: none empty: DP-1, DP-2, DP-3, HDMI-A-1 bus-ID: 01:00.0
chip-ID: 10de:2520 class-ID: 0300
Device-3: IMC Networks Integrated Camera driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-7:2 chip-ID: 13d3:56d5
class-ID: 0e02 serial: <filter>
Display: wayland server: X.org v: with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris
gpu: i915,nvidia display-ID: 0
Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia wayland: drv: iris x11: drv: iris
inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.2-arch1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
device-ID: 8086:9bc4 memory: 7.56 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 4 device: 0 type: integrated-gpu name: Intel
UHD Graphics (CML GT2) driver: mesa intel v: 24.1.2-arch1.1
device-ID: 8086:9bc4 surfaces: xcb,xlib,wayland device: 1
type: discrete-gpu name: NVIDIA GeForce RTX 3060 Laptop GPU driver: nvidia
v: 550.90.07 device-ID: 10de:2520 surfaces: xcb,xlib,wayland device: 2
type: cpu name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.1.2-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: Intel Comet Lake PCH cAVS vendor: Razer USA driver: snd_hda_intel
v: kernel alternate: snd_soc_skl, snd_soc_avs, snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA GA106 High Definition Audio vendor: Razer USA
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1 chip-ID: 10de:228e
class-ID: 0403
API: ALSA v: k6.9.6-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8125 2.5GbE vendor: Razer USA driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 3d:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp61s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6E AX210/AX1675 2x2 [Typhoon Peak] driver: iwlwifi
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 3f:00.0
chip-ID: 8086:2725 class-ID: 0280
IF: wlp63s0 state: up mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:5 chip-ID: 8087:0032
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.3 lmp-v: 12
status: discoverable: no pairing: no
Local Storage: total: 1.38 TiB used: 12.18 GiB (0.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 model: NVMe CA5-8D512 size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
tech: SSD serial: <filter> fw-rev: CQ20904 temp: 35.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:8 vendor: Samsung model: SSD 980 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 1B4QFXO7 temp: 43.9 C
scheme: GPT
ID-1: / raw-size: 49.04 GiB size: 49.04 GiB (100.00%)
used: 11.58 GiB (23.6%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-2: /boot/efi raw-size: 2.56 GiB size: 2.55 GiB (99.80%)
used: 616.6 MiB (23.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 49.04 GiB size: 49.04 GiB (100.00%)
used: 11.58 GiB (23.6%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-4: /var/log raw-size: 49.04 GiB size: 49.04 GiB (100.00%)
used: 11.58 GiB (23.6%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-5: /var/tmp raw-size: 49.04 GiB size: 49.04 GiB (100.00%)
used: 11.58 GiB (23.6%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.48 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
System Temperatures: cpu: 51.0 C pch: 46.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 16 GiB available: 15.48 GiB used: 2.9 GiB (18.7%)
Processes: 350 Power: uptime: 14m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.15 GiB services: org_kde_powerdevil,
power-profiles-daemon, thermald, upowerd Init: systemd v: 256
default: graphical tool: systemctl
Packages: pm: pacman pkgs: 1408 libs: 410 tools: octopi,pamac,paru
Compilers: gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1
running-in: konsole inxi: 3.3.35
Garuda (2.6.26-1):
System install date:     2024-06-28
Last full system update: 2024-06-28
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:            intel-undervolt.service

Have you tried with an x11 session (in the login screen)?


Yes I did. It reduced the frequency of the freeze but did not eleminate it. But overall, Isn’t wayland a better and more modern engine (or w/e) than x11?

It is, but it is also still less “mature”.
There is no rule, everybody should try them both on their specific hw and decide.
By-the-way, you can disabled this

But it is not related to your issue.


How many freezes did you have in a single day after a fresh install :thinking:?

Do the LEDs on the Caps Lock and Num Lock keys react when you press them during a freeze? If not, then it looks like a kernel panic.

Wayland and nvidia don’t work for everyone without issues, so you should use x11 instead.

The next time you have a freeze, restart your system and post the output of:

journalctl -b -1 --no-pager

Upload this to https://bin.garudalinux.org/ and share the generated link here.


Sorry, can’t resist… :wink:
As I always say, very challenging but also very useful as a reference


just got a freeze
here is the output of the requested command

The log is useless. We need more of it to identify a potential pattern.

You had previously installed Garuda Linux and used linux-lts:

Did you experience any freezes during the previous installation?

Please answer all questions.

1 Like

Well I just posted the output of the command you mentioned in the previous post

and yes during the previous installation I encountered multiple freezes.

Sorry did not notice this part. Will report it if I encountered another freeze

This just means that the log does not contain any useful information about the cause of the freeze. This is typical for a kernel panic, then the log suddenly stops.

The next time it freezes, the same thing again:

journalctl -b -1 --no-pager

got another freeze. Was installing thorium browser
For the light of caps lock, it did not light during the freeze no matter how many times I click on it.
here is the output of the required command

another one. was enabling power saving tweaks

got another one. This time was on x11 not wayland and got the freeze in the middle of a system update. using garuda-update command

The logs are all useless and no pattern can be identified.

Both together indicate a classic kernel panic.
You’ve already tried a lot, for example linux, linux-lts, linux-zen and linux-mainline. You’ve also tested various energy saving options, played around with tlp and hdparm - but the freezes still remain, regardless of whether you use wayland or x11. It can’t be narrowed down to a specific scenario either, as the freezes occur completely randomly. My guess is either a hardware issue or an problem with the nvidia drivers.

In addition to Windows, you also have EndeavourOS installed, does EndeavourOS run without issues? Which DE do you use on EndeavourOS, also KDE Plasma?

Try switching to the open source graphics driver nouveau as a test and check whether freezes occur with it too.

Run an extensive memtest, preferably overnight. You can select and start memtest in the grub menu.

You can also try installing another garuda spin, for example Garuda Cinnamon, and check whether it also causes freezes.


Some ideas from other forums.

Fix with other kernel:

Driver signing and secure boot:

I wonder if GPU error ( screen goes blank , or pixelated) would cause similar kernel panic?

The OP has no freezes during booting. He has already tried different kernels, this is evident in the logs and I also recommended this to him in his other topic. And I am 99.999999999999% sure that Secure Boot is deactivated on his computer :slight_smile:

There is no indication of this. If the cause were the nvidia drivers, then theoretically it would be visible in the logs - but it isn’t. My guess about the nvidia drivers is just a shot in the dark.

If it were a defective GPU, then the OP would also have the problem on Windows and EOS. Nothing has been mentioned about this so far. Let’s just wait for a response from @lordvoldmort.


Well thanks for your response. Here are some answers/ clarifications:
1- I rarely had any freeze on EoS . It happened once or twice and as far as I remember it was on wayaland not on x11. Never got a freeze on windows ever before. And Yes I also have KDE on EoS
2- I also tried fedora. With both wayland and x11, never got a freeze. Used open source drivers out of the box , no freezes then ,disabled the open source ones and installed nvidia drivers there with multiple ways. no freezes still .

3- Yes I have secure boot deactivated. It was mentioned during the installation instruction on garuda website. Should it be re-activated? Can this have an impact on the freeze issue?

That’s interesting. A very big difference between Garuda (BTRFS/Snapper) and EOS (ext4) is the file system, so you can theoretically rule that out as the cause (there was no indication of it in the logs either). The “main suspects” are KDE and nvidia.
As a test, try the open source driver nouveau.

Also with KDE?

As for the memtest: Windows is not really interested in memory errors and works with memory errors until a serious one occurs - the result is then a BSOD with a typical “page error message”. It’s different with Linux, Linux is much more sensitive. If it were defective RAM, then Fedora would freeze just like Garuda and EOS. Of course, it also depends on whether you have used Fedora for the same length of time and with the same scenarios to trigger a potential memory error.
Do an extensive memtest.

No, leave it deactivated. While you’re at it, check whether Fast Boot is disabled in the BIOS and whether Faststart is also disabled in Windows.



Yes it is disabled.

How to check that?

OK will this have any impact on performance or battery life?

this should be done on Garuda right?

Lately, I used Fedora even more than I used Garuda or EoS with same usage patterns.