Random system freeze while playing trails of cold steel 3 leaves kde in broken state

System Info

  Kernel: 5.17.5-256-tkg-pds arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: intel_pstate=passive
    root=UUID=ef15347e-a4da-4628-afc3-2bff20cbb710 rw [email protected]
    rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 libahci.ignore_sss=1
    resume=UUID=e7745511-30a0-4b3d-93c1-4bc3daa8b2b8 loglevel=3
    sysrq_always_enabled=1 nowatchdog iommu=pt
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: X470 Taichi serial: <superuser required>
    UEFI: American Megatrends v: P4.86 date: 01/27/2022
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 4167 high: 4185 min/max: 2200/3600 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 4168 2: 4168
    3: 4163 4: 4174 5: 4185 6: 4150 7: 4175 8: 4170 9: 4173 10: 4184 11: 4130
    12: 4171 bogomips: 86487
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: Gigabyte driver: nvidia
    v: 510.68.02 alternate: nouveau,nvidia_drm pcie: gen: 3 speed: 8 GT/s
    lanes: 16 ports: active: none off: DP-1,HDMI-A-1 empty: DP-2,DP-3,DVI-D-1
    bus-ID: 0d:00.0 chip-ID: 10de:1b80 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia,nvidia-nvswitch
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 6400x2160 s-dpi: 101 s-size: 1608x543mm (63.31x21.38")
    s-diag: 1697mm (66.82")
  Monitor-1: DP-1 mapped: DP-0 note: disabled pos: primary,left
    model: LG (GoldStar) HDR WFHD serial: <filter> built: 2021 res: 2560x1080
    dpi: 81 gamma: 1.2 size: 798x334mm (31.42x13.15") diag: 869mm (34.2")
    modes: max: 2560x1080 min: 640x480
  Monitor-2: HDMI-A-1 mapped: HDMI-0 note: disabled pos: right
    model: Samsung serial: <filter> built: 2019 res: 3840x2160 hz: 60 dpi: 52
    gamma: 1.2 size: 1872x1053mm (73.7x41.46") diag: 1093mm (43") ratio: 16:9
    modes: max: 3840x2160 min: 640x480
  OpenGL: renderer: NVIDIA GeForce GTX 1080/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.68.02 direct render: Yes
  Device-1: NVIDIA GP104 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 0d:00.1 chip-ID: 10de:10f0 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.5-256-tkg-pds running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 09:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Device-1: Edimax Bluetooth Adapter type: USB driver: btusb v: 0.8
    bus-ID: 1-8:3 chip-ID: 7392:c611 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 2.96 TiB used: 2.99 TiB (101.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO 250GB size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXE7 temp: 35.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:5 vendor: Samsung model: SSD 980 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 1B4QFXO7
    temp: 33.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DX002-2DV164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC41 scheme: GPT
  ID-1: / raw-size: 914.08 GiB size: 914.08 GiB (100.00%)
    used: 774.12 GiB (84.7%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 29.4 MiB (11.5%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:6
  ID-3: /home raw-size: 914.08 GiB size: 914.08 GiB (100.00%)
    used: 774.12 GiB (84.7%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
  ID-4: /var/log raw-size: 914.08 GiB size: 914.08 GiB (100.00%)
    used: 774.12 GiB (84.7%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
  ID-5: /var/tmp raw-size: 914.08 GiB size: 914.08 GiB (100.00%)
    used: 774.12 GiB (84.7%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:7
  Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
  ID-1: swap-1 type: partition size: 17.18 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme1n1p3 maj-min: 259:8
  ID-2: swap-2 type: zram size: 31.27 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 49.5 C mobo: 34.0 C gpu: nvidia temp: 38 C
  Fan Speeds (RPM): fan-1: 0 fan-2: 1880 fan-3: 1297 fan-4: 1309
    fan-5: 1564 gpu: nvidia fan: 31%
  Power: 12v: N/A 5v: N/A 3.3v: 3.28 vbat: 3.28
  Processes: 428 Uptime: 6m wakeups: 2 Memory: 31.27 GiB
  used: 14.75 GiB (47.2%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: 2277 pacman: 2265 lib: 582 flatpak: 12
  Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: alacritty
  inxi: 3.3.15
Garuda (2.6.2-1):
  System install date:     2021-10-17
  Last full system update: 2022-05-02
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            fancontrol.service

hw-probe with logs SMART health checks and more

So I am getting these random system hangs when playing trails of cold steel 3. The system becomes unresponsive for a bit and then comes back (I think it's running out of memory?), however when it does finally become responsive, the KDE desktop is no longer working replaced by a black screen.

What I have tried

  • Different kernel versions (including vanilla lts)

  • Fully updating my system

  • Checks for HW defects (Testing ram checking temps etc..)


Filter to just the time of the incident as a full log is too long to post on a Pastebin

EDIT: the last one got a password protected for some reason

EDIT2: more complete log paste

EDIT3:It set another password again for some reason :weary:

From taking a look at the logs its seems plasma memory leaked and anicy killed it?

Freezing Questionnaire/Checklist:

Have you posted the output of the garuda-inxi command?

yes see the beginning of the post

Have you provided a full history of fixes attempted?

yes see what I have tried section

Have you checked for errors/segfaults/crash dumps, and posted your logs?

yes see the above private bin post

Have you given at least 3 alternate kernels a test out? which ones?


  • linux-lts 5.15.37-1
  • linux 5.17.5.arch1-1
  • linux-tkg-pds-generic_v3 5.17.5-256

Have you fully updated your system?

Is your BIOS up to date?

Have you checked your resource usage with htop, iotop, etc?

resource usage

Are you getting close to maxing out your ram at any time?

I was before I upgraded to 32GB

Have you checked your system temperatures?

yes, never exceeds 60c on both the CPU and GPU

Did this issue start recently after an update?

not as far as I can tell been having freezes and performance issues for about a month now

If this started recently, have you tried performing a rollback via a snapshot?


Can you recall making any config changes about when this issue began?


Have you tried disabling the baloo file indexer temporarily?

I always disable baloo on KDE

Have you tried disabling all network adapters temporarily?

yes found that does help and noticed system freezes seem to be tied to steam

Have you tried disabling hardware acceleration in your browser?

yes I also make sure to close out any browsers that are running when I am gaming or not using them, doesn't seem to help much

Have you tried disabling BTRFS Quotas (groups)?

yes noticed I was getting really bad performance whenever a btrfs maintenance task was run (I have it set up to run a balance and a filesystem check every now and then) and this helped with that so that was part of the reason for my hangs

Have you run a BTRFS balancing operation?

If you press the CAPS or NUMLOCK key, does your KB state light change?

Is your CAPS or NUMLOCK LED blinking? (kernel panic indicator)

no, and no kernel panic messages in the logs as far as I can tell

Can you move your mouse cursor?


Can you move your mouse cursor, but clicking has no effect?

Yes I can move my mouse cursor but clicking has a delayed effect

Do you have full keyboard functionality?


Is this a complete freeze-up with no keyboard or mouse responsiveness?

no, but the system performs very slowly

Does pressing CTRL+T open a terminal?

after a while yes

Does pressing CTRL+ALT+F2 get you to a TTY?

after awhile yes

Have you tried restarting your system from the terminal or TTY?

yes I usually switch to another TTY and press ctrl+alt+del to reboot when the issue happens

Have you tried to remote in from another computer via ssh?

Yes again it is very slow and unresponsive

Have you tried to ping your machine from another computer?

Can you use the Magic SysRq key to restart/shutdown?


Have you tried restarting (KDE) plasmashell or kwin from the terminal?

Is there a specific program or action that often triggers a freeze?

when steam is downloading a game and any btrfs maintenance tsk before disabling btrfs quotas

How many applications are generally running when the freezing occurs?

Are the freezes completely random?

Is their any pattern to the freezes?

How often do the freezes usually occur?

How long have these freezes been happening on this install?

Do the freezes seem to be getting more frequent over time?

What is your longest time without a freeze?

Do freezes only happen while doing something CPU intensive?

Do the freezes happen even if the system is completely idle?


If a freeze does occur, does it resolve on its own if you wait a long time?


Have you tried both the proprietary and free Nvidia drivers, (if present)?

Have you tried changing your compositor settings?

Have you tried disabling your compositor entirely?

I disable my compositor when gaming

Have you followed all the steps in the hardware troubleshooting tutorial?

Have you followed all the steps in the software troubleshooting tutorial?

Have you tried removing all plasma widgets (plasmoids) you've installed?

Have you tried removing all Gnome extensions you've installed?


Have you used Garuda Assistant to reset your default config?


Have you tried Installing linux-firmware-git , and rebooting?

Have you made any overclocking/undervolting or similar modifications?

just a slight overclock to the GPU which i only apply when gameing through gamemode

Do you use full disk encryption?


Do you use a swap partition?


Have you installed multiple Desktop Environments or WM's together?

Are you running Garuda in a Virtual Machine?


Do you have only 4GB of RAM (or less) with shared video?

no integrated GPU and 32GB of RAM

Does your electrical grid experience power fluctuations?


Is your home wiring very old, do your lights flicker?


Have you installed any extra apps (which) from the AUR/Chaotic repos?

air-for-steam 2019_0917-1
android-bash-completion r43.c1b0656-1
apk-preview 1.3.2-3
apk-thumbnailer 1.0-2
app-outlet-bin 2.1.0-1
archlinux-artwork 1.6-6
archlinux-themes-sddm 2.0-1
awesome-terminal-fonts-patched 1.0.0-2
base-devel-meta 2021.08.07-1
bash-pipes 1.3.0-9
betterdiscordctl 2.0.1-1
chiaki 2.1.1-2
classik 3.0.breeze5.23.80-1
cod 0.1.0-5
compact-steam-skin 1.6.53-1
compleat-git r121.8cf2bcd-1
cpu-x 4.3.0-4
ddd-ftn 3.3.12-13
dotpac 0.4-4
dracula-gtk-theme v3.0-2
etcher-bin 1.7.9-1
fluent-decoration-git r33.5655249-1
fluent-kde-theme-git r47.f1ac81e-1
fontconfig-emoji-git r15.3706c6c-1
fusesmb 0.8.7-4
fzf-extras 0.3.1-1
gamescope-session-git r50.bdc69f7-1
genius-spicetify-git r21.dbbd430-1
gpu-screen-recorder-git r110.32c3807-1
gpu-screen-recorder-gtk-git r33.a87de5f-1
gputest 0.7.0-1
hastebin 1.4.0-1
i2c-tools-git r384.eacb6a4-1
icu67 67.1-1
imgcat 1.2.0-2
interbench 0.31-4
invert-steam-skin 353-2
joplin 2.7.15-4
joplin-desktop 2.7.15-4
jstest-gtk-git 0.1.0.r116.g9c69fec-1
kcm-colorful-git 1.0.5.r0.g411e8c9-1
kcm-uefi 0.1-1
kde-servicemenus-newfolderwithselection 1.1-1
kde-thumbnailer-apk 1.1-1
kipi-plugins 22.04.0-1
kotatogram-desktop-bin 1.4.9-1
krita-plugin-gmic-git 3.0.0.r15.gd1ef621-1
kvantum-theme-sunset-dark-git r4.d21b6a1-1
kwin-effect-shaders-git 155.r06e2fae-1
lib32-libde265 1.0.8-1
lib32-ncurses5-compat-libs 6.3-1
libffi6 3.2.1-1
libkipi 22.04.0-1
libmediawiki 5.37.0-5
libpng15 1.5.30-1
libretro-opera-git 462.aa868e6-1
libsndio-61-compat 1.3.0-1
lightlyshaders-git r85.51e0c56-1
ludusavi 0.10.0-4
magnus 1.0.3-3
memtest86-efi 1:9.4build1000-4
metro-for-steam-skin 4.4-1
mono-basic 4.8-1
mpd-discord-rpc-git v1.4.1.r0.gdf3b30d-1
mymc 2.6-11
noto-fonts-emoji-flags 20200120-1
nro-thumbnailer-git 0.0.2.r0.gdc57dfc-1
nvidia-tweaks 510-3
nyrna 2.4.1-1
organize 1.10.1-1
osl 0.9.2-2
pev 0.81-1
phantomjs-beta-bin 2.5.0-2
pince-git r1142.7e1a5a9-1
pinta-git r2479.d6ff4252-1
pipes.sh 1.3.0-1
pixelvision2-steam-skin 1.0-1
pkg2zip-fork 2.3-2
plasma5-applet-awesome-widgets 3.4.3-1
plasmoidviewer-debug 5.15.0-1
pnputils-git 0.1.3.r56.g81e685a-1
polkit-qt4 0.112.0+git20180107-1
pressure2-unofficial-steam-skin 1.1.1-1
protondb-tags 1.1.1-1
protonfixes-git 1.0.15.r201.g24ecb37-1
pug-hook-git 20200107.e4bb973-1
python-exifread 2.3.2-1
python-simplematch 1.3-1
python-smbus-git r385.a460931-1
remoteplaywhatever-bin 0.1.14-1
renderdoc 1.19-1
replay-sorcery 0.6.0-1
retrosmart-kvantum-theme 1.0b-1
rom-properties 1.8.3-1
samrewritten-git r243.6bf7002-1
semantik 1.2.7-1
sgdboop-bin 1.0.12-1
spicetify-custom-apps-and-extensions-git r102.b4b33b2-1
spicetify-theme-dribbblish-dynamic 4.2.0-1
srt-live-server 1.4.8-1
sssm 1.2.1-1
steam-metadata-editor-git 1.0.0.r34.d9d62f7-1
steamtinkerlaunch-git 10.0.20220430.r759.53d0f7d-1
systemd-kcm 1.2.1-5
threshold-miku-dark-steam-skin 2.4.2-1
threshold-miku-light-steam-skin 2.4.2-1
ttf-opendyslexic 1-3
ttf-segoewp 1.0-3
ttf-twemoji-color 13.1.0-1
vivaldi-widevine 1:4.10.2449.0-1
win11-gtk-theme-git r10.62225c3-1
win11-icon-theme-git r128.a148adf-1
xdotool-gui 1.2-2
xrasengan 1.0.0-5
zsh-systemd-git r2.d9fea29-1
zsh-you-should-use 1.7.3-1

Have you fully updated all apps from the AUR/Chaotic repos?


Have you experienced similar issues with this hardware on other OS's?


Did, (or does) freezing also occur on Windows?


Did, (or does) freezing also occur on other Linux distros?


Have you booted live disks of other Garuda DE's or other distros?

ubuntu and fedora

Does freezing also occur in live environments, (which ones)?

no (tried ubuntu and fedora)

Does freezing also occur if you create a new user account?

Will try

Does the system get progressively slower before freezing?


Has your computer ever shut off on its own, without you initiating ?


Does sound continue playing, or loop during a freeze?

it stutters and cuts in and out

Are you using tlp ? if so, disable or uninstall it temporarily.


If your computer has a disk activity LED, is it blinking during the freeze?


Greetings. i will try to assist. So please, how much RAM you have in your system?
Also, be aware , Ryzen CPUs (not all but some of them due wrong microcoding programming) when the C6 state is on 'Auto' on your motherboard BIOS, can freeze and crash the system. So solution I had with my freezing installations too, was to change the C6 state option from 'Auto' to 'Typical' or ' 'Normal' depends how named by motherboard manufacturer.
Try the second 'tip' if you have large amount of memory.

1 Like

This FAQ tutorial may help:


I could see it overheating with this failed service. And you know where that leads.


Thanks everyone for the tips

fans are still working though but at the curves set at bios. the software curves are not working never could fix that so I haven't bothered my CPU never exceeds 70c anyways nor does my GPU(always check my temps like I said in the OP)

I have 32GB of ram (just recently upgraded from a 2x 8GB to a 2x 16GB)

So maybe could be related? I have heard of this but I thought it only happened to zen 1 processors? so 1800x, for example, this is a 2600x so it's zen+ which I thought fixed the issue? Doesn't hurt to try though right? or will it impact performance?

Yeah, I've been getting some issues with btrfs before so I have disabled quotas, but maybe that wasn't enough or didn't fix it...

Sometimes deleting your stored snapshots then performing a btrfs balancing helps with random freezes. Be sure to reboot.


No will not hurt performance . But can make your system more stable. Even some 3000 series ryzen had similar issue so you don't lose something to try ^

So Found the option in my bios but it only has a setting of auto, manual or disabled and manual just sets it to auto so possible a bios issue there

Also, I found That the issue seems to happen (at least I think) when steam is downloading something in the background CPU usage goes way up (90-100%) when downloading a game and the system becomes very slow

I edited the OP to include the troubleshooting questionnaire and some answers to it (which Im working on)

What motherboard brand you have?
Mine is Asus and has the options .

That's what garuda-inxi is for

1 Like

so I have done a balance and rebooted and I'm still getting system unresponsiveness while downloading a steam game. Asked about this in several discords and this seems to actually be normal behavior when using a ryzen 5 with gigabit speeds?

EDIT: don't know why I find this github issue

so yes it is normal and can be solved by

  1. not allowing downloads while playing a game
  2. limiting your download speed to something lower like 200 Mbps in the steam settings

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.