My screen keeps flickering and showing me background apps

Hello. I switched from windows 10 to garuda Dragonized. I used garuda before, but now i switched for good(or at least i tried to). My screen keeps flickering like it did back when i first tried to use Garuda. When i’m using Brave or any other brower- i currently only have brave installed because its my fav the screen keeps showing me parts and chunks of destkop and its super fast and annoying. When i’m typing and even now my words keep glitching out and vanishing then only to reappear. I use Nvidia RTX 2070 and i have everything updated. I tried reinstalling garuda, but it doesn’t fix anything. I have Intel Core i7, 32GB ram and Nvidia RTX 2070. Is there any way to fix this or do i have to go back on windows ? I tried few solutions like disabling my nigh light or playing with different hzs. I also tried to resize my screen and resolution and not even that fixes anything. I even scanned for errors and it came at 0. Please help if you can.

Hi there, welcome to the forum.
First of all, please always provide your garuda-inxi as required in the topic template.
My best guess without further info would be to try using a Plasma x11 session in the login screen instead of Wayland, which is the new default, and doesn’t get along very well with Nvidia.

  Kernel: 6.8.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    avail: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=b58c058b-2bff-4086-96d2-a19d53deca95 rw rootflags=subvol=@ quiet loglevel=3 ibt=off
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0 wm: kwin_wayland vt: 1
    dm: SDDM Distro: Garuda base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: Z390-A PRO (MS-7B98) v: 1.0 serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends v: 1.10 date: 08/22/2018
  Info: model: Intel Core i7-9700KF bits: 64 type: MCP arch: Coffee Lake gen: core 9 level: v3
    note: check built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158) stepping: 0xC (12)
    microcode: 0xF6
  Topology: cpus: 1x cores: 8 smt: <unsupported> cache: L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB
    L2: 2 MiB desc: 8x256 KiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 4600 high: 4602 min/max: 800/4900 scaling: driver: intel_pstate
    governor: powersave cores: 1: 4602 2: 4600 3: 4600 4: 4600 5: 4602 6: 4600 7: 4600 8: 4600
    bogomips: 57600
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: NVIDIA TU106 [GeForce RTX 2070] vendor: Micro-Star MSI driver: nvidia v: 550.76
    alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current (as of 2024-04; EOL~2026-12-xx)
    arch: Turing code: TUxxx process: TSMC 12nm FF built: 2018-2022 pcie: gen: 3 speed: 8 GT/s
    lanes: 16 ports: active: none off: DP-1 empty: DP-2,DP-3,HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 10de:1f02 class-ID: 0300
  Display: wayland server: v: with: Xwayland v: 23.2.6 compositor: kwin_wayland
    driver: X: loaded: nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: nvidia
    display-ID: 0
  Monitor-1: DP-1 res: 2327x1309 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2 drv: swrast gbm:
    drv: nvidia surfaceless: drv: nvidia wayland: drv: nvidia x11: drv: zink inactive: device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.76 glx-v: 1.4 direct-render: yes
    renderer: NVIDIA GeForce RTX 2070/PCIe/SSE2 memory: 7.81 GiB display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 10 device: 0 type: discrete-gpu name: NVIDIA GeForce RTX 2070
    driver: nvidia v: 550.76 device-ID: 10de:1f02 surfaces: xcb,xlib,wayland device: 1 type: cpu
    name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.5-arch1.1 (LLVM 17.0.6)
    device-ID: 10005:0000 surfaces: xcb,xlib,wayland
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
  API: ALSA v: k6.8.7-zen1-1-zen status: kernel-api with: aoss type: oss-emulator tools: N/A
  Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e v: kernel port: N/A
    bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager,systemd-timesyncd
  Local Storage: total: 10.96 TiB used: 3.95 TiB (36.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SNV2S2000G size: 1.82 TiB block-size:
    physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: SBM02103 temp: 29.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Kingston model: SKC6002048G size: 1.86 TiB block-size:
    physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 0113
    scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST8000NT001-3LZ101 size: 7.28 TiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: EN01 scheme: GPT
  ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 692.55 GiB (37.2%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 584 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 692.55 GiB (37.2%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 692.55 GiB (37.2%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 692.55 GiB (37.2%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 31.28 GiB used: 256 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  System Temperatures: cpu: 39.0 C pch: 42.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 32 GiB available: 31.28 GiB used: 4.56 GiB (14.6%)
  Processes: 304 Power: uptime: 1h 7m states: freeze,mem,disk suspend: deep avail: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 12.47 GiB
    services: org_kde_powerdevil, power-profiles-daemon, upowerd Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1986 libs: 558 tools: octopi,paru pm: flatpak pkgs: 0 Compilers:
    clang: 17.0.6 gcc: 13.2.1 Client: shell wrapper v: 5.2.26-release inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-04-25
  Last full system update: 2024-04-26
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:            

I didn’t know that i’m sorry- i posted it. I just relogged in plasma x11 and its doing the same thing, but not as often as it did before.

I’m not an Nvidia expert (and user) but I don’t see anything wrong in your specs.
Go for x11 and maybe check if you can update your BIOS, really old. You never can say…


This is something strange I just noticed. I don’t know if in x11 it looks different.
Check if you can change e.g. the resolution from the system settings, or maybe check in the Arch wiki, e.g.
There might be better or other articles, but I have no more time… :smiling_face:


Thank you i will try that on plasx11 , but as i wrote, i played with different monitor settings and resolutions and nothing helped. I hope the bios outdated isn’t an issue because i know you can ruin it if you update it. I don’t want to play with that and roll the dice just because of an issue that i hope is solvable other way.

Hey, same issue here. Logging out, switch to X11 did help for now.

1 Like

That only reduced the frequency of flickering. I still cannot watch anything without it flickering or as it seems it glitches a bit.

This is a fantastic tutorial. Quite “demanding” but also great for learning in general, the approach and the hints.


Maybe first of all, if the issue is limited to browsing, you could try installing other browsers and also play toggling hardware acceleration on and off.

That’s my question too, the information isn’t clear enough.

Have you tried this?

There are no issues on Windows, but on linux with wayland and x11. That sounds like typical nvidia driver problems…
btw: issues with the 550 drivers have been increasing since the beginning of April.
Try switching to the nouveau driver and check if you have the same issues.

Come on, dare. Don’t be a coward:
Release Date: 2022-11-08


I mean i did try using hardware acceleration and ive tried other browsers. Ther issue is it keeps flickering during movies, listening to music, just having nothing open. Each time i scroll it starts flickering and that really looks annoying. If i was epileptic this would trigger an attack - its that bad. Switching to x11 did make it less frequent, but it still happens. Now i could try to update my bios, but it will be the last thing i’ll do because i am afraid of destroying my motherboard-thanks for the link. I am not being a coward, just being wise due to me not wanting to waste money for peerpressure of being a coward. I thought the same thing about browsers, so i tried mozilla, chromium, tor, firedragon it does the same thing. Its not limited to browsing, but it does that all the time. I tried different themes, tried to change my setting, updated my drivers, cleared the cache etc. Nothing is really helping. I believe this is because of nvidia drivers-why is nvidia so mean ): not playing along and making my eyes hurt.

I still don’t understand whether you only have problems in browser`s or in general. If the issues only occur in the browser and activating/deactivating hardware acceleration doesn’t help, then it smells like Nvidia.
If you had system wide hardware acceleration issues, other applications would also be affected.

Have you checked whether the issues also occur with the open source nouveau driver?

Because nvidia is greedy and hates open source software :face_vomiting:
Linus Torvalds commented on this very well :grin:


Have you tried using the force full composition pipeline option for your Nvidia card.

Search that term on the Arch Wiki for full details and instructions on how to implement this.

I have not had to use this setting for many years now, as I gave up on Nvidia long ago.


It got fixed yesterday. Idk how or why and i didn’t really do anything else. I just updated my system and restarted it because i changed my login picture and i wanted to see how it looks. Its fixed now… idk how, but something worked.


Pure magic :wink:

Nice to hear it’s working now :slight_smile:

I mean i did install hogwards legacy :rofl: maybe that has something to do with it.