KDE feels choppy and laggy

╭─[email protected] in ~  
╰─λ garuda-inxi
Kernel: 5.17.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1a7b1b9c-65b1-4325-a966-5d7c7228631c rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=a5a047b9-ca89-413f-b513-57d047847ef0 loglevel=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: ASRock model: A320M Pro4-F serial: <superuser required>
UEFI-[Legacy]: American Megatrends v: P2.20 date: 07/27/2020
Info: model: AMD Ryzen 3 3100 bits: 64 type: MT MCP arch: Zen 2
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3743 high: 3884 min/max: 2200/3906 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3762 2: 3746
3: 3590 4: 3731 5: 3884 6: 3724 7: 3678 8: 3831 bogomips: 57490
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Tul / PowerColor driver: amdgpu v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 16 ports: active: HDMI-A-1
empty: DP-1, DP-2, DP-3, DVI-D-1 bus-ID: 06:00.0 chip-ID: 1002:67df
class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Samsung SMB2330HD built: 2010
res: 1920x1080 hz: 60 dpi: 96 gamma: 1.2 size: 510x290mm (20.08x11.42")
diag: 587mm (23.1") ratio: 16:9 modes: max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 470 Graphics (polaris10 LLVM 13.0.1 DRM
3.44 5.17.9-zen1-1-zen)
v: 4.6 Mesa 22.1.0 direct render: Yes
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Tul / PowerColor driver: snd_hda_intel v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 06:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 08:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound Server-1: ALSA v: k5.17.9-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Local Storage: total: 2.49 TiB used: 191.69 GiB (7.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: PNY model: CS900 240GB SSD
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 0615 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA050
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A750
scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST2000VN004-2E4164
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5900 serial: <filter> rev: SC60 scheme: MBR
ID-1: / raw-size: 206.47 GiB size: 206.47 GiB (100.00%)
used: 100.42 GiB (48.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 206.47 GiB size: 206.47 GiB (100.00%)
used: 100.42 GiB (48.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 206.47 GiB size: 206.47 GiB (100.00%)
used: 100.42 GiB (48.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 206.47 GiB size: 206.47 GiB (100.00%)
used: 100.42 GiB (48.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.55 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.1 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda2 maj-min: 8:2
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 56.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 609
Processes: 323 Uptime: 9m wakeups: 0 Memory: 15.55 GiB
used: 2.82 GiB (18.1%) Init: systemd v: 251 tool: systemctl Compilers:
gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1849 lib: 538 Shell: fish
v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.16
Garuda (2.6.3-2):
System install date:     2022-05-26
Last full system update: 2022-05-28
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

Hi! I use the Gaming edition, but my screen feels choppy and laggy. When i record a video, there is no lag on the recorded video. Also when i game it feels laggy and choppy like the kde desktop too, but the fps is stable 60. The gpu is RX 470 4gb. I don't have that problem when I boot live flash drive with Garuda, also it was not like this when it was fresh installed. Maybe it's some config but I don't know where to touch it.


This is a long, challenging but really complete tutorial.
I'd start from the btrfs (balance?) part, and why not a status check of your HDD.

1 Like

Just to say sometimes on restart it fixes by itself, sometimes on restart it feels choppy.

Keep it under control with htop or similar, to see what's going on when it starts lagging.

It's lagging the effects of the desktop like the gpu is slow and it's lagging while gaming but the fps is stable 60 in gaming, also there is nothing wrong with the load. On a video record I can't show it, because the recorded video doesn't have the lag that I see.

Now I notice my display is set to 60 hz. When i switch to 50 hz and then go back to 60 hz it fixes.

The way I fixed it:

When I start xrandr I see this:

╭─[email protected] in ~
╰─λ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
DisplayPort-1 disconnected (normal left inverted right x axis y axis)
DisplayPort-2 disconnected (normal left inverted right x axis y axis)
HDMI-A-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 510mm x 290mm
1920x1080     60.00 +  50.00    59.94*   30.00    25.00    24.00    29.97    23.98
1680x1050     59.88
1280x1024     75.02    60.02
1440x900      74.98    59.90
1280x960      60.00
1280x800      59.91
1152x864      75.00
1280x720      60.00    50.00    59.94
1024x768      75.03    70.07    60.00
832x624       74.55
800x600       72.19    75.00    60.32    56.25
720x576       50.00
720x480       60.00    59.94
640x480       75.00    72.81    66.67    60.00    59.94
720x400       70.08
DVI-D-0 disconnected (normal left inverted right x axis y axis)

and now it works. On auto the "*" was on 60 hz. I created a script:

xrandr --output HDMI-A-0 --mode 1920x1080 --rate 59.94

I've put that script on autostart and bam - It's now smoother then ever.

The output is after the fix.

Maybe this could help to somebody.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.