Animations become laggy after some time

Here is my inxi

Kernel: 6.7.0-zen3-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ccdae71d-6b5f-4b38-a1d0-702837715fe4 rw rootflags=subvol=@
quiet resume=UUID=f69d185f-9355-48ae-8918-12a24a0576b1 loglevel=3
spidev.bufsiz=37268 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_wayland dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X421FAY_K413FA
v: 1.0 serial: <filter>
Mobo: ASUSTeK model: X421FAY v: 1.0 serial: <filter>
UEFI: American Megatrends v: X421FAY.304 date: 01/04/2021
ID-1: BAT0 charge: 28.4 Wh (100.0%) condition: 28.4/42.1 Wh (67.5%)
volts: 11.8 min: 11.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: not charging cycles: 324
Info: model: Intel Core i3-10110U socket: BGA1528 (U3E1) note: check
bits: 64 type: MT MCP arch: Comet/Whiskey Lake note: check gen: core 10
level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x8E (142) stepping: 0xC (12) microcode: 0xF8
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 2956 high: 4102 min/max: 400/4100 base/boost: 2673/8300
scaling: driver: intel_pstate governor: powersave volts: 0.8 V
ext-clock: 100 MHz cores: 1: 3717 2: 400 3: 3608 4: 4102 bogomips: 20799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: ASUSTeK driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:9b41
class-ID: 0300
Device-2: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:2 chip-ID: 13d3:56a2
class-ID: 0e02 serial: <filter>
Display: server: X.Org v: 23.2.4 with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :1 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.00x11.26")
s-diag: 583mm (22.95")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x14e5 built: 2018 res: 1920x1080
hz: 60 dpi: 157 gamma: 1.2 size: 310x170mm (12.2x6.69") diag: 354mm (13.9")
ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.3-arch1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
device-ID: 8086:9b41 memory: 3.54 GiB unified: yes
API: Vulkan v: 1.3.274 layers: 3 device: 0 type: integrated-gpu name: Intel
UHD Graphics (CML GT2) driver: mesa intel v: 23.3.3-arch1.1
device-ID: 8086:9b41 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.3.3-arch1.1 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Comet Lake PCH-LP cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:02c8 class-ID: 0403
API: ALSA v: k6.7.0-zen3-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.1 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:4 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: no address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Local Storage: total: 476.94 GiB used: 23.4 GiB (4.9%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 005C temp: 33.9 C scheme: GPT
SMART: yes health: PASSED on: 206d 0h cycles: 1,535
read-units: 147,866,654 [75.7 TB] written-units: 63,279,060 [32.3 TB]
ID-1: / raw-size: 43.95 GiB size: 43.95 GiB (100.00%)
used: 23.04 GiB (52.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 29.3 MiB (5.7%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p6
maj-min: 259:6
ID-3: /home raw-size: 43.95 GiB size: 43.95 GiB (100.00%)
used: 23.04 GiB (52.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
ID-4: /var/log raw-size: 43.95 GiB size: 43.95 GiB (100.00%)
used: 23.04 GiB (52.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
ID-5: /var/tmp raw-size: 43.95 GiB size: 43.95 GiB (100.00%)
used: 23.04 GiB (52.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 3.63 GiB used: 3.2 GiB (88.1%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
ID-2: swap-2 type: partition size: 4.38 GiB used: 341.7 MiB (7.6%)
priority: -2 dev: /dev/nvme0n1p7 maj-min: 259:7
System Temperatures: cpu: 61.0 C pch: 55.0 C mobo: N/A
Fan Speeds (rpm): cpu: 1300
Processes: 244 Uptime: 1h 27m wakeups: 0 Memory: total: 4 GiB
available: 3.63 GiB used: 2.05 GiB (56.6%) igpu: 64 MiB Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1374 libs: 407 tools: octopi,paru Shell: garuda-inxi (sudo)
default: Bash v: 5.2.21 running-in: konsole inxi: 3.3.31
Garuda (2.6.22-1):
System install date:     2023-11-19
Last full system update: 2024-01-18 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Yes
Failed units:

So after startup and a few minutes of usage the animations including cursor movements become laggy, no latency but laggy as if the screen refresh rate had dropped to 30hz. I am on a UHD 630 which i believe is more than capable to handle any animations you throw on it as it can run older (~2017) AAA games smoothly.
lspci -k

00:02.0 VGA compatible controller: Intel Corporation CometLake-U GT2 [UHD Graphics] (rev 02)
DeviceName: VGA
Subsystem: ASUSTeK Computer Inc. CometLake-U GT2 [UHD Graphics]
Kernel driver in use: i915
Kernel modules: i915

Here is my dmesg View paste 7K2Q

Maybe too little RAM?

I am monitoring ram usage, sits well within 3GB

Be that as it may. I think the minimum requirement is a bit too weak to enjoy a full KDE.
But that’s just my personal experience.

1 Like

The ‘swoosh’ indicates you need to reboot. Please do so.

Agreed. It’s like pushing a heavy car uphill.


An apt analogy.

Thats the resource usage when its laggy

Do you have the same issue in x11?
Have you tried other kernels?


Sorry for the late reply, had a “issue” at my house coughs, anyways.
Yea i have tried linux-lts and X11 and the issue persists

If you are willing to try do you think you can go through this thread,

This is kinda a lot, a very big post but there is not a lot people can really suggest. Btw, have you tried other spins of garuda just to check if this is really a resource bottleneck as everyone says? Wouldn’t hurt to test that out before diving into the above labyrinth of troubleshooting.

Also wanna ask you are not using something like packagekit right? I have seen a few old posts where people had this installed and complained of slowdowns and removing it did the trick.

I would also suggest to check your journal logs to see if anything is coredumping or respawing continuously. Because if it is then that’s likely the cause of issue.


You left out some important info. Was this issue immediately apperent after you installed Garuda, or did it begin some time afterwards?

Have you tried disabling your compositor, or a bunch of KDE’s eye candy to see if it changes anything.

Does restarting plasma on X11 get rid of the lag temporarily?

I also tend to agree with others that 4 GB of ram is a little skimpy for good performance unless you disable many of KDE’s effects. I have used 4 GB of ram with Garuda on a desktop computer, and it ran OK after removing some of KDE’s effects. However, I have also installed Garuda KDE on older laptops with slightly more ram and they ran like a slug. I personally feel you can get away with 4 GB on a desktop computer, but on a laptop that’s pushing it, (uphill so to speak).

Try detuning KDE’s effects and let us know if it changes anything. Also, if you use an ephemeral paste service for your logs then that info is inaccessible a short period of time after you post it.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.