Error on booting "452 out of range"

I'm very new to linux so this may be a very obvious fix. I've been using Garuda for a month now with zero problems, it's the only OS installed on my PC. Today I try to boot up and get this error message before I can even get the OS running.

"Loading Linux linux-zen ...
452: out of range pointer: 0x87be7020
Aborted. Press any key to exit._"

I tried restarting and using one of the snapshots but it just brings me back to the same error.
Thanks for your help,

  • Clueless Noob
1 Like

Hi there, welcome to the community!

Firstly, try booting into a snapshot. Refer

Also, if it boots fine, restore snapshot and share output of

garuda-inxi

as text

2 Likes

I just tried that. Tried the most recent one, as well as several others going back more than a week. No matter which one I try, I just get looped back to the same error message.

According to this,
https://www.reddit.com/r/EndeavourOS/comments/wx8vt5/system_wont_boot_after_update/
it is another face of the GRUB issue

So, first thing to try is chroot from live USB and reinstall the grub.

1 Like

Snapshot restore worked for me - however you have to go into your bios and select a previous UEFI option for it to bypass the error you're describing, which I have been dealing with all morning on my laptop.

1 Like

There is an option to select for "UEFI firmware settings" in the boot menu... is that what you mean? If I select that it just takes me into the BIOS I'm not sure what it means to "select a previous UEFI option"

There are many bugs lately:

  • GPU driver issues (nVidia and AMD)
  • GRUB issues
  • issues with docker/KDE/Compositing (high chance it is related to the GPU driver issues..)
    :thinking: :thinking: :thinking:
2 Likes

Just try following this tutorial

1 Like

Ok i've got this tutorial pulled up on my laptop, sitting next to my linux computer. I've literally never used a terminal before I'm completely new to linux. I booted into the Garuda live USB, opened up a terminal and typed in lsblk -f, it printed out a bunch of stuff looks like it's listing the drives I have on my computer? In the tutorial it says to look for something starting with "/dev/" but I'm not seeing anything starting with /dev...?

1 Like

Can you post from the live USB the terminal input and output?

1 Like

Do you mean a picture of it like this? Or there is some way to actually send the entire text of it?

From the terminal you should shift+ctrl+C to Copy. Then past here.
Anyway

sudo mkdir -p /mnt/broken
sudo mount /dev/nvme0n1p2 /mnt/broken
sudo garuda-chroot /mnt/broken/@

Afterwards inside chroot

mount /dev/nvme0n1p1 /boot/efi
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
update-grub
3 Likes
╭─[email protected] in ~ as πŸ§™ 
╰─λ lsblk -f
NAME FSTYPE FSVER LABEL                  UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0
squash 4.0                                                                     0   100% /run/miso/sfs/livefs
loop1
squash 4.0                                                                     0   100% /run/miso/sfs/mhwdfs
loop2
squash 4.0                                                                     0   100% /run/miso/sfs/desktopfs
loop3
squash 4.0                                                                     0   100% /run/miso/sfs/rootfs
sda  iso966 Jolie GARUDA_DR460NIZEDGAMING_TALON
2022-07-17-09-17-44-00                     0   100% /run/miso/bootmnt
β”œβ”€sda1
β”‚    iso966 Jolie GARUDA_DR460NIZEDGAMING_TALON
β”‚                                        2022-07-17-09-17-44-00
└─sda2
vfat   FAT12 MISO_EFI               04A6-82CE
sr0  udf    1.02  JOHN_MAYER_ANY_GIVEN_THURSDAY
3e0785535f5f5f4d
zram0
[SWAP]
nvme0n1

β”œβ”€nvme0n1p1
β”‚    vfat   FAT32 NO_LABEL               5D38-F71C
└─nvme0n1p2
btrfs                               87a0d3a8-a8fd-4a06-9a5e-45c4ec78aff7
McFly: Importing shell history for the first time. This may take a minute or two...done.

╭─[email protected] in ~ as πŸ§™ took 3ms
╰─λ

Cool, I didn't know you could do that.
So I'm assuming I just type in the stuff you just posted starting with "sudo", and pressing enter after each line? I know this is super basic stuff I just don't want to mess anything up

1 Like
╭─[email protected] in ~ as πŸ§™ took 3ms
╰─λ sudo mkdir -p /mnt/broken

╭─[email protected] in ~ as πŸ§™ took 5ms
╰─λ sudo mount /dev/nvme0n1p2 /mnt/broken

╭─[email protected] in ~ as πŸ§™ took 65ms
╰─λ sudo garuda-chroot /mnt/broken/@
sh-5.1# mount /dev/nvme0n1p1 /boot/efi
sh-5.1# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
Installing for x86_64-efi platform.
Installation finished. No error reported.
sh-5.1# update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda-dr460nized/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-zen-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2022-08-26 21:32:32 | @/.snapshots/64/snapshot | post | dxvk-mingw-git garuda-hooks garuda-libs garuda-setup-assistant garuda-we |
Found snapshot: 2022-08-26 21:31:56 | @/.snapshots/63/snapshot | pre  | /usr/lib/packagekitd                                                     |
Found snapshot: 2022-08-25 21:27:46 | @/.snapshots/62/snapshot | post | ananicy-rules-git btrfs-assistant cups-filters dxvk-mingw-git ethtool fi |
Found snapshot: 2022-08-25 21:27:41 | @/.snapshots/61/snapshot | pre  | /usr/lib/packagekitd                                                     |
Found snapshot: 2022-08-24 00:13:35 | @/.snapshots/60/snapshot | post | ananicy-rules-git bolt dxvk-mingw-git geoip-database lib32-mangohud paho |
Found snapshot: 2022-08-24 00:13:34 | @/.snapshots/59/snapshot | pre  | /usr/lib/packagekitd                                                     |
Found snapshot: 2022-08-22 22:07:10 | @/.snapshots/58/snapshot | post | akonadi-mime ark baloo-widgets binutils bomber bovo btrfs-assistant ca-c |
Found snapshot: 2022-08-22 22:06:41 | @/.snapshots/57/snapshot | pre  | /usr/lib/packagekitd                                                     |
Found snapshot: 2022-08-18 20:12:41 | @/.snapshots/56/snapshot | post | ananicy-rules-git bind bluetooth-support brave-bin btrfs-progs candy-ico |
Found snapshot: 2022-08-18 20:12:14 | @/.snapshots/55/snapshot | pre  | /usr/lib/packagekitd                                                     |
Found snapshot: 2022-08-15 22:00:33 | @/.snapshots/54/snapshot | post | attica baloo bluez-qt brave-bin breeze-icons cifs-utils cython dhclient  |
Found snapshot: 2022-08-15 22:00:28 | @/.snapshots/53/snapshot | pre  | /usr/lib/packagekitd                                                     |
Found 12 snapshot(s)
Unmount /tmp/grub-btrfs.5UgQur7p7c .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
done
sh-5.1#

ok I typed in all that stuff and this is where it took me, does this mean I can boot up normally now?

1 Like

Yes go on.
I edited your post for proper formatting.
Like this
~~~
Text
~~~

3 Likes

Now enter exit and reboot removing the USB.
:crossed_fingers:

Nice! I'm back to my normal desktop now.
Is there something I should do different to prevent that happening again? Was it just some problem with updates?
Thanks for your help

2 Likes

It is a bug in the latest update of the GRUB package "upstream"... It happens...

2 Likes

So should I wait for awhile to do another update? Or is that fixed by now?

Ok so I just restarted my computer again and back to the same error message...
do I have to go through this entire process every time I start my computer now? Until this bug is fixed? That can't be right