Strange bricked boot/grub issue consitently happening almost all reboots

Hi there, I have a very bizarre issue that has been consistent for quite some time now. At first, it would boot into a post screen saying

“Loading Linux linux-zen …
452: out of range pointer: 0x87be7020
Aborted. Press any key to exit._”

and I was able to fix it thanks to this lovely forum post htps://forum.garudalinux.org/t/error-on-booting-452-out-of-range/22109/

However, recently it started occurring more often, especially after long periods of PC usage. If I use my PC for many hours and then turn it off, the likelihood of the issue appearing is quite high.

This no longer gives me any post errors or messages, it simply freezes on my bios logo screen being completely unresponsive. I can’t enter bios and can’t input anything. What I have to do is turn off the PC, unplug both of my system drives, plug in a live ventoy bootdrive with garuda on it, turn it on and then it off once on the ventoy screen. Once that is done, I plug in my drives and this somehow refreshes my uefi and gets me into the next screen. After, I can get past the bios/into the bios but I then get a new message error at post.

Booting -garuda linux
Loading linux linux-zen …
error: symbol -grub_is_shim_lock_enabled" not found
loading initial ramdisk…

error: symbol -grub_is_shim_lock_enabled" not found.
press any key to continue
failed to boot both default and failback entries
press any key to continue.

No snapshots work at this point
I update my PC quite regularly but I have slowed down because after every update it would cause the issue to appear again and I would have to manually update grub every time.

I have read the wiki and searched this issue online numerous times but I can never seem to find a long term solution, it always tells me to chroot and update grub. Which I always do but it is only a temporary fix until the next boot. What is strange is that this issue happens unprovoked. I can go a few days without upgrades/installing any updates and it would still happen making me believe this is not linked to garuda-update.
I tried many forum posts on here too. Like this one Error on booting "452 out of range" - #11 by advancedcaveman and this one Can't boot after update: symbol 'grub_is_shim_lock_enabled' not found But they don’t seem to cover a long term solution.

Including the steps above, this is what I have to do in a live garuda session every time

sudo mkdir -p /mnt/broken
sudo mount /dev/sdb2 /mnt/broken
sudo garuda-chroot /mnt/broken/@
mount /dev/sdb1 /boot/efi
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
update-grub

I am quite at a loss here. Any ideas? Thanks a lot.
Edit: As I rebooted to get a fresh inxi, it happened again and I had to liveboot. Any help will be greatly appreciated.

System:
Kernel: 6.7.6-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=bec9422a-d102-4b77-900d-522e97b1d1f8 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
v: 5.115.0 wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Desktop System: ASUS product: All Series v: N/A
serial: <superuser required>
Mobo: ASUSTeK model: Z97-P v: Rev X.0x serial: <superuser required>
part-nu: All uuid: <superuser required> UEFI: American Megatrends v: 2907
date: 03/11/2016
CPU:
Info: model: Intel Core i5-4690K bits: 64 type: MCP arch: Haswell
gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 3718 high: 3735 min/max: 800/3900 scaling:
driver: intel_cpufreq governor: performance cores: 1: 3734 2: 3707 3: 3698
4: 3735 bogomips: 27984
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Sapphire driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands
process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: HDMI-A-1 empty: DP-1, DP-2, DVI-D-1, HDMI-A-2
bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300 temp: 34.0 C
Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Sony TV serial: <filter>
built: 2010 res: 1920x1080 hz: 60 dpi: 30 gamma: 1.2
size: 1600x900mm (62.99x35.43") diag: 1836mm (72.3") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.2-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 580 Series (radeonsi
polaris10 LLVM 16.0.6 DRM 3.57 6.7.6-zen1-2-zen) device-ID: 1002:67df
memory: 3.91 GiB unified: no
API: Vulkan v: 1.3.276 layers: 14 device: 0 type: discrete-gpu name: AMD
Radeon RX 580 Series (RADV POLARIS10) driver: mesa radv v: 24.0.2-arch1.1
device-ID: 1002:67df surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 24.0.2-arch1.1 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel 9 Series Family HD Audio vendor: ASUSTeK 9
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8ca0
class-ID: 0403
Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Sapphire driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403
API: ALSA v: k6.7.6-zen1-2-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK AM1I-A driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
IF-ID-2: ztyouusv64 state: unknown speed: 10000 Mbps duplex: full
mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd
Drives:
Local Storage: total: 2.29 TiB used: 415.67 GiB (17.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD2003FZEX-00Z4SA0 size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s tech: N/A serial: <filter> fw-rev: 1E.8
scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 3B6Q scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Kingston model: DataTraveler 3.0
size: 14.41 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 415.67 GiB (89.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 596 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 415.67 GiB (89.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 415.67 GiB (89.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 415.67 GiB (89.3%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.56 GiB used: 13.2 MiB (0.1%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 36.0 C mobo: N/A gpu: amdgpu temp: 35.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 1761
Info:
Memory: total: 16 GiB available: 15.56 GiB used: 2.04 GiB (13.1%)
Processes: 260 Power: uptime: 0m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.19 GiB services: org_kde_powerdevil,upowerd
Init: systemd v: 255 default: graphical tool: systemctl
Packages: pm: pacman pkgs: 2307 libs: 617 tools: octopi,pamac,paru
pm: flatpak pkgs: 0 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: garuda-inxi
default: Bash v: 5.2.26 running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2022-12-01
Last full system update: 2024-03-01
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       No/Undetected
Failed units:            preload.service [email protected]

Have you tried just running the lts kernel

2 Likes

I have not actually, would that be a good idea? Can give it a go if it does not cause further issues

grub_is_shim_lock_enabled gives some search results, also on Arch BBS.
e.g. GRUB update - symbol "grub_is_shim_lock_enabled" not found / Pacman & Package Upgrade Issues / Arch Linux Forums ← page 2, last two comments
(I actually have no idea though, my potato does not UEFI)

5 Likes

Please do and report back with your finding.

2 Likes

Gonna give this a go, thank you for your suggestion. Will report as soon as I can

I have this one actually bookmarked. Bit overwhelming for me at the moment but will definitely will be giving these suggestions a go if the LTS kernel does not fix it.

Which directories would be safe to remove on garuda as suggested in that post? I do not have the technical knowhow to retrace their steps without a guide. Do not want to accidentally remove something vital.

Thanks for reminding me about this though

I have changed my kernel to LTS and gave it a few test reboots and so far so good. Will report back after longer usage/updates this weekend.

I might want to install & run MEMTEST for 18-24 hrs, see if the RAM is flaky or not.

Is 2016 the latest BIOS available for your rig?

EDIT: Is fastboot/fast boot disabled in your BIOS? And SecureBoot?

1 Like

Sadly yes 2016 is the latest.

And correct just double checked - both disabled

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.