Can't boot after update: symbol 'grub_is_shim_lock_enabled' not found

Hello, I updated yesterday using garuda-update and i am stuck in grub. Here is the full error afer selecting any option in grub:

Loading Linux linux-zen
error: symbol grub_is_shim_lock_enabled' not found
Loading initial ramdisk
error: symbol 'grub_is_shim_lock_enabled' not found

Press any key to continue...

System Info:

  • Latest Garuda GNOME
  • Linux-zen kernel (also tried with linux-lts w/ same error)
  • root and home drive is btrfs

Things i have tried:

  1. Restoring from snapshot or rebooting with any advanced option
  • Unable to restore any snapshot. Same error as above.
  • All advanced options give the same error
  1. Live ISO Chroot
  • Chroot into system: garuda-update and sudo update-grub and reinstalled linux-zen and linux-lts kernels wih no luck. Same error.
  • mkinitcpio -p linux-zen linux-lts gives the same error on reboot.
  1. Live ISO boot repair
  • Same error as above.
  1. Research similar topics: shim lock
  • It seems like it has something to do with secure boot, but secure boot has always been disabled in my BIOS settings...
  • I cant find this exact error anywhere...

If anyone has any other ideas, please reach out. Thank you.

It looks like many people have had the same issue yesterday.

Accoriding to @pebcak from the endevourOS forums:
The solution is going into chroot and running grub-install --efi-directory=/boot/efi

The additional flag --efi-directory=/boot/efi is required

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.