Stuck in boot loop after update

Hi Garuda Users,
I am using a Dell XPS 9510 with an encrypted Garuda install. After the latest update (through Garuda Assistant) I can't get even get to Grub anymore. I can enter my decryption key, but right when "Slot0 opened" the laptop shuts down and reboots into Bios.
All I can do is change Bios settings or enter a wrong decryption key and interact with Grub rescue.
Any idea what's wrong?
Thanks.

1 Like

I Had same problem after Update grub => 2:2.06.r322.gd9b.. so i think its a bug on the grub update

my solution was but live iso and then restored a snapshot and put grub to IgnorePkg on pacman.conf.

10 Likes

Welcome @zoneid :slight_smile:

pacman -Qi grub
Name                     : grub
Version                  : 2:2.06.r322.gd9b4638c5-1

No problem here, with unencrypted system.

5 Likes

Thanks @smoky I have repaired my system and broke it again, just to confirm the issue. I also think it's due to the bug @SGS mentioned. I'll create an account there and leave a vote to increase the visibility of the issue.
I really love Garudas BTRFS snapshots. So far I could always restore the backups from Grub, but I am glad to experience, that it even works when Grub is broken.

4 Likes

There actually is something going on with the latest grub update. It is causing multiple systems to be unbootable. There's a thread stuck at the top of the endeavouros forum about it. No one has figured out is it grub, os-prober, or grub customizer related. On my arch plasma install i have zero issues. Most people are working around the problem by chrooting in and downgrading grub.

4 Likes

Weird thing is, I'm also having a FDE setup which requires me to enter my encryption password before going to the GRUB screen - no issues even with updated GRUB :eyes:

https://bbs.archlinux.org/viewtopic.php?id=279006

3 Likes

Got this issue to I fixed it by booting in a live cd and chroot into my system by following How to chroot Garuda Linux , mounted my efi partition to /boot/efi/ from whithin the chroot and did the following /usr/bin/grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id="Garuda"
and while I got a booting system i get a bunch of werid errors in grub and all my extra boot options (including snapshots) are gone

garuda-inxi
System:
  Kernel: 5.19.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=53e270ad-dfd5-4874-a125-69d21ada6b8d rw [email protected]
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
    sysrq_always_enabled=1 amdgpu.ppfeaturemask=0xffffffff nowatchdog
    nmi_watchdog=0
  Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASRock model: X470 Taichi serial: <superuser required>
    UEFI: American Megatrends v: P4.90 date: 05/18/2022
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
CPU:
  Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3 gen: 4
    built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x21 (33)
    stepping: 2 microcode: 0xA20120A
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 3686 high: 4614 min/max: 2200/4650 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3633 2: 3661
    3: 3593 4: 3590 5: 3598 6: 3590 7: 3589 8: 4614 9: 3595 10: 3588 11: 3600
    12: 3587 bogomips: 88813
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M]
    vendor: Gigabyte driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: DP-1,HDMI-A-1 empty: DP-2,HDMI-A-2
    bus-ID: 10:00.0 chip-ID: 1002:73df class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
    alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 6505x2160 s-dpi: 120 s-size: 1376x457mm (54.17x17.99")
    s-diag: 1450mm (57.08")
  Monitor-1: DP-1 mapped: DisplayPort-0 pos: primary,left model: LG
    (GoldStar) HDR WFHD serial: <filter> built: 2021 res: 2560x1080 dpi: 81
    gamma: 1.2 size: 798x334mm (31.42x13.15") diag: 869mm (34.2") modes:
    max: 2560x1080 min: 640x480
  Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: right model: Samsung
    serial: <filter> built: 2019 res: 3840x2160 hz: 60 dpi: 52 gamma: 1.2
    size: 1872x1053mm (73.7x41.46") diag: 1093mm (43") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  OpenGL: renderer: AMD Radeon RX 6700 XT (navy_flounder LLVM 14.0.6 DRM
    3.47 5.19.3-zen1-1-zen) v: 4.6 Mesa 22.1.6 direct render: Yes
Audio:
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 10:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 12:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound Server-1: ALSA v: k5.19.3-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 08:00.0
    chip-ID: 8086:24fb class-ID: 0280
  IF: wlp8s0 state: down mac: <filter>
  Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 0a:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
  Device-1: Edimax Bluetooth Adapter type: USB driver: btusb v: 0.8
    bus-ID: 1-8:5 chip-ID: 7392:c611 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 2.96 TiB used: 3.73 TiB (126.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:4 vendor: Samsung model: SSD 980 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 1B4QFXO7
    temp: 36.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO
    250GB size: 232.89 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7
    temp: 36.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DX002-2DV164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC41 scheme: GPT
Partition:
  ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 724.37 GiB
    (77.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:6
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 16.7 MiB
    (5.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:5
  ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 724.37
    GiB (77.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:6
  ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 724.37
    GiB (77.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:6
  ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 724.37
    GiB (77.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:6
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.27 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 44.0 C mobo: 35.0 C gpu: amdgpu temp: 54.0 C
    mem: 54.0 C
  Fan Speeds (RPM): cpu: 1670 fan-1: 0 fan-3: 1309 fan-4: 1470 fan-5: 1215
    gpu: amdgpu fan: 0
  Power: 12v: N/A 5v: N/A 3.3v: 3.22 vbat: 3.28 gpu: amdgpu watts: 31.00
Info:
  Processes: 424 Uptime: 6m wakeups: 2 Memory: 31.27 GiB used: 10.15 GiB
  (32.5%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 2437 pacman: 2415 lib: 586
  flatpak: 22 Shell: fish v: 3.5.1 default: Bash v: 5.1.16
  running-in: alacritty inxi: 3.3.20
Garuda (2.6.6-1):
  System install date:     2022-05-22
  Last full system update: 2022-08-25
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            systemd-networkd-wait-online.service

EDIT: errors say "out of memory" and "syntax error"

1 Like

Shortly after this issue was discovered, we put in place an update lock on grub so this doesn't break countless systems.

This update lock was now removed, and grub will now be automatically and properly updated to the latest version during a system update. For me, this updated a 2 years old grub version to the latest version :laughing:

image

7 Likes

getting this error after updating:

Update notices:
The GRUB bootloader could not be updated automatically. Please reinstall it manually, otherwise the system may
face a bootloop that has to be resolved from a setup ISO.

Post the output of efibootmgr and sudo pacman -S grub please.

3 Likes
λ efibootmgr
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0004,0005
Boot0004* UEFI OS       HD(1,GPT,b8a1b722-25d6-d54a-bee6-49821803685e,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)0000424f
Boot0005* UEFI OS       HD(1,GPT,f2ae0764-517e-594b-80ee-0b995d6427f0,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)0000424f
λ sudo pacman -S grub
[sudo] password for ace:
warning: grub-2:2.06.r322.gd9b4638c5-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) grub-2:2.06.r322.gd9b4638c5-1

Total Installed Size:  33.02 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                     [------------------------------------] 100%
(1/1) checking package integrity                                   [------------------------------------] 100%
(1/1) loading package files                                        [------------------------------------] 100%
(1/1) checking for file conflicts                                  [------------------------------------] 100%
(1/1) checking available disk space                                [------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 315
:: Processing package changes...
(1/1) reinstalling grub                                            [------------------------------------] 100%
:: Running post-transaction hooks...
( 1/11) Enabling os-prober...
( 2/11) Arming ConditionNeedsUpdate...
( 3/11) Refreshing PackageKit...
( 4/11) Updating grub binary in EFI


!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

The GRUB bootloader could not be updated automatically.
Please reinstall it manually, otherwise the system may face a bootloop that has to be resolved from a setup ISO.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Waiting 10 seconds.

( 5/11) Foreign/AUR package notification
blasphemer-wad 0.1.7-1
chexquest3-wad 1.4-1
doom1-wad 1.9-3
frozen-bubble 2.2.1beta1-17
hacx-wad 1.2-2
harmony-wad 1.1-3
heretic1-wad 1.2-2
hexen1-wad 1.1-1
kipi-plugins 21.12.3-1
libkipi 21.12.3-1
perl-alien-sdl 1.446-12
perl-sdl 2.548-6
samba-mounter-git 186.29ebad4-1
sdl_pango 0.1.2-8
square1-wad 2.0-1
strife0-wad 1.1-1
urbanbrawl-wad 1.0-1
( 6/11) Fix 'grub' and 'os-prober'
( 7/11) Orphaned package notification...
asciidoc 10.2.0-1
bluetooth-autoconnect 1.3-1.1
ceph-libs 15.2.14-6
deutex 5.2.2-3
gtest 1.12.1-1
gtksourceview5 5.4.2-1
js78 78.15.0-4
ntp 4.2.8.p15-1
( 8/11) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/locale.gen.pacnew
/etc/pacman.d/mirrorlist.pacnew
/etc/paru.conf.pacnew
/etc/retroarch.cfg.pacnew
Please check and merge
( 9/11) Updating the info directory file...
(10/11) Performing snapper post snapshots for the following configurations...
==> root: 316
(11/11) Syncing all file systems...

[email protected] in ~ as 🧙 took 20s
λ

Run sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id="Garuda" to update your grub.

Did you ever use Garuda boot repair or something similar?

3 Likes
λ sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id="Garuda"
[sudo] password for ace:
Installing for x86_64-efi platform.
Installation finished. No error reported.

Seems like that completed fine.

Also I haven't used any boot repair or anything similar to that.

Should I try a restart now to test the GRUB fix?

1 Like

Go right ahead!

3 Likes

after putting in my password for LUKS, I got this error.

error: symbol 'grub_debug_malloc' not found.
Entering rescue mode...
grub rescue>

I guess I should try a different way to repair this?

Hi everybody

Same issue here
I boot on a USB Garuda Live and use the GUI Grub Repair Tool
after reboot seems good I'm on my beloved garuda

2 Likes

Sadly, I have tried to repair or reinstall the Grub with a Garuda USB (using the option for EFI), and it only seemed to make matters worse.

After trying to fix the GRUB, I can't even boot that Garuda's installation directly from the BIOS screen (which I was able to do before I attempted to fix GRUB via the install media.) . It now just spits out the same error I've posted prior: error: symbol 'grub_debug_malloc' not found. (either that or it doesn't do anything after I get past unlocking LUKS and just freezes up)

I am unsure what exactly I could have done wrong, but I remember while trying to reinstall GRUB that the output was saying that OS-prober couldn't find an "overlay" of some kind if I remember correctly...
Edit: here was the error: Installing for x86_64-efi platform. Installation finished. No error reported. /usr/bin/grub-probe: error: failed to get canonical path of 'overlay'.

erf' maybe try this ? after grub-reinstallation
https://bbs.archlinux.org/viewtopic.php?id=257865

grub-mkconfig -o boot/grub/grub.cfg

Well... In my hasty late-night and into the morning troubleshooting I forgot I restored a snapshot after things was really going bad so I could at least get BIOS to boot into Garuda directly (mainly so I could make a new Garuda boot media, only had an Wayland ISO on hand on my recently remade Ventoy USB lol). After reinstalling GRUB via a Garuda USB (using its tools from the Garuda Welcome menu, and reinstalling GRUB for EFI) and restoring to a snapshot right after I installed GRUB, things seem to work fine now! :sweat_smile:

Edit: Just wanted to note here that after doing garuda-update it still has the GRUB warning from before about not being able to automatically do its thing, but even after rebooting things still work fine for me.

3 Likes

hello, I am having the same problem, I chrooted garuda and followed the guide. nothing changed it still boots into bios, have tried this 2 times following different guides and none of them worked. no errors were given during the grub update. What should I do?