Stuck in boot loop after update

How was your grub install different from the one I told you to do? :eyes:


Need some more info here. Need at least your garuda-inxi as well as efibootmgr.


Hey @edu4rdshl I think you owe me a burger??


Hmm, what about you? What did your update messages say? Success or failure?

1 Like

rechrooted it to execute what you asked

  12Kernel 5.18.16-zen1-1-zen 12arch x86_64 12bits 64 12compiler gcc 12v 12.1.1
    12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda
    misolabel=GARUDA_GNOME_TALON quiet systemd.show_status=1 driver=nonfree nouveau.modeset=0
    i915.modeset=1 radeon.modeset=1
  12Console N/A 12wm gnome-shell 12Distro Garuda Linux 12base Arch Linux
  12Type Laptop 12System Razer 12product Book 13 - RZ09-0357 12v 0.04 12serial <filter> 12Chassis 12type 10
    12serial N/A
  12Mobo Razer 12model MA310 12v 4 12serial N/A 12UEFI Razer 12v 2.00 12date 11/20/2020
  12ID-1 BAT0 12charge 26.1 Wh (45.1%) 12condition 57.9/55.2 Wh (104.8%) 12volts 12.4 12min 11.6
    12model Razer Blade 12type Unknown 12serial <filter> 12status charging
  12Info 12model 11th Gen Intel Core i7-1165G7 12socket U3E1 12bits 64 12type MT MCP 12arch Tiger Lake
    12gen core 11 12built 2020 12process Intel 10nm 12family 6 12model-id 0x8C (140) 12stepping 1 12microcode 0xA4
  12Topology 12cpus 1x 12cores 4 12tpc 2 12threads 8 12smt enabled 12cache 12L1 320 KiB 12desc d-4x48 KiB; i-4x32
    KiB 12L2 5 MiB 12desc 4x1.2 MiB 12L3 12 MiB 12desc 1x12 MiB
  12Speed (MHz) 12avg 1291 12high 1302 12min/max 400/4700 12base/boost 2800/4700 12scaling
    12driver intel_pstate 12governor powersave 12volts 0.7 V 12ext-clock 100 MHz 12cores 121 1301 122 1301 123 1301
    124 1301 125 1277 126 1250 127 1302 128 1301 12bogomips 44851
  12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  12Type itlb_multihit 12status Not affected
  12Type l1tf 12status Not affected
  12Type mds 12status Not affected
  12Type meltdown 12status Not affected
  12Type mmio_stale_data 12status Not affected
  12Type retbleed 12status Not affected
  12Type spec_store_bypass 12mitigation Speculative Store Bypass disabled via prctl
  12Type spectre_v1 12mitigation usercopy/swapgs barriers and __user pointer sanitization
  12Type spectre_v2 12mitigation Enhanced IBRS, IBPB: conditional, RSB filling
  12Type srbds 12status Not affected
  12Type tsx_async_abort 12status Not affected
  12Device-1 Intel TigerLake-LP GT2 [Iris Xe Graphics] 12vendor Razer USA 12driver i915 12v kernel
    12arch Gen-12.1 12process Intel 10nm 12built 2020-21 12ports 12active eDP-1 12empty DP-1, DP-2, DP-3, DP-4,
    DP-5, HDMI-A-1 12bus-ID 00:02.0 12chip-ID 8086:9a49 12class-ID 0300
  12Device-2 IMC Networks Integrated Camera 12type USB 12driver uvcvideo 12bus-ID 3-1:2
    12chip-ID 13d3:5447 12class-ID fe01 12serial <filter>
  12Display 12server 12v 12with Xwayland 12v 22.1.3 12compositor gnome-shell 12driver 12X
    12loaded modesetting 12alternate fbdev,intel,vesa 12gpu i915 12display-ID :0
  12Monitor-1 eDP-1 12model Sharp LQ134N1JW48 12built 2020 12res 1920x1200 12dpi 169 12gamma 1.2
    12size 288x180mm (11.34x7.09") 12diag 340mm (13.4") 12ratio 16:10 12modes 1920x1200
  12Message Unable to show GL data. Required tool glxinfo missing.
  12Device-1 Intel Tiger Lake-LP Smart Sound Audio 12vendor Razer USA 12driver sof-audio-pci-intel-tgl
    12bus-ID 00:1f.3 12chip-ID 8086:a0c8 12class-ID 0401
  12Sound Server-1 ALSA 12v k5.18.16-zen1-1-zen 12running yes
  12Sound Server-2 PulseAudio 12v 16.1 12running no
  12Sound Server-3 PipeWire 12v 0.3.56 12running yes
  12Device-1 Intel Wi-Fi 6 AX201 12driver iwlwifi 12v kernel 12bus-ID 00:14.3 12chip-ID 8086:a0f0
    12class-ID 0280
  12IF wlo1 12state up 12mac <filter>
  12Device-1 Intel AX201 Bluetooth 12type USB 12driver btusb 12v 0.8 12bus-ID 3-10:6 12chip-ID 8087:0026
    12class-ID e001
  12Report bt-adapter 12ID hci0 12rfk-id 0 12state up 12address N/A
  12Local Storage 12total 252.8 GiB 12used 17 GiB (6.7%)
  12SMART Message Required tool smartctl not installed. Check --recommends
  12ID-1 /dev/nvme0n1 12maj-min 259:0 12model NVMe CA5-8D256 12size 238.47 GiB 12block-size 12physical 512 B
    12logical 512 B 12speed 31.6 Gb/s 12lanes 4 12type SSD 12serial <filter> 12rev CQ20904 12temp 38.9 C
  12ID-2 /dev/sda 12maj-min 8:0 12type USB 12vendor SanDisk 12model Cruzer Blade 12size 14.33 GiB 12block-size
    12physical 512 B 12logical 512 B 12type N/A 12serial <filter> 12rev 1.00
  12ID-1 / 12raw-size 39.06 GiB 12size 39.06 GiB (100.00%) 12used 17 GiB (43.5%) 12fs btrfs
    12block-size 4096 B 12dev /dev/nvme0n1p5 12maj-min 259:5
  12Kernel 12swappiness 133 (default 60) 12cache-pressure 100 (default)
  12ID-1 swap-1 12type zram 12size 15.39 GiB 12used 0 KiB (0.0%) 12priority 100 12dev /dev/zram0
  12System Temperatures 12cpu 40.0 C 12mobo N/A
  12Fan Speeds (RPM) N/A
  12Processes 267 12Uptime 4m 12wakeups 1 12Memory 15.39 GiB 12used 2.14 GiB (13.9%) 12Init systemd 12v 251
    12default graphical 12tool systemctl 12Compilers 12gcc 12.2.0 12Packages 12pacman 1258 12lib 341 12Client Unknown
  Client: kthreadd 12inxi 3.3.20
Garuda (2.6.6-1):
head: cannot open '/var/log/pacman.log' for reading: No such file or directory
  System install date:
  Last full system update: 2022-08-25
  Is partially upgraded:   No
  Relevant software:       NetworkManager connman
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
Running in chroot, ignoring command 'list-units'
  Failed units:
BootCurrent: 0003
Timeout: 2 seconds
BootOrder: 0001,0000,0003,0002
Boot0000* Windows Boot Manager	HD(2,GPT,f36669ed-e25c-42c5-965c-7c54c6f40ac9,0x203a800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d0000002c000100000010000000040000007fff0400
Boot0001* garuda	HD(2,GPT,f36669ed-e25c-42c5-965c-7c54c6f40ac9,0x203a800,0x32000)/File(\EFI\GARUDA\GRUBX64.EFI)
Boot0002  Nitrux	HD(2,GPT,f36669ed-e25c-42c5-965c-7c54c6f40ac9,0x203a800,0x32000)/File(\EFI\NITRUX\SHIMX64.EFI)
Boot0003* UEFI: SanDisk	PciRoot(0x0)/Pci(0x14,0x0)/USB(2,0)/CDROM(1,0x4871c4,0x8000)0000424f

I'm actually not using nitrux anymore but it still shows up,
when I boot into you just get the grub command line. garuda was working fine, so I don't think that has to do with the problem. the sandisk pciroot is the live usb I am booted into

tried it again and noticed it says

 umount: /mnt/broken/@: target is busy.

when typing exit, so I just tired unmounted it manually, but that didn't work, do I just reboot while leaving it mounted?

solved it. after the 6th try, I saw that I never executed grubx update. it all works now

After the update, got some message of "memory error" on reboot and grub was ugly, plain white. Garuda started OK, though.

Rebooted again and everything was normal... :nerd_face:

so how do I get a fully working system now? Like I said I was able to boot into my system but I get a bunch of grub errors and only one boot option (snapshots and everything else is gone)

I launched

sudo pacman -S grub 

and after

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id="Garuda" 

and after sprezzante del pericolo e sfidando la sorte ( contemptuous of danger and tempting fate) I made a reboot.

I am here. All (I hope) works fine.



Ok so sorta fixed it somehow by restoring a snapshot before this whole mess but then grub would not boot after restoring the snapshot. So I redid the instructions chroot instructions linked above.
But now I have several problems

  1. Grub now takes forever to boot about 2 minutes

  2. It is still showing those errors that it was showing before.

  3. I got all my boot options back (before they're were missing but I can't select anything it will just auto boot my default choice

..... I hate grub

EDIT: new garuda-inxi

  Kernel: 5.19.4-269-tkg-bmq arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: intel_pstate=passive
    root=UUID=53e270ad-dfd5-4874-a125-69d21ada6b8d rw [email protected]
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
    sysrq_always_enabled=1 amdgpu.ppfeaturemask=0xffffffff nowatchdog
  Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: X470 Taichi serial: <superuser required>
    UEFI: American Megatrends v: P4.90 date: 05/18/2022
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3 gen: 4
    built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x21 (33)
    stepping: 2 microcode: 0xA20120A
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 4161 high: 4543 min/max: 2200/4650 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 4500 2: 4517
    3: 4028 4: 4517 5: 3924 6: 3605 7: 4525 8: 4503 9: 3610 10: 4543 11: 4063
    12: 3601 bogomips: 88899
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M]
    vendor: Gigabyte driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: DP-1,HDMI-A-1 empty: DP-2,HDMI-A-2
    bus-ID: 10:00.0 chip-ID: 1002:73df class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
    alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 6505x2160 s-dpi: 120 s-size: 1376x457mm (54.17x17.99")
    s-diag: 1450mm (57.08")
  Monitor-1: DP-1 mapped: DisplayPort-0 pos: primary,left model: LG
    (GoldStar) HDR WFHD serial: <filter> built: 2021 res: 2560x1080 dpi: 81
    gamma: 1.2 size: 798x334mm (31.42x13.15") diag: 869mm (34.2") modes:
    max: 2560x1080 min: 640x480
  Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: right model: Samsung
    serial: <filter> built: 2019 res: 3840x2160 hz: 60 dpi: 52 gamma: 1.2
    size: 1872x1053mm (73.7x41.46") diag: 1093mm (43") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  OpenGL: renderer: AMD Radeon RX 6700 XT (navy_flounder LLVM 14.0.6 DRM
    3.47 5.19.4-269-tkg-bmq) v: 4.6 Mesa 22.1.7 direct render: Yes
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 10:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 12:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound Server-1: ALSA v: k5.19.4-269-tkg-bmq running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 08:00.0
    chip-ID: 8086:24fb class-ID: 0280
  IF: wlp8s0 state: down mac: <filter>
  Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 0a:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
  Device-1: Edimax Bluetooth Adapter type: USB driver: btusb v: 0.8
    bus-ID: 1-8:6 chip-ID: 7392:c611 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
  Local Storage: total: 3.87 TiB used: 3.73 TiB (96.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:4 vendor: Samsung model: SSD 980 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 1B4QFXO7
    temp: 36.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO
    250GB size: 232.89 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7
    temp: 38.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DX002-2DV164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC41 scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 type: USB vendor: Western Digital
    model: WD10EURX-63UY4Y0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B type: HDD rpm: 5400 serial: <filter> scheme: GPT
  ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 728.25 GiB
    (78.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:6
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 16.7 MiB
    (5.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:5
  ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 728.25
    GiB (78.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:6
  ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 728.25
    GiB (78.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:6
  ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 728.25
    GiB (78.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:6
  Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
  ID-1: swap-1 type: zram size: 31.27 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 61.9 C mobo: 36.0 C gpu: amdgpu temp: 55.0 C
    mem: 56.0 C
  Fan Speeds (RPM): cpu: 2410 fan-1: 0 fan-3: 1319 fan-4: 1503 fan-5: 1230
    gpu: amdgpu fan: 0
  Power: 12v: N/A 5v: N/A 3.3v: 3.18 vbat: 3.28 gpu: amdgpu watts: 31.00
  Processes: 430 Uptime: 10m wakeups: 2 Memory: 31.27 GiB used: 13.5 GiB
  (43.2%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 2441 pacman: 2419 lib: 588
  flatpak: 22 Shell: fish v: 3.5.1 default: Bash v: 5.1.16
  running-in: alacritty inxi: 3.3.20
Garuda (2.6.6-1):
  System install date:     2022-05-22
  Last full system update: 2022-08-26
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            shadow.service systemd-networkd-wait-online.service

EDIT2: tried reinstalling grub, os-prober and all related stuff (took from the dependices of garuda-grub

and got this

1 Like

Please run efibootmgr

BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,000A,0005,000B,0001
Boot0000* rEFInd Boot Manager	HD(1,GPT,51359687-0157-a847-beda-4d18b6ee56df,0x1000,0x96000)/File(\EFI\REFIND\REFIND_X64.EFI)
Boot0001  Garuda	HD(1,GPT,51359687-0157-a847-beda-4d18b6ee56df,0x1000,0x96000)/File(\EFI\GARUDA\GRUBX64.EFI)
Boot0005  Nobara	HD(1,GPT,3aa22cc4-d401-4deb-b152-6744a6f83f63,0x800,0x12c000)/File(\EFI\FEDORA\SHIMX64.EFI)
Boot000A  UEFI OS	HD(1,GPT,51359687-0157-a847-beda-4d18b6ee56df,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)0000424f
Boot000B  Fedora	HD(1,GPT,3aa22cc4-d401-4deb-b152-6744a6f83f63,0x800,0x12c000)/File(\EFI\FEDORA\SHIM.EFI)0000424f

Oh, you're booting grub from rEFInd?

yea I need to because for some reason when I set the ultra-fast boot option in my bios it breaks keyboard support in grub if I boot grub first. refind somehow fixes that :person_shrugging: . plus refind looks cooler :rofl:

now that you point it out it could be refind mucking up the grub-install and the hooks

OH. That explains why you ended up in this situation in the first place.


The GRUB bootloader could not be updated automatically.
Please reinstall it manually, otherwise the system may face a bootloop that has to be resolved from a setup ISO.

Waiting 10 seconds.

But.. How did you miss this message? It's written in red with sooo many exclamation points.
I'll look into fixing this.


what originally? i did the update before it was even held back in the garuda-update when I was trying to fix latte-dock then i pop in on the telegram to post it was a wayland issue and I see everyone complaing about grub and was like oh oh :sweat_smile:

You would have been fine if it weren't for rEFInd.

yeah, prob shouldn't have mixed two bootloaders. i think I'm just going to remove grub as my system is just to slow to boot without the bios option and grub doesn't work with that

No, please keep it. Pffff. Just have a bit of patience, I'm working on some changes.