Stucks at Terminating Plymouth Boot Screen while using Proprietary (Nvidia) driver

Whenever I try to install Garuda Dragonized Gaming Edition [03.01.2022 ISO] using proprietary (nvidia) driver it gets stuck and does not do anything at "Terminating Playmouth Boot Screen".
What can I do to install it?
I am using a single SSD drive in my system. Partition table is okay cause I used Erase Disk option.
When I use open source driver it works but it does not work while using proprietary driver.

Kernel: 5.16.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=22d356d9-8602-4ffa-af8f-150a79ea6337 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Gigabyte product: Z370 HD3 v: N/A
serial: <superuser required>
Mobo: Gigabyte model: Z370 HD3-CF v: x.x serial: <superuser required>
UEFI: American Megatrends v: F13 date: 08/13/2019
Info: model: Intel Core i5-8400 bits: 64 type: MCP arch: Coffee Lake
family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEC
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
desc: 1x9 MiB
Speed (MHz): avg: 3941 high: 3982 min/max: 800/4000 scaling:
driver: intel_pstate governor: performance cores: 1: 3958 2: 3921 3: 3907
4: 3902 5: 3982 6: 3980 bogomips: 33599
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Gigabyte
driver: nouveau v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max:
gen: 3 speed: 8 GT/s ports: active: HDMI-A-3
empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2 bus-ID: 01:00.0
chip-ID: 10de:1c03 class-ID: 0300
Device-2: Microdia Webcam Vitade AF type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-3:2 chip-ID: 0c45:6366
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
loaded: nouveau unloaded: modesetting alternate: fbdev,nv,vesa gpu: nouveau
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: HDMI-3 mapped: HDMI-A-3 model: HP 22er serial: <filter>
built: 2017 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 476x268mm (18.7x10.6") diag: 583mm (23") ratio: 15:9 or 16/10
modes: max: 1920x1080 min: 720x400
OpenGL: renderer: NV136 v: 4.3 Mesa 21.3.7 direct render: Yes
Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
class-ID: 0403
Device-2: NVIDIA GP106 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:10f1
class-ID: 0403
Device-3: Microdia Webcam Vitade AF type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-3:2 chip-ID: 0c45:6366
class-ID: 0102 serial: <filter>
Device-4: Kingston HyperX Cloud Stinger Core Wireless + 7.1 type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-4:3 chip-ID: 0951:170b
class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.16.14-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
Local Storage: total: 223.57 GiB used: 31 GiB (13.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Transcend model: TS240GSSD220S
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 71.1 scheme: GPT
ID-1: / raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 31 GiB (13.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 31 GiB (13.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 31 GiB (13.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 31 GiB (13.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 512 KiB (0.0%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 27.8 C mobo: 16.8 C gpu: nouveau temp: 45.0 C
Fan Speeds (RPM): N/A gpu: nouveau fan: 743
Processes: 266 Uptime: 3m wakeups: 0 Memory: 15.57 GiB
used: 1.75 GiB (11.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1736 lib: 511 Shell: fish v: 3.3.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13
Garuda (2.5.6-2):
System install date:     2022-03-15
Last full system update: 2022-03-15
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service


OS: Garuda Linux  
Host: Gigabyte Technology Co., Ltd. Z370 HD3-CF  
Kernel: 5.16.14-zen1-1-zen  
Uptime: 3 mins  
Packages: 1736 (pacman)  
Shell: bash  
DE: Plasma 5.24.3  
WM: KWin  
WM Theme: Sweet-Dark  
Terminal: konsole  
CPU: Intel i5-8400 (6) @ 4.0GHz  
GPU: NVIDIA GeForce GTX 1060 6GB  
Memory: 1.72GiB / 15.57GiB

I edited your title to reflect Plymouth as I know not any Playmouth. It should help in your resolution from others :+1:


This person had a similar issue. Their solution ended up being to switch to the LTS kernel: Garuda ISO boot stuck on Starting Terminating Plymouth Boot Screen

So you would install with open source, then install the proprietary drivers and LTS kernel and switch to those after you have the new installation up.


Maybe I misunderstood the problem, anyway, if the issue was only that you couldn't boot the live USB with proprietary drivers to install the system directly with them, it is very common to have that issue.
So, after installing with open source drivers, it is sufficient to install the Nvidia proprietary driver with the HW assistant (Garuda Welcome -> Garuda Settings Manager -> Hardware Configuration)

1 Like

Ya but when I tried to do that I see conflicts in packages and the progress stops.
Just wondering if I replace the python packages then will the open source driver crash and will not post into my monitor? Is it safe to do?

> Using config 'video-nvidia-dkms' for device: 0000:01:00.0 (0300:10de:1c03) Display controller nVidia Corporation GP106 [GeForce GTX 1060 6GB]
> Installing video-nvidia-dkms...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-dkms/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases...
 core downloading...
 extra downloading...
 community downloading...
 multilib downloading...
 chaotic-aur downloading...
resolving dependencies...
looking for conflicting packages...
:: python-pyxdg and python-xdg are in conflict. Remove python-xdg? [y/N] error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)

:: python-pyxdg and python-xdg are in conflict
Error: pacman failed!
Error: script failed!

Done ...

Yes, I think you can answer y there.
I see python-pyxdg provides python-xdg now:


I see. Thank you.

Before this topic gets automatically closed, is it possible to know if python-pyxdg eventually worked?
I'm asking this because this conflict appeared long ago and was fixed, but now popped up again so we're going to fix this again. But at least I'd like to understand if there were further problems.


13 posts were split to a new topic: Stuck at "terminate plymouth boot screen" when installing proprietary drivers