Stuck at "terminate plymouth boot screen" when installing proprietary drivers

hi, i also have a similar issue, when i tried to install via proprietary drivers it gets stuck at terminate plymouth boot screen, after installing in open source i tried to auto install the proprietary drivers has the same conflict issue, it didnt ask me for y in terminal.

Open a terminal and enter this command

Then try again with proprietary drivers.


This step is now automated by garuda-update!
Finally got around to doing it :slight_smile:


I have no words... :wink::+1::muscle:

nope, got stuck on initialise ramdisk, had to format my pc.

You could've just restored a snapshot, but okayyy sure you do you.


i never used a snapshot before

Well, instead of completely resetting everything, you could've just restored a snapshot and restored to a previous version of the OS.


i see, will do, thank you.

Well, it's too late now.

well i still havent fixed the issue and i formated twice before that.

Instead of installing the proprietary drivers after you installed the rest of the system, why not install them by selecting the proprietary driver when booting the ISO?

1 Like

cause it gets stuck on terminate plymouth booting screen

Please post your garuda-inxi.
You kinda hijacked a previous post.

1 Like

inxi? whats that?

nvm i fixed it using these command lines:
sudo pacman -S nvidia-dkms
sudo mkinitcpio -P