Stuck in boot loop after update

Think I'll hold off updating for now. :smiley:

No, you'll be fine. Just pay attention to the update messages.

If you see something like this

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

The GRUB bootloader could not be updated automatically.
Please reinstall it manually, otherwise the system may face a bootloop that has to be resolved from a setup ISO.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

then you should post the logs here and downgrade your grub version again. Otherwise, you'll be perfectly. fine.

2 Likes

Script already did that for you.

1 Like

wasn't sure since I got a failed message

finally!

after installing garuda linux last year, I finally have an issue :slight_smile:

thanks @TNE , updated grub to that package and it fixed. ( grub previously complained about "no more memory" (rough translation) but still gave a black and white boot and allowed to boot the system ).

i also was on that specific version: r322.gd9b..

3 Likes

I unfortunately rebooted today (after 5 days) to give my system rest , Now it is not even showing grub ,

1)Acer BIOS keeps rebooting automatically , the only way to stop is to hard power off using power button .
To make matter worse the lastest kde-lite-iso is also not booting ( I have checked sha256 checksum and they match) , currently typing this from Ubuntu live ISO .

  1. Now how to get Live ISO of Garuda to boot ?
    (after selecting either open source or Nvidia It is showing shell root )
    So that I can restore my old installation from snapshot or Fix grub .

  2. Can this be done from Ubuntu ISO ?

  3. I have made backup of my home partition using Nautilus on Ubuntu to my HDD

Download another Garuda version, not KDE lite of all things.
Under Garuda-Welcome start chroot, grub-install, update-grub. Then see what garuda-update tells you.
If you have a M$ dualboot, you have to repeat update-grub after booting.
I did it this way on two notebooks and no problems since, unfortunately it doesn't seem to work this way on all devices. Maybe use this then.

  • Problem is in kde-lite latest ISO maybe
  • Now I tried with old kde-git iso and it booted fine
  • Then I used Boot Repair utility and selected ESP mode , It quickly repaired boot but showed some overlay error
  • Then I rebooted to old installation and it worked without causing bootloops

Thanks for making Boot Repair Utility , it made reinstalling grub very easy and fast

Problem is, it seems it does not work for everybody (boot repair), or the user make something wrong?

IDK :slight_smile:

1 Like

noticed im still getting

Update notices:
The GRUB bootloader could not be updated automatically. Please reinstall it manually, otherwise the system may face a bootloop that has to be resolved from a setup ISO.

upon running garuda-update even if it didn't touch grub (in fact I set grub to be ignored in pacman.conf)

Just decided to throw in the towel and downgrade grub in the repos.
garuda-update will now downgrade the version of grub you have installed to a known good version, but the version of grub you have installed in your EFI will not be changed. You shouldn't have to take any more action. If you're scared the previous grub version would break your install, you can rest assured it is now safe to update.

8 Likes

FYI: I updated this bug report with my solution that does not require rolling back to a previous version.

The solution was tested on my system using LUKS2 and BTRFS with /boot being encrypted as part of the / os.

In short, when upgrading to the latest Grub package, re-run the 'grub-install', then if you need to add luks2 support, run the grub-mkimage and copy the resulting image to your EFI System Partition. grub-mkconfig to update your /boot/grub/grub.cfg, and finally, mkinitcpio -P (for me, this is to be sure my cryptsetup files are added to the initram and may not be needed for most users).

I am noob but I found that if you re partition the hard drive from the flash drive with your Garuda ISO and install again on the the new partition it will allow you to choose in boot options from the new grub to go into the new install or the old one. I even added hard drive encryption that covers both installs.
I am working from the restored install now so it works. The low end solution involves chroot from a flash drive and my terminal skills are not up to it especially when flipping out over my bricked install.
i still need to ask if the new OS install and partition can be deleted safely to recover the hard drive space?
On line I found only the low end solution.
Garuda folk please include more high end solutions for us terminal wimps.
I hope this helps other terminal incompetent high end users. We do suffer.

I think it's probably just best to learn the *nix CLI. It's the most powerful tool in the toolbox. I hate to say it because nobody likes to be told this, but Google is probably the best resource for it. There are tons of tutorials out there, and most of the solutions on here will walk you through exactly what to type.

I also recommend OverTheWire: Bandit to teach you about SSH, SCP, filetypes, encryption, and compression. Just make sure you're connecting from a virtual machine.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.