Reinstalling GRUB

Hi guys!
Can you please tell me how to reinstall GRUB using livecd? GRUB stopped working after recent update, and now I'm stuck in endless reboot loop.
Sorry, can post system info - I'm on my phone now.

And, I assume you have seen it, anyway... follow

3 Likes

When you updated your system, did you ignore any update notices? What did they say? This is important info.

2 Likes

There wasn't any as I remeber. Just a regular update.

garuda-update or sudo pacman -Syu ?

1 Like

garuda-update, I don't use pacman for updating the system.

Can't chroot.

What have you mounted on /mnt?
Also, please, copy terminal text in the posts instead of pictures. You should have connectivity from the live USB.

2 Likes

Sorry, was trying to remember what is my pass, cause all my passwords is in password manager in OS that I can't access. :smiley:

First of all I did this:

╭─[email protected] in ~ as πŸ§™ took 2ms
╰─λ sudo fdisk -l
Disk /dev/sda: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: KINGSTON RBUSNS8
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 63FBFAC8-D8B7-46A5-B7AE-152AA78CC49A

Device        Start        End   Sectors   Size Type
/dev/sda1      2048    1437695   1435648   701M Microsoft basic data
/dev/sda6   1437696   19869695  18432000   8.8G Linux swap
/dev/sda7  19869696 1000214527 980344832 467.5G Linux filesystem

Then I tried this:

sudo mkdir /mnt

sudo mount /dev/sda1 /mnt

sudo garuda-chroot /mnt/@

After first one I got this:

╭─[email protected] in ~ as πŸ§™ took 15ms
╰─λ sudo mkdir /mnt
mkdir: cannot create directory β€˜/mnt’: File exists

So I proceed to next steps. I mounted sda1 partition:

sudo mount /dev/sda1 /mnt

Then I tried to chroot with this commands:

sudo garuda-chroot /mnt/@

Or this:

╭─[email protected] in ~ as πŸ§™ took 14ms
[πŸ”΄] Γ— sudo garuda-chroot /mnt/sda1/@
==> ERROR: Can't create chroot on non-directory /mnt/sda1/@

It getting me the same error.
Disclaimer: I decided to recreate the boot partition, cause there was old windows partition.
So I made a new one: fat32, with flag "bootable", 700mb.
Now I need to install Garuda GRUB on this new sda1 partition.

Please follow the sample

sudo mkdir -p /mnt/broken
sudo mount /dev/nvme0n1p2 /mnt/broken
sudo garuda-chroot /mnt/broken/@
sudo mount /dev/sda7 /mnt

sudo garuda-chroot /mnt/@

Afterwards inside chroot

mount /dev/sda1 /boot/efi

And continue with GRUB installation

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
update-grub
3 Likes

It worked, I booted in grub when I rebooted.
But after I choose Garuda in grub - it loads about 5 minutes with logo then entering emergency mode.
I tried to revert back to snapshot I did few days ago, and now I have this:

setfont: KDFONTOP: Function not implemented.
Error: Root device mounted successfully, but /sbin/init does not exist.

sh: can't access tty: job control turned off.

As i see, when I trying to boot normally it gives me only this error:
setfont: KDFONTOP: Function not implemented.

Really sorry for picture but I cant copy this unfortunately.

Ok, I figured out - it was corrupted fstab file. Fixed the file, system booted.
Thanks.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.