Pipewire breaks after update

Kernel: 5.18.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d77cec55-b378-49d4-a4f7-9c0791c8e0f0 rw rootflags=subvol=@
quiet quiet splash snd_hda_intel.dmic_detect=0 rd.udev.log_priority=3
vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Google product: Lick v: rev3
serial: Chassis: type: 9 serial:
Mobo: Google model: Lick v: rev3 serial:
UEFI: coreboot v: MrChromebox-4.16 date: 04/09/2022
ID-1: BAT0 charge: 29.7 Wh (71.6%) condition: 41.5/41.8 Wh (99.2%)
volts: 11.9 min: 11.2 model: SMP L17M3PB type: Li-ion serial:
status: discharging cycles: 103
Info: model: Intel Celeron N4020 bits: 64 type: MCP arch: Goldmont Plus
built: 2017 process: Intel 14nm family: 6 model-id: 0x7A (122) stepping: 8
microcode: 0x1E
Topology: cpus: 1x cores: 2 smt: cache: L1: 112 KiB
desc: d-2x24 KiB; i-2x32 KiB L2: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 2706 high: 2713 min/max: 800/2800 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 2713 2: 2699
bogomips: 4377
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel GeminiLake [UHD Graphics 600] driver: i915 v: kernel
arch: Gen9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
empty: DP-1,DP-2 bus-ID: 00:02.0 chip-ID: 8086:3185 class-ID: 0380
Device-2: Acer EasyCamera type: USB driver: uvcvideo bus-ID: 1-7:3
chip-ID: 5986:1162 class-ID: 0e02 serial:
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: InfoVision Optronics/Kunshan 0x048e built: 2016
res: 1366x768 hz: 60 dpi: 136 gamma: 1.2 size: 256x144mm (10.08x5.67")
diag: 294mm (11.6") ratio: 16:9 modes: 1366x768
OpenGL: renderer: Mesa Intel UHD Graphics 600 (GLK 2) v: 4.6 Mesa 22.1.1
direct render: Yes
Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_apl bus-ID: 00:0e.0
chip-ID: 8086:3198 class-ID: 0401
Sound Server-1: ALSA v: k5.18.3-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.0 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Device-1: Intel Gemini Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:0c.0 chip-ID: 8086:31dc class-ID: 0280
IF: wlp0s12f0 state: up mac:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-9:4 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address:
Local Storage: total: 148.21 GiB used: 10.63 GiB (7.2%)
ID-1: /dev/mmcblk0 maj-min: 179:0 vendor: SanDisk model: DA4032
size: 29.12 GiB block-size: physical: 512 B logical: 512 B type: SSD
serial: rev: 0x8 scheme: GPT
SMART Message: Unknown smartctl error. Unable to generate data.
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Generic
model: STORAGE DEVICE size: 119.08 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: rev: 0819 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 28.62 GiB size: 28.62 GiB (100.00%)
used: 10.55 GiB (36.9%) fs: btrfs dev: /dev/mmcblk0p2 maj-min: 179:2
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/mmcblk0p1 maj-min: 179:1
ID-3: /home raw-size: 119.08 GiB size: 119.08 GiB (100.00%)
used: 82.4 MiB (0.1%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/log raw-size: 28.62 GiB size: 28.62 GiB (100.00%)
used: 10.55 GiB (36.9%) fs: btrfs dev: /dev/mmcblk0p2 maj-min: 179:2
ID-5: /var/tmp raw-size: 28.62 GiB size: 28.62 GiB (100.00%)
used: 10.55 GiB (36.9%) fs: btrfs dev: /dev/mmcblk0p2 maj-min: 179:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.7 GiB used: 633.3 MiB (16.7%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 66.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 267 Uptime: 2h 28m wakeups: 32979 Memory: 3.7 GiB
used: 1.93 GiB (52.3%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 Packages: pacman: 1156 lib: 298
Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.17
Garuda (2.6.3-2):
System install date: 2022-06-12
Last full system update: 2022-06-12 ↻
Is partially upgraded: No
Relevant software: NetworkManager
Windows dual boot: No/Undetected
Snapshots: Snapper
Failed units:
thread 'main' panicked at 'McFly error: DELETE from selected_commands to work (attempt to write a readonly database)', src/history/history.rs:158:17
note: run with RUST_BACKTRACE=1 environment variable to display a backtrace

this was a fresh install of garuda dragonized. sound was working and detection output devices. after running garuda-update, it says no output device found. i tried running (systemctl --user restart pipewire pipewire-pulse). i also tried reinstalling pipewire all togather. then i tried to swith to pulseaudio with garuda assistant. same problem, wont detect any output devices. same thing happens with all garuda versions on the website. it just stops seeing any output devices after update.

First, reboot.
Second, edit your post.



Minimum requirements

  • 4 GB RAM
  • Video card with OpenGL 3.3 or better
  • 64-bit system

I'm closing here since it's already been reported to gitlab.

1 Like