My audio system is a mess, can't uninstall pulseaudio

My audio system has been broken since 2022. I tried some things, but I’ve never figured out how to actually fix it, and I ended up accepting life.

I have bought a mic recently and I want to record some video tutorials. I would really appreciate anyone’s help to fix my audio system, I’m not sure how broken it is. I don’t remember how much I ended up messing with it last 1.5 year, because I tried multiple approach from multiple topics from this forum

One thing I realized is that everyone says to remove pulseaudio and just use pipewire, but I haven’t been able to uninstall pulseaudio due to multiple dependencies need it. When I try to remove pulseaudio with its dependencies, an error appears saying it is not possible because there are multiple dependencies of dependencies, to the point I’m feel insecure I’m gonna break everything if I keep adding “remove a b c d e f g h e i j k l” from the system.

My goals are:

  1. connect my headset, and hear audio from it.
  2. connect the mic, and see it working

Currently, I can only hear any audio from my headset by starting an audio stream, like YT video, then I need to open audio settings, and change audio profile twice like on this image:

Then I need to do the same with the microphone. Once the YT video stops, the headset stops working, and the mic too. The workaround I found the last year is starting an infinite audio stream by entering an audio channel on Discord after boot. I feel very sad doing this every day, every boot, or every time I disconnect the headset, or connect a mic.


Kernel: 6.6.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1841fbdb-0a5a-497a-86d3-67c2ef2f6c76 rw rootflags=subvol=@
quiet rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Avell High Performance product: A65 MOB v: Standard
serial: <superuser required>
Mobo: Avell High Performance model: Avell A65 MOB v: Standard
serial: <superuser required> UEFI: American Megatrends LLC. v: N.1.07AVE00
date: 07/23/2021
ID-1: BAT0 charge: 77.5 Wh (100.0%) condition: 77.5/93.5 Wh (82.9%)
volts: 12.2 min: 11.4 model: standard type: Li-ion serial: <filter>
status: full
ID-2: hidpp_battery_0 charge: 95% condition: N/A volts: 4.1 min: N/A
model: Logitech G703 LIGHTSPEED Wireless Gaming Mouse w/ HERO type: N/A
serial: <filter> status: discharging
Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
process: Intel 10nm family: 6 model-id: 0x8D (141) stepping: 1
microcode: 0x4E
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 1559 high: 3913 min/max: 800/4600 scaling:
driver: intel_pstate governor: performance cores: 1: 3684 2: 3913 3: 800
4: 800 5: 800 6: 3791 7: 800 8: 800 9: 2557 10: 800 11: 2202 12: 800
13: 800 14: 800 15: 800 16: 800 bogomips: 73728
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Tongfang Hongkong
driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
ports: active: eDP-1 empty: DP-1 bus-ID: 00:02.0 chip-ID: 8086:9a60
class-ID: 0300
Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q]
vendor: Tongfang Hongkong driver: nvidia v: 545.29.06
alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current (as of
2023-10; EOL~2026-12-xx) arch: Ampere code: GAxxx process: TSMC n7 (7nm)
built: 2020-2023 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s ports: active: none off: HDMI-A-1 empty: DP-2,DP-3,eDP-2
bus-ID: 01:00.0 chip-ID: 10de:2520 class-ID: 0300
Device-3: Chicony Integrated IR Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-13:8 chip-ID: 04f2:b71a
class-ID: 0e02 serial: <filter>
Device-4: Logitech Brio 500
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB rev: 2.1
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-5:6 chip-ID: 046d:0943
class-ID: 0300 serial: <filter>
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia dri: iris
gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
Screen-1: 0 s-res: 5120x1440 s-dpi: 96 s-size: 1354x381mm (53.31x15.00")
s-diag: 1407mm (55.38")
Monitor-1: HDMI-A-1 mapped: HDMI-1-0 note: disabled pos: primary,bottom-r
model: LG (GoldStar) 25UM58G serial: <filter> built: 2015 res: 2560x1080
dpi: 96 gamma: 1.2 size: 677x290mm (26.65x11.42") diag: 730mm (28.8")
modes: max: 2560x1080 min: 640x480
Monitor-2: eDP-1 pos: top-left model: BOE Display 0x0974 built: 2021
res: 2560x1440 hz: 165 dpi: 189 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 2560x1440
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 1 drv: iris device: 3 drv: swrast surfaceless:
drv: nvidia x11: drv: iris inactive: gbm,wayland,device-2
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (TGL GT1)
device-ID: 8086:9a60 memory: 61.08 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 8 device: 0 type: integrated-gpu name: Intel
UHD Graphics (TGL GT1) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:9a60 surfaces: xcb,xlib device: 1 type: discrete-gpu
name: NVIDIA GeForce RTX 3060 Laptop GPU driver: nvidia v: 545.29.06
device-ID: 10de:2520 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Tiger Lake-H HD Audio vendor: Tongfang Hongkong
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
Device-2: NVIDIA GA106 High Definition Audio vendor: Tongfang Hongkong
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
Device-3: Fifine Microphone driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-1.2:4
chip-ID: 3142:5060 class-ID: 0300
Device-4: Logitech Brio 500
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB rev: 2.1
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-5:6 chip-ID: 046d:0943
class-ID: 0300 serial: <filter>
API: ALSA v: k6.6.5-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: JACK v: 1.9.22 status: off with: a2jmidid status: off tools: N/A
Server-2: PipeWire v: 1.0.0 status: active with: wireplumber
status: active tools: pw-cat,pw-cli,wpctl
Server-3: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl,pavucontrol
Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Tongfang Hongkong driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 2e:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp46s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
IF-ID-2: br-cc173ea2f690 state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
IF-ID-3: docker0 state: down mac: <filter>
IF-ID-4: veth0e384c5 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-5: veth398dbbb state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-6: veth602980e state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-7: veth661b0f0 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-8: veth6f5bdc7 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-9: veth7c908dc state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-10: veth7f8f211 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-11: vetha0a62e7 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-12: vetha8e7167 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-13: vethf255c27 state: up speed: 10000 Mbps duplex: full
mac: <filter>
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-14:9 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Local Storage: total: 3.73 TiB used: 610.64 GiB (16.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:1 vendor: A-Data model: SX8200PNP
size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 42B9T6TB temp: 42.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP
size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 42B9T6TB temp: 41.9 C
scheme: GPT
ID-1: / raw-size: 1.86 TiB size: 1.86 TiB (100.00%) used: 610.64 GiB (32.0%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:8
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 563 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:7
ID-3: /home raw-size: 1.86 TiB size: 1.86 TiB (100.00%)
used: 610.64 GiB (32.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:8
ID-4: /var/log raw-size: 1.86 TiB size: 1.86 TiB (100.00%)
used: 610.64 GiB (32.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:8
ID-5: /var/tmp raw-size: 1.86 TiB size: 1.86 TiB (100.00%)
used: 610.64 GiB (32.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:8
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 62.54 GiB used: 16.5 MiB (0.0%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
dev: /dev/zram0
System Temperatures: cpu: 67.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 557 Uptime: 11m wakeups: 0 Memory: total: 64 GiB note: est.
available: 62.54 GiB used: 13.05 GiB (20.9%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 alt: 12
clang: 16.0.6 Packages: pm: dpkg pkgs: 0 pm: pacman pkgs: 2608 libs: 573
tools: pamac,paru Shell: fish v: 3.6.2 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2021-09-13
Last full system update: 2023-12-11
Is partially upgraded:   No
Relevant software:       timeshift(custom) NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:            anbox-container-manager.service systemd-guest-user.service systemd-networkd-wait-online.service~~~

You have multiple sound servers the cause of all your pain. Either go full (pulseaudio+jack) and remove everything pipewire related or go full pipewire. We suggest pipewire because it’s new and is rapidly gaining influence. Hence, you need to remove everything except pipewire and then reinstall pipewire.

You don’t need to remove them. The apps with dependencies on pulseaudio and jack are going to be fullfilled by pipewire-pulse and pipewire-jack packages respectively provided by pipewire.

sudo pacman -Rdd jack-support pulseaudio-support pulseaudio  pulseaudio-alsa  pulseaudio-bluetooth pulseaudio-equalizer pulseaudio-jack  pulseaudio-lirc pulseaudio-rtp  pulseaudio-zeroconf a2jmidid  celt  jack  jack_capture  jack_utils  libffado zita-ajbridge

Remove whatever software from this list pacman complains it can’t find. For example if pacman says it can’t find pulseaudio-support just erase it’s name from the command.

Then for good measure remove orphans with this command,


It’s an alias to

sudo pacman -Rns $(pacman -Qtdq)

I know this is a very aggressive command but it’s better to get rid of unwanted orphans that might contribute to our problems than keep them. If there are truly software among this list that you wish to keep you can just press ‘n’ to exit the transaction mark them as explicitly installed and then proceed with removing orphans again.

Now we need to reinstall pipewire follow this post to reinstall pipewire,

Apart from reinstalling pipewire we also want to ensure that our user belongs to the realtime group. Use garuda assistant for this.


As you can see ensure you are a part of realtime group apply changes and reboot.


I would like to thank you for your reply.
This worked perfectly for me, I followed every step, it seems my audio system is finally working after so long.

I’m really really grateful for your thoughtful answer, very detailed. You nailed it! Jack and pulseaudio have been removed. Reinstalled pipewire with no issues and rebooted, and everything went fine.

Mic is working very well, system switches to headset immediately when I connect it to the computer.

I believe cleanup removed quite 8GB of garbage from my system that probably I mistakenly installed. Long time ago I wondered how I could undo all the wrong things I installed when I didn’t know how to use poetry or pyenv properly.

Thank you my friend, God bless you!

While I am quite happy that everything worked out for you, are you quite sure you wanted to remove all that? I mean if you installed nasm and mingw-x64-gcc isn’t that usually something you install explicitly? Don’t think there are any softwares that need these as dependencies that removing them would cause them to become orphans. Then again if you didn’t care about writing x86 assembly code or cross compiling then it doesn’t matter.

I would like to raise 1 issue, which is after I followed all these steps, I’m getting this error every time I open a new terminal:

Cannot find the mcfly binary, please make sure that mcfly is in your path before sourcing

Do you know what this is?

Yeah, go to


and look at it’s sub directories and remove every file that has mcfly in its name. There shouldn’t be a lot as far as I remember only one should be there but maybe stuff has changed.

You’re right, it seems scrcpy stopped working. I basically reinstalled scrcpy and it’s working now. Other softwares may be broken but I will solve it one by one, no issues. I don’t know what exactly was using nasm or mingw-x64-gcc.

I have been cross-compiling but I will reinstall it when the error arises.

I also removed mcfly with your instructions and the error disappeared.

I have one extra question: when I open the terminal and type pip list I see a myriad of packages, I believe most of them are not from garuda system, but I myself installed them when I did not know how to use virtual environments properly, so I installed everything globally. :sweat:

How could I uninstall all of them which are not strictly used by garuda? I mean, it is very annoying every time I type garuda-update all of these globally installed pip packages update, one by one, even though I stopped using them a long time ago (after I learned how to use venvs). But I don’t even know what is from the system and what I myself installed.

╰─λ pip list
Package                   Version
------------------------- ----------------------------------
absl-py                   2.0.0
aiohttp                   3.9.1
aiosignal                 1.3.1
aiosqlite                 0.19.0
alembic                   1.9.4.dev0
annotated-types           0.6.0
anyio                     3.7.1
apparmor                  3.1.6
argcomplete               2.0.0
asgiref                   3.7.2
astor                     0.8.1
asttokens                 2.4.1
astunparse                1.6.3
attrs                     23.1.0
autocommand               2.2.2
autograd                  1.6.2
bcrypt                    4.0.1
beautifulsoup4            4.12.2
black                     23.10.1
bleach                    6.1.0
blinker                   1.6.3
boto3                     1.33.1
botocore                  1.33.1
btrfsutil                 6.6.2
build                     1.0.3
CacheControl              0.13.1
cachetools                5.3.2
cachy                     0.3.0
certifi                   2023.11.17
cffi                      1.16.0
charset-normalizer        3.3.2
cleo                      2.1.0
click                     8.1.7
colorama                  0.4.6
contourpy                 1.2.0
crashtest                 0.4.1
cryptography              41.0.7
cupshelpers               1.0
cycler                    0.12.1
Cython                    3.0.6
databases                 0.7.0
dbus-python               1.3.2
decorator                 5.1.1
Deprecated                1.2.14
dirty-equals              0.6.0                2.3.2
distlib                   0.3.7
distro                    1.8.0
dnspython                 2.4.2
docutils                  0.20.1
dulwich                   0.21.7
ecdsa                     0.18.0
et-xmlfile                1.1.0
evdev                     1.6.1
exceptiongroup            1.1.3
executing                 2.0.0
fastapi                   0.104.1
fastjsonschema            2.19.0
fastnumbers               5.1.0
filelock                  3.12.4
Flask                     2.3.3
Flask-Cors                4.0.0
flatbuffers               23.5.26
fonttools                 4.46.0
frozenlist                1.4.0
future                    0.18.3
gast                      0.3.3
geocoder                  1.38.1
google-auth               2.23.0
google-auth-oauthlib      1.1.0
google-pasta              0.2.0
gpg                       1.23.2
gps                       3.25
greenlet                  3.0.1
grpcio                    1.59.3
h11                       0.14.0
h5py                      3.10.0
html5lib                  1.1
httptools                 0.6.1
hypothesis                6.92.0
icecream                  2.1.3
idna                      3.4
importlib-metadata        5.0.0
importlib-resources       6.1.1
inflect                   7.0.0
iniconfig                 2.0.0
injector                  0.21.0
installer                 0.7.0
ipython                   8.18.1
itsdangerous              2.1.2
jaraco.classes            3.3.0
jaraco.context            4.3.0
jaraco.functools          3.9.0
jaraco.text               3.11.1
jedi                      0.19.1
jeepney                   0.8.0
Jinja2                    3.1.2
jmespath                  1.0.1
jsonschema                4.20.0
jsonschema-specifications 2023.11.2
keras                     2.12.0
Keras-Applications        1.0.8
Keras-Preprocessing       1.1.2
keyring                   24.2.0
Kivy                      2.2.1
kiwisolver                1.4.5
lark                      1.1.7
lensfun                   0.3.4
LibAppArmor               3.1.6
libfdt                    1.7.0
libinput-gestures-qt      0.3
libtorrent                2.0.9
libvirt-python            9.10.0
lit                       16.0.6.dev0
lockfile                  0.12.2
lxml                      4.9.2
Mako                      1.2.4
Markdown                  3.5.1
MarkupSafe                2.1.3
matplotlib                3.8.1
matplotlib-inline         0.1.6
mercurial                 6.6
ml-dtypes                 0.3.1
moddb                     0.10.0
more-itertools            10.1.0
msgpack                   1.0.5
multidict                 6.0.4
mypy-extensions           1.0.0
natsort                   8.4.0
netsnmp-python            1.0a1
nftables                  0.1
numpy                     1.26.2
oauthlib                  3.2.2
OpenCC                    1.1.7
openpyxl                  3.1.2
opt-einsum                3.3.0
optimus-manager           1.5
ordered-set               4.1.0
orjson                    3.9.10
packaging                 23.2
pandas                    1.5.3
paramiko                  2.11.1
parso                     0.8.3
passlib                   1.7.4
pathspec                  0.12.1
peewee                    3.16.3
pexpect                   4.8.0
pickleshare               0.7.5
Pillow                    10.1.0
pip                       23.3.1
pkginfo                   1.9.6
platformdirs              4.1.0
playsound                 1.3.0
pluggy                    1.3.0
ply                       3.11
plyer                     2.1.0
poetry                    1.7.1
poetry-core               1.8.1
poetry-plugin-export      1.5.0
pooch                     1.8.0
prompt-toolkit            3.0.41
protobuf                  4.25.1
psutil                    5.9.6
psycopg2                  2.9.9
ptyprocess                0.7.0
pure-eval                 0.2.2
py3nvml                   0.2.7
pyasn1                    0.4.8
pyasn1-modules            0.2.8
pybind11                  2.11.1
PyBluez                   0.30
pycairo                   1.25.1
pycparser                 2.21
pycups                    2.0.1
pycurl                    7.45.2
pydantic                  2.5.2
pydantic_core             2.14.5
pydantic-extra-types      2.1.0
pydantic-settings         2.1.0
pydot                     1.4.2
PyGithub                  1.59.1
Pygments                  2.17.2
PyGObject                 3.46.0
PyJWT                     2.8.0
PyNaCl                    1.4.0
PyOpenGL                  3.1.6
pyOpenSSL                 23.3.0
pyparsing                 3.1.1
pypng                     0.20231004.0
pyproject_hooks           1.0.0
PyQt5                     5.15.10
PyQt5-sip                 12.13.0
pyrate-limiter            3.1.0
pyrsistent                0.19.3
pyserial                  3.5
PySide2                   5.15.11
PySide6                   6.6.1
PySocks                   1.7.1
pytest                    7.4.3
python-barcode            0.15.1
python-dateutil           2.8.2
python-dotenv             1.0.0
python-editor             1.0.4
python-escpos             2.2.0
python-jose               3.3.0
python-xlib               0.33
pytz                      2023.3.post1
pyusb                     1.2.1
pyxdg                     0.28
PyYAML                    6.0.1
qrcode                    7.4.2
QtPy                      2.4.0
rapidfuzz                 3.4.0
ratelim                   0.1.6
reactivex                 4.0.4
referencing               0.31.1
Reflector                 2023.
reportlab                 3.6.12
requests                  2.31.0
requests-oauthlib         1.3.1
requests-toolbelt         1.0.0
rpds-py                   0.10.6
rsa                       4.9
s3transfer                0.8.0
SciPy                     1.11.4
scrypt                    0.8.20
SecretStorage             3.3.3
setuptools                69.0.0
setuptools-scm            8.0.4
sh                        1.14.3
shellingham               1.5.0.post1
shiboken2                 5.15.11
shiboken6                 6.6.1
shiboken6-generator       6.6.1
six                       1.16.0
skia-pathops              0.8.0
smbus                     1.1
sniffio                   1.3.0
sortedcontainers          2.4.0
sounddevice               0.4.6
soupsieve                 2.5
srt                       3.5.3
stack-data                0.6.3
starlette                 0.33.0
systemd-python            235
TBB                       0.2
tensorboard               2.15.0
tensorboard-data-server   0.8.0a0
tensorboard-plugin-wit    1.8.1
tensorflow                2.15.0
tensorflow-estimator      2.15.0
termcolor                 2.3.0
tomli                     2.0.1
tomlkit                   0.12.2
toolz                     0.12.0
torbrowser-launcher       0.3.6
traitlets                 5.14.0
trove-classifiers         2023.12.1
typing_extensions         4.9.0
ufw                       0.36.2
urllib3                   1.26.18
uvicorn                   0.24.0
uvloop                    0.19.0
validate-pyproject        0.13.post1.dev0+gb752273.d20230520
vboxapi                   1.0
virtualenv                20.25.0
wcwidth                   0.2.9
webencodings              0.5.1
websockets                10.4
Werkzeug                  2.3.8
wheel                     0.40.0
wrapt                     1.14.1
wxPython                  4.2.1
yarl                      1.9.2
zipp                      3.17.0

I will be honest I have no idea about python pip I am a C/C++ guy and recently started learning rust so my knowledge about pip dwarfs yours by leaps and bounds since I haven’t even installed pip in my system but I recon something like this is what you might need:

Though I would suggest opening a new thread for this issue and seek help from community. Pretty sure some python devs are lurking around here and can pull you out of your pinch.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.