Many Audio Issues

Hello y'all,
I'm fairly new to Garuda, but I've used Ubuntu and other Debian based Distros. This problem never happened to me on other distros, so this is my first time.

Output of inxi -Fxxxza

System:    Kernel: 5.14.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=aff4bd2f-a614-4ceb-bb5a-c286c22fc862
rw [email protected] quiet splash snd_hda_intel.dmic_detect=0 rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: HP product: HP Laptop 15s-gr0xxx v: Type1ProductConfigId serial: <filter>
Chassis: type: 10 serial: <filter>
Mobo: HP model: 87D1 v: 38.25 serial: <filter> UEFI: Insyde v: F.25 date: 08/18/2021
Battery:   ID-1: BAT1 charge: 29.5 Wh (73.9%) condition: 39.9/40.9 Wh (97.6%) volts: 11.7 min: 11.3
model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter> status: Discharging
CPU:       Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP
arch: Zen family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108109 cache: L2: 2 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33533
Speed: 1217 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1217 2: 1708
3: 1324 4: 1550 5: 1243 6: 1222 7: 1222 8: 1222
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Picasso vendor: Hewlett-Packard driver: amdgpu v: kernel bus-ID: 04:00.0
chip-ID: 1002:15d8 class-ID: 0300
Device-2: Luxvisions Innotech Limited HP TrueVision HD Camera type: USB driver: uvcvideo
bus-ID: 3-2.1:3 chip-ID: 30c9:0035 class-ID: fe01 serial: <filter>
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.42.0 5.14.16-zen1-1-zen LLVM 12.0.1)
v: 4.6 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 1002:15de class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard
driver: snd_pci_acp3x v: kernel alternate: snd_rn_pci_acp3x bus-ID: 04:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.14.16-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard
driver: r8169 v: kernel port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard
driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:c821
class-ID: 0280
IF: wlo1 state: up mac: <filter>
Bluetooth: Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8 bus-ID: 3-2.3:4
chip-ID: 0bda:b00a class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 21.93 GiB (4.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530 SDBPNPZ-512G-1006
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: <filter> rev: HPS2 temp: 40.9 C scheme: GPT
Partition: ID-1: / raw-size: 169.71 GiB size: 169.71 GiB (100.00%) used: 21.85 GiB (12.9%) fs: btrfs
dev: /dev/nvme0n1p7 maj-min: 259:7
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 83.4 MiB (32.6%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 169.71 GiB size: 169.71 GiB (100.00%) used: 21.85 GiB (12.9%) fs: btrfs
dev: /dev/nvme0n1p7 maj-min: 259:7
ID-4: /var/log raw-size: 169.71 GiB size: 169.71 GiB (100.00%) used: 21.85 GiB (12.9%)
fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
ID-5: /var/tmp raw-size: 169.71 GiB size: 169.71 GiB (100.00%) used: 21.85 GiB (12.9%)
fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 5.74 GiB used: 512 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 48.0 C mobo: 10.0 C gpu: amdgpu temp: 48.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 316 Uptime: 2m wakeups: 1 Memory: 5.74 GiB used: 3.04 GiB (53.0%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1766 pacman: 1757
lib: 537 snap: 9 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08

I tried the solution highlighted in this post, but it didn't work either.

I also have a few other problems like if I play Minecraft using TLauncher and open youtube, youtube won't play, and vice-versa. For some reason, my mic is picking up the audio in my headset, i.e. if I'm watching youtube, and go into a Teams meeting/Discord call, they can hear my youtube noises through my mic.

How can I fix this? Garuda is a lot cool, and it doesn't make me want to switch distros for few small issues.

Thanks :slight_smile:

Try some of the fixes in this post;

Hello,

That was a quick and prompt reply. I tried all of the fixes mentioned in that post, but in vain. I still cannot listen to both Youtube and Minecraft audio together. I did find this one information in the minecraft logs saying that it failed to start Sound System

For the Discord side of things, it is the same as my mic keeps picking up the youtube audio playing in my headphone.

Also, my mute LED on the keyboard doesn't light up even though my speaker is muted

Try using pulseaudio and pipe wire alsa is not good with multiple sources

1 Like

How am I supposed to do that?

Forum search and read read man its so simple. :grinning_face_with_smiling_eyes:

1 Like

I tried it, but I couldn't find a tutorial. I may be totally wrong though :slightly_smiling_face:

Install and run pavucontrol to check your configuration, and make sure PipeWire is actually running (e.g. systemctl --user status pipewire.service pipewire.socket).

It looks like you're limited to ALSA, which, as mandog says, doesn't support multiple simultaneous devices.

There won't be a tutorial for troubleshooting a specific problem.

1 Like

Hello there,
I tried installing pavucontrol and it worked fine, and my mic was still picking up the headphone audio. Before installing pavucontrol though, I tried updating using the Update command and getting a bunch of Error Code 500's.

On the other hand, both Pipewire Service and Socket are running without any issues.

Why is that so? But, for some reason, if I run Minecraft without sudo, all my audio works properly.

We'll need some output here to better check.
Even better, if the audio problem is solved, to open a new topic for this.

I'm not a Minecraft user, but I guess this is related to the fact that with sudo you don't pass to the root user your environment variables, unless using sudo -E, so there is something missing.
Anyway, I always followed the rule to always avoid sudo, if something works without, in order to avoid potential problems that you can create with root privilege.

2 Likes

Well, I tried the update command after 12 hours and it magically worked.

I usually do the same, but it was specifically given in the TLauncher Guide to run it as sudo, else there would be GPU issues.

My Mute LED isn't working too, and I tried this, but it didn't work

It's how ALSA works when PulseAudio is present: https://wiki.archlinux.org/title/Advanced_Linux_Sound_Architecture/Troubleshooting#Simultaneous_playback_problems

Unless you're doing system maintenance etc., you shouldn't run any applications using sudo!

Whatever that guide is, it's wrong.

3 Likes

It was the one that came when I installed TLauncher, it is the official one.

All of my volume control keys aren't either working or are working incorrectly.
The Mute Key (F6) LED doesn't light up
The Reduce Volume Key (F7) actually mutes the audio instead of reducing it

Read the manual from your keyboard, please.
Open issue on driver support, BTW this has nothing to do with your help request.

Seems you failed also to search the right way,

please read

I have looked at the TLauncher site and I can't find any reference to running it with sudo.

It also looks like a way to pirate Minecraft, so I'm not sure seeking help here is the best option.

image

4 Likes

No, I don't use the Pirated version with TLauncher account. I use a legit purchased it from Mojang :slight_smile:

If you download the zip file for Linux, inside it there will be the a JAR file, and two TXT files in both Russian and English

I'll research, and if I find nothing then create a new one :slight_smile:

What did I search wrongly there :/?

Anyway, this is going off on a tangent. The "solution" is to run user applications without sudo.

1 Like

That's not a Minecraft forum.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.