4GB out 12GB RAM can't be detected after installing Garuda

Hi
I had Ubuntu and windows installed on my device. After installing Garuda, 4GB of my RAM can't be detected neither in Bios Setting Nor in a live Ubuntu booted from flash disk
This is what I get in system information

Operating System: Garuda Linux
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Kernel Version: 5.13.9-zen1-1-zen (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-6700HQ CPU @ 2.60GHz
Memory: 7.7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 530

4GB of my RAM is missing

also this is out put form "free -h"

               total        used        free      shared  buff/cache   available
Mem:           7.7Gi       1.5Gi       4.3Gi       548Mi       1.8Gi       5.1Gi
Swap:           16Gi          0B        16Gi

and also File: /proc/meminfo is
MemTotal: 8035532 kB
MemFree: 4229196 kB
MemAvailable: 5196860 kB
Buffers: 2136 kB
Cached: 1954572 kB
SwapCached: 0 kB
Active: 1380248 kB
Inactive: 1304724 kB
Active(anon): 1380248 kB
Inactive(anon): 157560 kB
Active(file): 0 kB
Inactive(file): 1147164 kB
Unevictable: 671796 kB
Mlocked: 260716 kB
SwapTotal: 17262788 kB
SwapFree: 17262788 kB
Dirty: 2872 kB
Writeback: 0 kB
AnonPages: 1365484 kB
Mapped: 595912 kB
Shmem: 568640 kB
KReclaimable: 91208 kB
Slab: 213932 kB
SReclaimable: 91208 kB
SUnreclaim: 122724 kB
KernelStack: 13512 kB
PageTables: 38264 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
WritebackTmp: 0 kB
CommitLimit: 21280552 kB

and this is my dmesg log
https://drive.google.com/file/d/1FmambVbFpA9mi_MsYAUdmUxIrY0kcAev/view

I appreciate any help on the matter thanks

When you create a new post, a template is provided which requests specific information to be provided in order to get help. Please go back and re-read that and provide the requested info.

The information you provided isn't sufficient to fully answer your question.

4 Likes
inxi -Faz

or

inxi -I

:slight_smile:

Summary

I Like To Move It (Original Video) Madagascar HD - YouTube

1 Like

just uploaded the dmesg log

Please provide inxi -Faz as requested by the template. Also, there is no way I am downloading anything from your google drive.

3 Likes
System:    Kernel: 5.13.9-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=41a46d7b-b335-4021-87dc-511ca08b7bb5  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=03136cfa-08d9-459f-bfb9-9b7b29bce5a1 loglevel=3
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: ASUSTeK product: N552VW v: 1.0 serial: <filter>  
Mobo: ASUSTeK model: N552VW v: 1.0 serial: <filter> UEFI-[Legacy]: American Megatrends  
v: N552VW.204 date: 02/04/2016  
CPU:       Info: Quad Core model: Intel Core i7-6700HQ bits: 64 type: MT MCP arch: Skylake-S family: 6  
model-id: 5E (94) stepping: 3 microcode: EA cache: L2: 6 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41599  
Speed: 3261 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 3261 2: 3300 3: 3407 4: 3435  
5: 3363 6: 3296 7: 3421 8: 3238  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
Graphics:  Device-1: Intel HD Graphics 530 vendor: ASUSTeK driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:191b class-ID: 0300
Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: ASUSTeK driver: nvidia v: 470.57.02
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:139b class-ID: 0302
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus-ID: 1-4:2
chip-ID: 13d3:5666 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 507x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 21.1.6 direct render: Yes
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403
Sound Server-1: ALSA v: k5.13.9-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.33 running: yes
Network:   Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: e000 bus-ID: 02:00.0
chip-ID: 8086:095a class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169
v: kernel port: d000 bus-ID: 03:00.1 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0f1 state: down mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-9:4
chip-ID: 8087:0a2a class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 1.94 TiB used: 23.2 GiB (1.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZNLF128HCHP-00004 size: 119.24 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 301Q
scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000LM003 HN-M201RAD size: 1.82 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 0001 scheme: GPT
Partition: ID-1: / raw-size: 110.44 GiB size: 110.44 GiB (100.00%) used: 23.2 GiB (21.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 110.44 GiB size: 110.44 GiB (100.00%) used: 23.2 GiB (21.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 110.44 GiB size: 110.44 GiB (100.00%) used: 23.2 GiB (21.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 110.44 GiB size: 110.44 GiB (100.00%) used: 23.2 GiB (21.0%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2
maj-min: 8:2
ID-2: swap-2 type: zram size: 7.66 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 54.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2200
Info:      Processes: 305 Uptime: 28m wakeups: 12181 Memory: 7.66 GiB used: 3.57 GiB (46.6%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1773 lib: 336
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Since that is a hybrid laptop, it is possible that a portion of your RAM is being reserved as video memory.

3 Likes

Can we see the output of sudo inxi -m

4 Likes

Memory: RAM: total: 7.66 GiB used: 3.72 GiB (48.5%)
Array-1: capacity: 64 GiB slots: 4 EC: None
Device-1: ChannelA-DIMM0 size: No Module Installed
Device-2: ChannelA-DIMM1 size: No Module Installed
Device-3: ChannelB-DIMM0 size: 8 GiB speed: 2133 MT/s
Device-4: ChannelB-DIMM1 size: No Module Installed

It looks like only 1 DIMM is detected. Since you have 12GB, that should probably be multiple DIMMs. It looks like a hardware issue to me. Have you tried reseating the DIMMs?

5 Likes

No I haven't tried that, because it was just working fine an hour before installation

Everything works until the point that it stops working.

I used to work in a business that did repairs. I can't tell you how many times I was told. "It can't be broken, it was working fine yesterday" :wink:

9 Likes

Yeah thanks I will try this and report the results thanks a million :smile:

I can't thank you enough. This did the trick. I appreciate the time you took to investigate the matter patiently. Best lucks :smiley:

2 Likes

I mark the solution!mark-it-solved

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.