KDE agent ask for root password for snapper tools on every boot

Hello everyone,

I don't know if it is due to something I changed or if it was an update but, for the last few dais, I keep being asked for authentication every time I boot. Apparently, to run snapper tools. The service also kept asking me If I wished to delete old snaps, as if they belonged to someone else or to another system version/installation (sorry I don't remember exactly) until I let it delete then.

System:
Kernel: 5.18.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=810cddd0-3d54-45f7-88fa-84f8b12b1038 rw [email protected]
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.25.2 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-I GAMING v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 4602
date: 08/17/2021
CPU:
Info: model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen 2 gen: 3
built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 4098 high: 4100 min/max: 2200/4426 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4097 2: 4100
3: 4098 4: 4099 5: 4100 6: 4097 7: 4100 8: 4100 9: 4100 10: 4099 11: 4099
12: 4100 13: 4097 14: 4100 15: 4097 16: 4100 bogomips: 115200
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Gigabyte driver: amdgpu v: kernel arch: RDNA 1
process: TSMC n7 (7nm) built: 2019-20 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-1,DP-3 empty: DP-2,HDMI-A-1 bus-ID: 09:00.0
chip-ID: 1002:731f class-ID: 0300
Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-1:2 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.65x15.00")
s-diag: 1245mm (49.01")
Monitor-1: DP-1 mapped: DisplayPort-0 pos: primary,top-right
model: MSI MAG274QRF-QD serial: <filter> built: 2021 res: 2560x1440
dpi: 109 gamma: 1.2 size: 597x336mm (23.5x13.23") diag: 685mm (27")
ratio: 16:9 modes: max: 2560x1440 min: 640x480
Monitor-2: DP-3 mapped: DisplayPort-2 pos: bottom-l model: AOC 2590G4
serial: <filter> built: 2019 res: 1920x1080 dpi: 90 gamma: 1.2
size: 544x303mm (21.42x11.93") diag: 623mm (24.5") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL:
renderer: AMD Radeon RX 5700 (navi10 LLVM 14.0.6 DRM 3.46 5.18.9-zen1-1-zen)
v: 4.6 Mesa 22.1.3 direct render: Yes
Audio:
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
bus-ID: 1-1:2 gen: 4 chip-ID: 046d:0825 class-ID: 0102 speed: 16 GT/s
lanes: 16 serial: <filter> bus-ID: 09:00.1 chip-ID: 1002:ab38
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
Device-4: Logitech G432 Gaming Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2:3 chip-ID: 046d:0a9c
class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.18.9-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.54 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 04:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: ASUSTeK
driver: rtw_8822be v: N/A modules: rtw88_8822be pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: c000 bus-ID: 05:00.0 chip-ID: 10ec:b822
class-ID: 0280
IF: wlp5s0 state: up mac: <filter>
Bluetooth:
Device-1: ASUSTek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-8:5 chip-ID: 0b05:185c class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 1.84 TiB used: 1.04 TiB (56.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: S0118C
temp: 33.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10SPZX-00Z10T0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A01 scheme: MBR
Partition:
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 260.62 GiB (27.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 260.62 GiB (27.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 260.62 GiB (27.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 260.62 GiB (27.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.54 GiB used: 2.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 43.0 C mobo: 51.0 C gpu: amdgpu temp: 45.0 C
mem: 54.0 C
Fan Speeds (RPM): cpu: 656 case-1: 703 gpu: amdgpu fan: 709
Power: 12v: 9.92 5v: N/A 3.3v: N/A vbat: 3.23 gpu: amdgpu watts: 32.00
Info:
Processes: 370 Uptime: 54m wakeups: 0 Memory: 15.54 GiB
used: 3.32 GiB (21.4%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: pacman: 1878
lib: 561 flatpak: 0 Shell: fish v: 3.4.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.19
Garuda (2.6.4-2):
System install date:     2022-06-25
Last full system update: 2022-07-08
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

I add an screenshot.

Best regards and thanks in advance.

This is a very nice example of a completely unnecessary screenshot.

Please do not post pictures for one sentence error message.
Especially since you already had it as explained, we believe you even without a picture. :slight_smile:

4 Likes

Sorry about that. I thought there might be something there that could be useful.

1 Like

Maybe @TNE can fix it.

I think I only had that with

garuda-update

I can't check it right now.

5 Likes

There was! Thank you!

Update with garuda-update, should be fixed in garuda-system-maintenance 1.6.1, let me know if that works! :wink:

5 Likes

IDK, why I have snapper tools? :wink:
After garuda-update, reboot

pacman -Qi garuda-system-maintenance 
Name            : garuda-system-maintenance
Version         : 1.6.1-1
pacman -Qi snapper-tools 
Name            : snapper-tools
Version         : 1.1.1-2
Description     : A highly opinionated Snapper GUI and CLI
Architecture    : x86_64
URL             : https://gitlab.com/garuda-linux/applications/snapper-tools
Licenses        : GPL3
Groups          : None
Provides        : None
Depends On      : qt5-base  qt5-svg  polkit
Optional Deps   : None
Required By     : garuda-system-maintenance
Optional For    : garuda-assistant
Conflicts With  : None
Replaces        : None
Installed Size  : 213,72 KiB
Packager        : Nico Jensch <[email protected]>
Build Date      : Di 05 Jul 2022 05:47:07 CEST
Install Date    : Mi 06 Jul 2022 15:15:08 CEST
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature
1 Like

It did!

Thanks for the help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.