It seems that there is a specific problem with printers on Garuda

My experience with Canon LBP 2900 was very similar to this one and this one, as well as this one. Even though we have printers from various companies, the same issue appears - the request to print is send, but the printer does not print. Therefore, there is something wrong with CUPS or other important packages for printing on Garuda, that we need to check.

Open source in git?

Just open issue there.

2 Likes

First question, does it work properly with other distro?

1 Like

I tend to personally think this is not a Garuda specific problem. I have seen this issue on many distros I've used in the past.

Oftentimes printer setup is one of the most difficult things to achieve in Linux. Of course YMMV, as the specific printer model is often the determining factor of degree of difficulty installing in my experience.

2 Likes

So one NO - is a YES useful? (if not please delete)

If so, I run a Canon TS5050, which worked perfectly OOB.

Edited for clarity

I can't find anything related to printers with this word, so what do you mean?

1 Like

Sorry - nay = no, aye = yes (in voting) Language is a drag sometimes, apologies :blush:

I'll edit for clarity.

1 Like

For me, no. Tried Devuan and MX Linux on other hardware (old inspiron laptop). But others say that on other distros it works. Not sure about arch, though

2 Likes

My model is from 2007, if I recall correctly. And even on windows it only has drivers for the windows 7, lol.

3 Likes

Actually, soon I will buy a new ssd and need to make some bios tweaks, so I might experiment with my clear Qtile install and try more -git packages, as cups was recently forked and a lot has changed.

1 Like

Well i can assure you printing does work their are plenty of drivers my Epson that is so new their are no official drivers even works.
you have to be here /etc /group, add this if its not their cups:x:209: also cups needs enabling, systemctl enable cups it may of changed mind you CUPS - ArchWiki CUPS/Printer-specific problems - ArchWiki

4 Likes