Epson et-2027 printer/scaner not installing

I say installing only because I am not exactly sure what is going on, I have found drivers for the printer, installed them, and the printer is discoverable as a network printer "despite being a USB device". When I try to print anything it is sent to the queue, and then never prints. I have never had an issue with a simple printer not just....printing. and despite about 3 days on google, I am as of yet unable to fix this issue.

If someone could baby me through this it would be much appreciated because I have no idea what I am doing wrong.

1 Like

Hi @TheFirstTechPriest
Try this site for the driver

Epson driver for linux

EPSON Download Center

I had problem too before with EPSON L565 printer. Finding the right driver from repository is really confusing for EPSON printers.

  1. First I type the printer name that you use
  2. Choose the OS as Linux
  3. Choose the "Generic Driver" from the driver list and click on download
  4. Choose "Accept" on the [Epson's Software License Agreement]
  5. After that you can see the list of driver for your printer
  6. You can download it from there but for sure you can go to Add/Remove Software or Pacman and then find the driver from the repository based on the driver name from EPSON.
  7. And for the last go to the system settings>Printer>Add your printer>Choose your printer>Choose your driver that you just install it>finish. Try print something.

I hope this can help you. Good luck :beers:

8 Likes

add cups to /etc /group cups:x:209: start cups, systemctl enable cups reboot look in Arch wiki cups

2 Likes

I had a similar issue but with another printer, Canon LBP 2900. Drivers were installed and the request was send, but printer never prints, even though says that the page was printed. After all I discovered that this printer is labeled as "paperweight" on openprinting site, which means that Canon does not support it anymore. I tried opensource drivers too, which claim to get it working, but still no luck. I posted about this is another thread

1 Like