Issues with Updating `qemu-base` and `qemu-desktop` on Garuda Linu

Hello everyone,

I recently attempted to update my Garuda Linux system, but ran into dependency issues related to qemu-base and qemu-desktop. Specifically, I get a long list of broken dependencies when trying to update qemu-base to version 8.1.0-2.

╭─q42@q42 in ~
╰─λ garuda-update
[sudo] password for q42:
:: Synchronizing package databases...
garuda is up to date
core is up to date
extra is up to date
multilib is up to date
chaotic-aur                             2.6 MiB  4.29 MiB/s 00:01 [------------------------------------] 100%

--> Refreshing mirrorlists using rate-mirrors, please be patient..🍵
:: Synchronizing package databases...
garuda downloading...
core downloading...
extra downloading...
multilib downloading...
chaotic-aur downloading...
:: Starting full system upgrade...
:: Replace exa with extra/eza? [Y/n] y
warning: qemu-base: ignoring package upgrade (8.0.4-2 => 8.1.0-2)
resolving dependencies...
warning: ignoring package qemu-base-8.1.0-2
warning: cannot resolve "qemu-base=8.1.0-2", a dependency of "qemu-desktop"
warning: ignoring package qemu-base-8.1.0-2
warning: cannot resolve "qemu-base=8.1.0-2", a dependency of "qemu-desktop"
:: The following package cannot be upgraded due to unresolvable dependencies:

:: Do you want to skip the above package for this upgrade? [y/N] y
looking for conflicting packages...
:: networkmanager-support and networkmanager-fortisslvpn are in conflict. Remove networkmanager-fortisslvpn? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: networkmanager-support and networkmanager-fortisslvpn are in conflict

╭─q42@q42 in ~ as 🧙 took 56s
[🔴] ×

Here’s a snippet of the error message:

:: installing qemu-common (8.1.0-2) breaks dependency 'qemu-common=8.0.4-2' required by qemu-audio-alsa
:: installing qemu-common (8.1.0-2) breaks dependency 'qemu-common=8.0.4-2' required by qemu-audio-dbus
:: installing qemu-common (8.1.0-2) breaks dependency 'qemu-common=8.0.4-2' required by qemu-ui-spice-core
:: installing qemu-common (8.1.0-2) breaks dependency 'qemu-common=8.0.4-2' required by qemu-vhost-user-gpu

I’ve tried to manually update qemu-base using sudo pacman -S qemu-base, but it didn’t resolve the issue.

Has anyone else encountered this problem, and if so, how did you resolve it? Any guidance would be greatly appreciated.

Thank you!

Kernel: 6.4.11-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=eb3c6daf-a51b-40c6-b919-5d0844c5116b rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=1232fa25-bece-4a36-a25f-220cc22e4c1a loglevel=3 apparmor=1
security=apparmor ibt=off
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING II v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 4901
date: 07/25/2022
Info: model: AMD Ryzen 5 5600 bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3541 high: 3600 min/max: 2200/4467 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3500 2: 3598
3: 3500 4: 3500 5: 3500 6: 3500 7: 3500 8: 3599 9: 3598 10: 3599 11: 3600
12: 3500 bogomips: 83997
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Tonga PRO [Radeon R9 285/380] vendor: PC Partner / Sapphire
driver: amdgpu v: kernel arch: GCN-3 code: Volcanic Islands
process: TSMC 28nm built: 2014-19 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: DP-1,DVI-D-1 empty: DVI-D-2,HDMI-A-1 bus-ID: 07:00.0
chip-ID: 1002:6939 class-ID: 0300 temp: 64.0 C
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 4240x1622 s-dpi: 96 s-size: 1121x429mm (44.13x16.89")
s-diag: 1200mm (47.26")
Monitor-1: DVI-D-1 mapped: DVI-D-0 pos: bottom-l model: Acer AL2216W
serial: <filter> built: 2006 res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2
size: 473x296mm (18.62x11.65") diag: 558mm (22") ratio: 16:10 modes:
max: 1680x1050 min: 720x400
Monitor-2: DP-1 mapped: DisplayPort-0 pos: primary,top-right
model: LG (GoldStar) ULTRAGEAR serial: <filter> built: 2022 res: 2560x1440
hz: 120 dpi: 93 gamma: 1.2 size: 697x392mm (27.44x15.43")
diag: 800mm (31.5") ratio: 16:9 modes: max: 2560x1440 min: 640x350
API: OpenGL v: 4.6 Mesa 23.1.6 renderer: AMD Radeon R9 380 Series (tonga
LLVM 15.0.7 DRM 3.52 6.4.11-zen2-1-zen) direct-render: Yes
Device-1: AMD Tonga HDMI Audio [Radeon R9 285/380]
vendor: PC Partner / Sapphire driver: snd_hda_intel v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 07:00.1 chip-ID: 1002:aad8 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
API: ALSA v: k6.4.11-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.77 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 04:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Local Storage: total: 945.98 GiB used: 251.96 GiB (26.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:4 vendor: Kingston model: SNVS500G
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: S8542105 temp: 43.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Kingston model: SNVS500G
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: S8H40104 temp: 41.9 C
scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Verbatim model: STORE N GO
size: 14.45 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 2.0 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
fw-rev: 8.07 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 448.4 GiB size: 448.4 GiB (100.00%)
used: 251.93 GiB (56.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 25.9 MiB (8.7%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1
ID-3: /home raw-size: 448.4 GiB size: 448.4 GiB (100.00%)
used: 251.93 GiB (56.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 448.4 GiB size: 448.4 GiB (100.00%)
used: 251.93 GiB (56.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 448.4 GiB size: 448.4 GiB (100.00%)
used: 251.93 GiB (56.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.51 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.07 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme1n1p3 maj-min: 259:3
System Temperatures: cpu: 65.0 C mobo: 52.0 C gpu: amdgpu temp: 64.0 C
Fan Speeds (rpm): cpu: 2033 case-1: 1138 case-2: 1138 case-3: 1081
gpu: amdgpu fan: 548
Power: 12v: 10.03 5v: N/A 3.3v: N/A vbat: 3.27 gpu: amdgpu watts: 52.14
Processes: 336 Uptime: 1h 1m wakeups: 0 Memory: total: 16 GiB
available: 15.52 GiB used: 3.83 GiB (24.7%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages: 2043
pm: pacman pkgs: 2039 libs: 563 tools: octopi,paru,yay pm: rpm pkgs: 0
pm: flatpak pkgs: 4 Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-05-14
Last full system update: 2023-08-23
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Please use forum search before posting a help request. Infact while typing your query discourse must have suggested you similar threads don’t just ignore them.

For qemu,

For networkmanager-fortisslvpn,


I wanted to give you an update on the issues we discussed:


  • To address the qemu issue, I removed the conflicting packages virt-manager and virt-manager-meta as suggested on the forum.
  • After doing this, I was able to successfully update the system.
  • Then I installed those packages again and everything is OK now


  • Regarding the networkmanager-fortisslvpn issue, I followed your link to a forum solution, which involved removing the ppp package. This allowed me to update the system without any further issues.


  • I still have some questions: Is virt-manager-meta essential, and is there an alternative solution to the PGP signature problem? How should orphaned packages like networkmanager-fortisslvpn be handled? Additionally, do you have any tips for smoother future updates?

Thanks for your guidance and the networkmanager-fortisslvpn solution you shared.

It’s not an essential package rather it is just there to pull the following packages

bridge-utils  dnsmasq  iptables-nft  edk2-ovmf  libvirt  netcat  qemu-desktop  radvd
virt-viewer  virt-manager

via the dependency tree it creates. You can remove this meta package and install these packages individually, or forcefully remove only virt-manager-meta and mark it’s dependencies as explicitly installed so that they are not marked as orphans on your local system package database, but that just seems to be a duplication of work to me.

In your original post I didn’t see any PGP keys failing though? Could be a little more specific. What methods have you tried to resolve this issue?

Since the package has been orphaned it’s essentially no longer going to be updated unless someone picks it up on AUR again. So the best way to deal with it in my opinion is to remove it. However, you can still keep it if you feel it’s necessary. The only case I can think this package is necessary is if you are using openfortivpn.

The only issue post removal of this package was reported here along with a solution that didn’t even need this package.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.