Internal Microphone not working on lenovo Ideapad 330

Hello.

Post your terminal/konsole in- and output as text (no pictures) from:

```text
System:
  Kernel: 5.16.16-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=fcf3e49a-2e7a-45e4-a929-c4068ab274e5
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: KDE Plasma v: 5.24.3 tk: Qt v: 5.15.3 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 81DE v: Lenovo ideapad 330-15IKB
    serial: <superuser required> Chassis: type: 10 v: Lenovo ideapad 330-15IKB
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required> UEFI: LENOVO
    v: 8TCN61WW date: 05/19/2021
Battery:
  ID-1: BAT0 charge: 27.2 Wh (100.0%) condition: 27.2/35.3 Wh (77.1%) volts: 8.5 min: 7.6
    model: CPT-COS L16C2PB1 type: Li-poly serial: <filter> status: full
CPU:
  Info: model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Coffee Lake family: 6
    model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 799 high: 800 min/max: 400/3400 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 799
    bogomips: 28800
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel ports: active: eDP-1
    empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX150] vendor: Lenovo driver: nvidia v: 510.54
    alternate: nouveau,nvidia_drm pcie: gen: 1 speed: 2.5 GT/s lanes: 4 link-max: gen: 3
    speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1d10 class-ID: 0302
  Device-3: Syntek EasyCamera type: USB driver: uvcvideo bus-ID: 1-8:4 chip-ID: 174f:241a
    class-ID: 0e02
  Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99") s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x15e6 built: 2016 res: 1366x768 hz: 60 dpi: 101
    gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5") ratio: 16:9 modes: 1366x768
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.3.7 direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.16-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lenovo
    driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 168c:0042 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
Bluetooth:
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-7:3 chip-ID: 0cf3:e500
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 3 st
ate: down bt-service: enabled,running rfk-block:
    hardware: no software: yes address: <filter>
Drives:
  Local Storage: total: 931.51 GiB used: 67.37 GiB (7.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: LCM2 scheme: GPT
Partition:
  ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 33.51 GiB (33.5%) fs: btrfs
    dev: /dev/sda5 maj-min: 8:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 702 KiB (0.7%) fs: vfat
    dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 100 GiB size: 100 GiB (100.00%) used: 33.51 GiB (33.5%) fs: btrfs
    dev: /dev/sda5 maj-min: 8:5
  ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%) used: 33.51 GiB (33.5%) fs: btrfs
    dev: /dev/sda5 maj-min: 8:5
  ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%) used: 33.51 GiB (33.5%) fs: btrfs
    dev: /dev/sda5 maj-min: 8:5
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.55 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 977 MiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda4
    maj-min: 8:4
Sensors:
  System Temperatures: cpu: 53.0 C pch: 56.5 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 282 Uptime: 16m wakeups: 1 Memory: 7.55 GiB used: 2.67 GiB (35.3%) Init: systemd
  v: 250 tool: systemctl Compilers: gcc: 11.2.0 Packages: pacman: 1918 lib: 341
  Client: shell wrapper v: 5.1.16-release inxi: 3.3.14
Garuda (2.5.6-2):
  System install date:     2022-03-15
  Last full system update: 2022-03-25
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            
```

The microphone is not detecting any input.
HIstory:-
I have installed garuda linux many times on my laptop from time to time but there is always this issue of microphone not detecting any input. Audio for some reason works fine with zoom but doesnt work for any other software.

What i have tried(i might not remember everything coz i have been trying to solve this problem for a long time):

  1. I made sure that pulseaudio and pipewire are not conflicting
  2. I dont have any dependencies issue
  3. I have currently have pipewire as the like server for the sound part of my laptop
    4.I have made sure that nothing is muted in alsamixer using f5
  4. I have made sure that Analog Stereo Duplex is selected in pavucontrol
  5. I have only pipewire-media-session not wireplumber
  6. Output for arecord -l
    **** List of CAPTURE Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC236 Analog [ALC236 Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
  7. output for "pw-record --list-targets"
    Available targets ("*" denotes default): alsa_input.pci-0000_00_1f.3.analog-stereo
    •   73: source description="Built-in Audio Analog Stereo" prio=2009
         45: monitor description="Built-in Audio Analog Stereo" prio=1009
      

9.Output for "pactl info"
Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 180
Tile Size: 65472
User Name: sabinec
Host Name: SabineCallas
Server Name: PulseAudio (on PipeWire 0.3.48)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
Default Source: alsa_input.pci-0000_00_1f.3.analog-stereo
Cookie: c215:41d5
10. I think i read in one of the forms that booting into linux lts might fix the issues i have tried and it hasnt worked.
These are the forums i remember visiting

  1. Pipewire stealing my mic? - #8 by Exanime
  2. Internal microphone stopped working in lenovo laptop
  3. Internal/external Microphones do not receive sound - #3 by c00ter
  4. PipeWire - ArchWiki
  5. No system audio when joining a discord channel

When searching the Arch wiki for this model, it showed that very similar models (that also have a "stereo" mic) have issues. PulseAudio/Troubleshooting - ArchWiki

"No microphone input on Acer Aspire One and Lenovo Ideapad 310-15ISK/330-15ARR

Install pavucontrol, unlink the microphone channels and turn down the left one to 0.

Some applications (e.g. chromium) can change microphone levels causing the same issue, a workaround is to remap stereo input to mono and use the remapped device as default."

4 Likes

I tried this solution.

I dont have a concrete answer as to what is happening but i think keeping either left or right channel at 100% and then altering the other channel's input to somewhat of 60% is giving me some like reaction to my voice. Like now when i say something the graph goes up and comes down to a stable when not speaking, so its like a 50 - 50 workaround you have to see whats good for your system. But one thing thats sure is unlock the channels
.

I tried remapping the channels but i have pipewire and so it was not that useful, but i think it will work fine for now.
Thanks

2 Likes

The problem is back again this time with static noise, i tried to redo the solution probably thinking this might just be because of restarting but it is very hard to get that back.

I solved it with QasMixer. I leave you the steps to follow answered in the following link: https://github.com/pop-os/pipewire/issues/8

I'm glad to hear you fixed your issue @TiVP, but this is not Pop_OS and we do not use the apt package manager here.

For anyone who wants to try @TiVP's QasMixer package, it is provided by QasTools:

sudo pacman -S qastools

A three-month bump is a bit much for a support thread so I'll go ahead and wrap this one up here.

3 Likes