Internal microphone stopped working in lenovo laptop

Hi, I recently switched from windows to garuda, here I observe that my laptops internal mic does not work properly. I don't know what's wrong with it. I looked up the forum and tried a few things:

  1. I tried installing pulse audio from add remove software, but couldn't decide as to which among them to install
  2. Tried adjusting the microphone level
    Here is my inxi faz output
System:
Kernel: 5.15.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=55ad2dc2-c093-4bbf-a6b9-f8f27f5449b0 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 81MT v: Lenovo V145-15AST
serial: <superuser required> Chassis: type: 10 v: Lenovo V145-15AST
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <superuser required>
UEFI-[Legacy]: LENOVO v: 8ZCN27WW(V2.06) date: 01/12/2021
Battery:
ID-1: BAT1 charge: 22.6 Wh (100.0%) condition: 22.6/30.0 Wh (75.3%)
volts: 8.6 min: 7.5 model: 0x53 0x4D 0x50 0x00 0x31 0x PABAS0241231
type: Li-ion serial: <filter> status: Charging cycles: 487
CPU:
Info: model: AMD A6-9225 RADEON R4 5 COMPUTE CORES 2C+3G bits: 64 type: MCP
arch: Excavator family: 0x15 (21) model-id: 0x70 (112) stepping: 0
microcode: 0x6006705
Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 192 KiB
desc: d-2x32 KiB; i-2x64 KiB L2: 2 MiB desc: 2x1024 KiB
Speed (MHz): avg: 2822 high: 2826 min/max: 1300/2600 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2819 2: 2826
bogomips: 10380
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Lenovo
driver: amdgpu v: kernel bus-ID: 00:01.0 chip-ID: 1002:98e4 class-ID: 0300
Device-2: Syntek EasyCamera type: USB driver: uvcvideo bus-ID: 1-1.3:4
chip-ID: 174f:241a class-ID: 0e02
Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
s-diag: 414mm (16.3")
Monitor-1: eDP res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6")
diag: 394mm (15.5")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel
bus-ID: 00:01.1 chip-ID: 1002:15b3 class-ID: 0403
Device-2: AMD Family 15h Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus-ID: 00:09.2 chip-ID: 1022:157a class-ID: 0403
Sound Server-1: ALSA v: k5.15.11-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 01:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp1s0 state: down mac: <filter>
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Lenovo driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: 2000
bus-ID: 02:00.0 chip-ID: 10ec:c821 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-1.2:3 chip-ID: 0bda:c024 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 2 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 14.56 GiB (1.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 0E scheme: MBR
Partition:
ID-1: / raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 14.56 GiB (1.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 14.56 GiB (1.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 14.56 GiB (1.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 14.56 GiB (1.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.72 GiB used: 78 MiB (2.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 64.1 C mobo: N/A gpu: amdgpu temp: 64.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 213 Uptime: 1h 27m wakeups: 3 Memory: 3.72 GiB
used: 2.55 GiB (68.4%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1253 lib: 306 Shell: fish
v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.11


Any help?

In what way?

Does it show in your DE's audio settings as an input?

Does the volume meter show a response?

Is the audio device configured to allow audio input?

2 Likes

In what way is when i try making a discord call in laptop, the other person hears nothing from my end.

As in my DE's when I try to access audio settings, it does not show internal mic under input devices, only mouse, keyboard etc are shown.

I don't know whether my audio device is configured to allow audio input

Maybe check if this helps you too...

I tried downloading pavucontrol as in the post sent by you through the software centre, it says pulse audio and pipewire are in conflict. What sould I do?

Auch, I thought the dependency with pulseaudio was optional and it was working also with pipewire...
Sorry, forget about it, I don't want you to mess up your system just for one test.
Do you have pipewire-pulse installed?
This should fill the gap to completely replace pulseaudio with pipewire.

Let's wait for other suggestions anyway.

1 Like

It is, and it is.

Could you post the full output of

sudo pacman -Syu pavucontrol

(as text)?

2 Likes
sudo pacman -Syu pavucontrol
[sudo] password for erwin:        
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
warning: pavucontrol-1:5.0-1 is up to date -- reinstalling
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (1) pavucontrol-1:5.0-1

Total Installed Size:  1.07 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                                     [------------------------------------] 100%
(1/1) checking package integrity                                   [------------------------------------] 100%
(1/1) loading package files                                        [------------------------------------] 100%
(1/1) checking for file conflicts                                  [------------------------------------] 100%
(1/1) checking available disk space                                [------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 19
:: Processing package changes...
(1/1) reinstalling pavucontrol                                     [------------------------------------] 100%
:: Running post-transaction hooks...
(1/7) Arming ConditionNeedsUpdate...
(2/7) Foreign/AUR package notification
=> No foreign/AUR packages found.
(3/7) Orphaned package notification...
lua52 5.2.4-5
(4/7) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/nsswitch.conf.pacnew
/etc/default/grub.pacnew
/etc/default/grub-btrfs/config.pacnew
/etc/pamac.conf.pacnew
/etc/pacman.d/mirrorlist.pacnew
Please check and merge
(5/7) Updating the desktop file MIME type cache...
(6/7) Performing snapper post snapshots for the following configurations...
==> root: 20
(7/7) Syncing all file systems...

Oh did I have to do it the other way?

sudo pacman -Syu pavucontrol
[sudo] password for erwin:        
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
warning: pavucontrol-1:5.0-1 is up to date -- reinstalling
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (1) pavucontrol-1:5.0-1

Total Installed Size:  1.07 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                                     [------------------------------------] 100%
(1/1) checking package integrity                                   [------------------------------------] 100%
(1/1) loading package files                                        [------------------------------------] 100%
(1/1) checking for file conflicts                                  [------------------------------------] 100%
(1/1) checking available disk space                                [------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 19
:: Processing package changes...
(1/1) reinstalling pavucontrol                                     [------------------------------------] 100%
:: Running post-transaction hooks...
(1/7) Arming ConditionNeedsUpdate...
(2/7) Foreign/AUR package notification
=> No foreign/AUR packages found.
(3/7) Orphaned package notification...
lua52 5.2.4-5
(4/7) Checking for .pacnew and .pacsave files...
.pac* files found:
/etc/nsswitch.conf.pacnew
/etc/default/grub.pacnew
/etc/default/grub-btrfs/config.pacnew
/etc/pamac.conf.pacnew
/etc/pacman.d/mirrorlist.pacnew
Please check and merge
(5/7) Updating the desktop file MIME type cache...
(6/7) Performing snapper post snapshots for the following configurations...
==> root: 20
(7/7) Syncing all file systems...

It's already installed, so I'm not sure what you were trying to install that was bringing in PulseAudio.

You should be able to run pavucontrol in a terminal, or find "PulseAudio Volume Control" in an application menu.

1 Like

Yes
I found volume control.
Can you tell what I should do next?

Read the information linked here:

and let us know what you see.

3 Likes

Yeah I tried... It worked thank you. The other person did hear me.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.