No system audio when joining a discord channel

Hello everyone. I reinstalled Garuda a week ago and I have issues with my audio. Every time I join a discord channel, my whole system does not put out any audio (in the audio kde applet, there is are audio signals and nothing is actually muted). When I then for example restart spotify, everything works again. But if I rejoin a channel in discord, there is no audio again.
It is not a hardware thing regarding my headset, I tried with different speaker/headsets. I also uninstalled BetterDiscord to make sure that does not make any trouble.
This problem happens in combination with other programs, too. Discord and Spotify is a combination I use daily and a lot, so that was easiest for me to describe.
I'm thankful for any attempts to help me!

╭─[email protected] in ~  
╰─λ garuda-inxi
System:
Kernel: 5.16.15-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=bc8f8d86-89ac-49f4-8cd3-82c0aee773df rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=b229b137-db73-4551-bdd5-6e5a53af3a14 loglevel=3
Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: PRIME B350-PLUS v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 0902
date: 09/08/2017
Battery:
ID-1: hidpp_battery_0 charge: 62% condition: N/A volts: 3.9 min: N/A
model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
serial: <filter> status: Discharging
CPU:
Info: model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen
family: 0x17 (23) model-id: 1 stepping: 1 microcode: 0x8001129
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3550 high: 3791 min/max: 1550/3800 boost: disabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3184 2: 3785
3: 3451 4: 3224 5: 3636 6: 3791 7: 3695 8: 3614 9: 3719 10: 3781 11: 3321
12: 3402 bogomips: 91019
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT / 6800M] vendor: Gigabyte
driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
active: DP-2,HDMI-A-1,HDMI-A-2 empty: DP-1 bus-ID: 24:00.0
chip-ID: 1002:73df class-ID: 0300
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 6400x1080 s-dpi: 96 s-size: 1688x285mm (66.5x11.2")
s-diag: 1712mm (67.4")
Monitor-1: DisplayPort-1 mapped: DP-2 pos: primary,center
model: LG (GoldStar) HDR WFHD serial: <filter> built: 2020 res: 2560x1080
dpi: 81 gamma: 1.2 size: 798x334mm (31.4x13.1") diag: 869mm (34.2")
modes: max: 2560x1080 min: 640x480
Monitor-2: HDMI-A-0 mapped: HDMI-A-1 pos: right model: MSI MP242
serial: <filter> built: 2021 res: 1920x1080 dpi: 93 gamma: 1.2
size: 527x296mm (20.7x11.7") diag: 604mm (23.8") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-3: HDMI-A-1 mapped: HDMI-A-2 pos: primary,left
model: LG (GoldStar) IPS224 built: 2011 res: 1920x1080 hz: 60 dpi: 102
gamma: 1.2 size: 477x268mm (18.8x10.6") diag: 547mm (21.5") ratio: 16:9
modes: max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 6700 XT (NAVY_FLOUNDER DRM 3.44.0
5.16.15-zen1-1-zen LLVM 13.0.1)
v: 4.6 Mesa 21.3.7 direct render: Yes
Audio:
Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT]
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 24:00.1 chip-ID: 1002:ab28 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 26:00.3
chip-ID: 1022:1457 class-ID: 0403
Device-3: SteelSeries ApS Arctis 7 type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2.1:4 chip-ID: 1038:12ad
class-ID: 0300
Device-4: Realtek USB2.0 Microphone type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2.2:6 chip-ID: 0bda:4937
class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.16.15-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 1e:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp30s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Microsoft Wireless XBox Controller Dongle type: USB
driver: mt76x2u bus-ID: 3-3.2:4 chip-ID: 045e:02e6 class-ID: 0000
serial: <filter>
IF: wlp37s0f3u3u2 state: down mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-3:3 chip-ID: 0bda:8771 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: no
address: <filter>
Drives:
Local Storage: total: 7.04 TiB used: 6.42 TiB (91.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS500G3XHC-00SJG0 size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 102000WD temp: 50.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: SanDisk model: SSD PLUS 240GB
size: 223.58 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 00RL scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA300
size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: ABB0 scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Seagate
model: Expansion Desk size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B type: N/A serial: <filter> rev: 0915 scheme: GPT
Partition:
ID-1: / raw-size: 150 GiB size: 150 GiB (100.00%) used: 26.55 GiB (17.7%)
fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 283.26 GiB size: 283.26 GiB (100.00%)
used: 173.96 GiB (61.4%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 150 GiB size: 150 GiB (100.00%)
used: 26.55 GiB (17.7%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-5: /var/tmp raw-size: 150 GiB size: 150 GiB (100.00%)
used: 26.55 GiB (17.7%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 32 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: swap-2 type: zram size: 31.34 GiB used: 2.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 51.0 C
mem: 52.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 474 Uptime: 3h 7m wakeups: 12 Memory: 31.35 GiB
used: 10.65 GiB (34.0%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1994 lib: 529 Shell: fish v: 3.3.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13
Garuda (2.5.6-2):
System install date:     2022-03-14
Last full system update: 2022-03-22 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper (maybe)
Failed units:

I had a similar issue and it was being caused by hardware. Specifically, if I had a USB audio device with both input and output and it was selected as the default audio device for both input and output, I'd get no audio. This was specifically a Steel Series USB headset w/mic. When I switched to my Blue Snowball mic (it's an input only device) and headphones (via a Grace m9xx DAC), the problem went away.

I don't know the exact causes but did lots of digging without figuring out the reasons why. Maybe this will help you in your debugging.

3 Likes

I actually have a Steelseries USB headset and an additional USB microphone. The mic is set as default input and the headset as default output. I use this configuration for a year now, and it worked almost a year on garuda. Any way to fix this? Maybe some driver stuff? Im kinda new to driver stuff and pretty unexperienced, so I dont really know how this all works and stuff...

See here: My Steelseries Pro Wireless headphones no longer work after upgrading to the 5.16.15 kernel

4 Likes

booting with the lts kernel fixed my issue, thanks!

EDIT: it seemed to have fixed it, but the issue is still there, somehow...