Information for KDE users - KDE 6 available in Arch repos

Hello everyone :wave:

We have some important information to share for everyone who either hasn’t read about it yet or hasn’t updated since yesterday. The KDE 6 megarelease got pushed into Arch repos:

For everyone using the default (dr460nized) theme

We already prepared a migration assistant for everyone making use of the default theme. Read about it here (also contains useful information for custom theme users!):

For everyone using a custom global theme :warning:

The migration won’t be offered. Nevertheless, it is important to note that your customization might break after updating depending on what theme and plasmoids are being used as they need to be ported to KDE 6. Since the question came up a lot of times already: this upgrade can not be avoided. Restoring a snapshot might be a temporary solution in case of issues, but the long-term goal should be to adapt the custom theme to the new KDE version.

Thanks to everyone who participated in the KDE 6 testing process! :hugs:

Also potentially relevant (adding threads with common issues here):


Would have been to have been given a heads-up that the update was coming yesterday. I updated, rebooted, and ended up logging out and into x11 cause as suspected Wayland still is not ready for primetime. I think I got off pretty lucky compared to some of the reports I’ve seen so far. I had to reassign apps to their proper desktop, replace the application menu, add the normal pager back, add the normal log-off panel widget, couple of minor adjustments to the panels. I left the unsupported widgets on the main panel as a reminder to check for updates to them every so often. All in all I think 6 looks and functions pretty good.


So much broke this update I had to switch distros


I happily updated yesterday, and in the 5 mins I had my hands on it, it worked pretty nicely, HDR enabled, SDR Brightness slider is a godsend, will test more out after work :slight_smile: and all of it on Wayland/admgpu. I had to reboot after the update for everything to settle, after which migration tool kicked in automatically and it was working nicely.

So, if you have some errors/issues, it might be better to try posting a useful “need help” post with all the data needed for such a topic, general whining will not help neither you, nor the people who might be otherwise willing and able to help you.


Yes, whoever does the updates on your computer for you should review the packages instead of blindly installing them, and give you a heads-up like you mentioned.

Oh, oops–I guess that person is you. :face_with_hand_over_mouth:

This is a bit of a overreaction which does not actually directly address the issue, since Garuda Linux neither develops nor packages KDE. It is kind of like saying “the traffic was so bad I had to get a new car.”


I for one wasn’t whining but you knew that before you posted.

@BluishHumility you know what I meant, that it would have been nice for Arch to have pushed a message a day or so before this massive of a upgrade to prepare people. Not to get home check the forum, see that peeps seemed to have gotten the 6 updates, check to see what updates were out there, and find out yes the 6 updates were there if I wanted to go ahead and update. I Hell even Microsour does that. I only went ahead with them cause I didn’t feel like waiting til 6.0.2 dropped before updating again.

Absolutely no help to anyone, but it seems to work ok for me on X11 and Wayland.

There is maybe a question though. I’m away on Business right now. The Laptop I have has updated perfectly well and I’ll remove the testing repository tonight, run Pacman as suggested and re-update.
However,my Home PC has not been updated since last weekend, should i remove the testing repo and update as usual to pick up the 6.0.1 updates?

For me so far it’s working good. Except for the slow boot time which is also reported in the official subreddit for kde r/kde

I seem to have no issues with my boot time. I think I might run a fresh install of the current Garuda release on the backend of this drive and see what milage I get with Wayland there.

1 Like

Updated, no problem on startup or boot time. But, I have visual glitch that wasn’t there before, specially in game (native by Steam); flickering with certain mouse swings.

Ho, and Spotify stopped working

╭─haeffound@haeffdesk in ~
╰─λ spotify-launcher
[2024-03-07T13:55:58Z INFO  spotify_launcher::config] Loading configuration file at "/etc/spotify-launcher.conf"
[2024-03-07T13:55:58Z INFO  spotify_launcher] No update needed
spotify: /usr/lib/ no version information available (required by spotify)
/home/haeffound/.local/share/spotify-launcher/install/usr/share/spotify/spotify: /usr/lib/ version information available (required by /home/haeffound/.local/share/spotify-launcher/install/usr/share/spotify/spotify)
/home/haeffound/.local/share/spotify-launcher/install/usr/share/spotify/spotify: /usr/lib/ version information available (required by /home/haeffound/.local/share/spotify-launcher/install/usr/share/spotify/spotify)

I actually accidentally hit enter when presented with the list of updates - yes, accidentally because I had the extra-testing repo added to pacman.conf
I removed it after the update was finished and then again did garuda-update, which only told me that gstreamer packages were newer than what in repo, which I shrugged off and rebooted.
Expected all hell to be broken loose, but nothing happened at all except the cube not working!

Yes, people like me also exist :rofl:

1 Like

That’s odd because while I did have to go into desktop effects and enable to cube effect (defaults to Super + C), the cube worked perfectly for me on 6 Wayland. I’ve seen many many reports on that specifically so I believe it’s valid, just surprises me that it works perfectly fine on my (not Linux friendly) hardware. I think the release is just hitting everyone differently. My main issues are stuff that haven’t been ported over to 6 yet, but that’s not a big deal, I can wait on that.

My main thing is Brave browser (as well as Edge, Chrome also) stopped showing the app menu in the global menu bar and it’s bugging the hell out of me. It worked perfectly before (even on Wayland), and Signal Beta shows in the global menu without issue. I’m going to give it a couple weeks and see if it’s something that auto corrects itself.


I just did this too, but had a much longer list of packages newer than the repo. Rebooting now, wish me luck! xD

Edit: Ok, graphics are choppy in X11. I can live with it though, we’ll see.


Steam is “glitchy” with this update. parts of the window disappear randomly, and the store page is completely borked.

So I’m not the only one :sweat_smile: I was going insane after FireDragon didn’t have the app menu patch anymore because Mozilla stopped maintaining it :smiley: It still looks very off to me, but you’ll get at least a bit used to it.


Same. I haven’t tested the Cube Yet. Dumb on my part since I’ve been looking forward to it being back.

1 Like

I’m hoping, praying, pleading that it’ll get working again. :sweat_smile: I’m one of the rare users that uses the global menu VERY heavily, and love that feature (one of the main reasons I switched from Gnome to Plasma originally tbh). In the meantime, I can use the application menu like normal people until it’s fixed. No worries, I’m not gonna “change distros”. :wink: I know they’re going to keep polishing and fixing and porting everything, so I’m not worried about it!



Are you running Wayland? Are you running NVIDIA drivers? If so, there is a known KDE bug for it (I’d have to search to find the link again).

I know, the me from years ago chuckled with glee as I played around with it again, lol. Just brought me back to when I first used Plasma quite some time ago. Necessary? Not even the slightest. Does it make my experience better? 1,000%

1 Like