Heroic launcher GTA 5

I am following this forum to install GTA 5,
I have installed it from Heroic launcher,
But, now I don't know how to run the GTA 5 wine script from Lutris,
I am new to gaming on Linux,

Thanks

You need to install proton from steam. After you do so click on the game and go to its settings. There you will see you installed proton. Select it and try running the game.

Helpful link: https://www.protondb.com/app/271590

1 Like

goto

then click install on
Wine Rockstar Games Launcher version

after that goto heroic games launcher

after that
settings

then play

7 Likes

But now when I press play, the game is not launching

Thank you :+1:

*@librewish I even 'tried repair and verify install',
but the verification didn't end even after 3 hrs, and I didn't see any Disk read/write after 2 hours, so I quit from Heroic and rebooted still no luck.

*I had had the same issue while installing, it was stuck @ 100% and when I restarted the launcher,
It was showing the play button (this was before I started this post)

I even tried reinstalling lutris wine (deleted the lutris folder from /home/.local/share/lutris)
and then again followed the steps you asked me to do.
By-the-way I removed the wine prefix which it had created for 'Epic Games Launcher'

I even tried this

โฏ legendary verify-game 9d2d0eb64d5c44529cece33fe2a46482
[cli] INFO: Loading installed manifest for "9d2d0eb64d5c44529cece33fe2a46482"
[cli] INFO: Verifying "Grand Theft Auto V" version "1.0.2245.0"
Verification progress: 351/351 (100.0%)
[cli] INFO: Verification finished successfully.
โฏ legendary repair 9d2d0eb64d5c44529cece33fe2a46482
[Core] INFO: Trying to re-use existing login session...
[cli] INFO: Using existing repair file: /home/austin/.config/legendary/tmp/9d2d0eb64d5c44529cece33fe2a46482.repair
[cli] INFO: Preparing download...
[Core] INFO: Parsing game manifest...
[Core] INFO: Install path: /home/austin/Games/GTAV
[DLM] INFO: Found previously interrupted download. Download will be resumed if possible.
[DLM] INFO: Skipping 351 files based on resume data.
[cli] INFO: Download size is 0, the game is either already up to date or has not changed. Exiting...
โฏ legendary launch 9d2d0eb64d5c44529cece33fe2a46482
[cli] INFO: Logging in...
[Core] INFO: Trying to re-use existing login session...
[cli] INFO: Checking for updates...
[Core] INFO: Getting authentication token...
[cli] INFO: Launching 9d2d0eb64d5c44529cece33fe2a46482...

 ๏…ผ ๎‚ฐ ๏€• ~ ๎‚ฐยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยท๎‚ฒ at 10:28:28 AM ๏€— โ”€โ•ฎ
โฏ MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0                                                                โ”€โ•ฏ

skipping config: /home/austin/.config/MangoHud/wine-explorer.conf [ not found ]
skipping config: /usr/bin/MangoHud.conf [ not found ]
skipping config: /home/austin/.config/MangoHud/wine64-preloader.conf [ not found ]
skipping config: /home/austin/.config/MangoHud/MangoHud.conf [ not found ]
MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

skipping config: /home/austin/.config/MangoHud/wine-explorer.conf [ not found ]
skipping config: /usr/bin/MangoHud.conf [ not found ]
skipping config: /home/austin/.config/MangoHud/wine64-preloader.conf [ not found ]
skipping config: /home/austin/.config/MangoHud/MangoHud.conf [ not found ]
wine: Unhandled page fault on read access to 0031D030 at address 7BC2842F (thread 012c), starting debugger...
012c:err:seh:NtRaiseException Unhandled exception code c0000005 flags 0 addr 0x7bc2842f
00cc:fixme:dialog:MSGBOX_DlgProc Help button not supported yet
0090:err:rpc:I_RpcReceive we got fault packet with status 0x1c010003


โฏ inxi -Fxxxza
System:    Kernel: 5.11.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=8dafc1bb-1c35-4c72-9779-095f94c86b8c 
           rw rootflags=subvol=@ quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
           Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 15-3567 v: N/A serial: <filter> Chassis: type: 9 
           serial: <filter> 
           Mobo: Dell model: 0D53F5 v: A00 serial: <filter> UEFI: Dell v: 2.13.0 date: 08/13/2020 
Battery:   ID-1: BAT0 charge: 8.9 Wh (37.2%) condition: 23.9/41.4 Wh (57.6%) volts: 16.0 min: 14.8 
           model: SMP DELL VN3N047 type: Li-ion serial: <filter> status: Charging 
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake 
           note: check family: 6 model-id: 8E (142) stepping: 9 microcode: DE cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21599 
           Speed: 3053 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 3053 2: 3100 3: 3100 4: 3100 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:5916 class-ID: 0300 
           Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] 
           vendor: Dell driver: radeon v: kernel alternate: amdgpu bus-ID: 01:00.0 chip-ID: 1002:6660 
           class-ID: 0380 
           Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:3 
           chip-ID: 0bda:5769 class-ID: 0e02 serial: <filter> 
           Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: ati,intel,radeon 
           unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
           OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.0.2 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403 
           Sound Server-1: ALSA v: k5.11.13-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.25 running: no 
Network:   Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell 
           driver: ath10k_pci v: kernel port: e000 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280 
           IF: wlp2s0 state: down mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel 
           port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8136 class-ID: 0200 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-8:5 chip-ID: 0cf3:e009 
           class-ID: e001 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 931.51 GiB used: 212.6 GiB (22.8%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB block-size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 3D 
           scheme: GPT 
Partition: ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 18.79 GiB (18.8%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
           ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%) used: 27.5 MiB (2.7%) fs: vfat 
           dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw-size: 150 GiB size: 150 GiB (100.00%) used: 104.54 GiB (69.7%) fs: btrfs 
           dev: /dev/sda3 maj-min: 8:3 
           ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%) used: 18.79 GiB (18.8%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
           ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%) used: 18.79 GiB (18.8%) fs: btrfs 
           dev: /dev/sda2 maj-min: 8:2 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
           ID-1: swap-1 type: partition size: 6 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda7 
           maj-min: 8:7 
           ID-2: swap-2 type: zram size: 2.86 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-3: swap-3 type: zram size: 2.86 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-4: swap-4 type: zram size: 2.86 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-5: swap-5 type: zram size: 2.86 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram3 
Sensors:   System Temperatures: cpu: 59.0 C mobo: 57.0 C gpu: radeon temp: 50.0 C 
           Fan Speeds (RPM): cpu: 2557 
Info:      Processes: 253 Uptime: 1h 56m wakeups: 16 Memory: 11.44 GiB used: 4.29 GiB (37.5%) Init: systemd 
           v: 248 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1398 lib: 381 
           Shell: Zsh v: 5.8 running-in: konsole inxi: 3.3.03 

You need to run games with

DRI_PRIME=1 

IN LAUNCH OPTIONS IN SETTINGS

4 Likes

Thank you so much for your support,
the game is now launching.
But unfortunately, the keyboard is not working for the game, when I press any key the game gets stuck for few seconds, and there is no response to the key clicks, whereas the mouse is working.

I just want a completely smooth gameplay in Linux, so that I could ditch windows forever,
I just rely on Linux for my everyday uses.

yeah when playing via keyboard it gets stuck here as well.
So I'm using xbox360 controller and using it I can play very well

2 Likes

But I don't have one,
Now what will I do?
We both have the same issue now.
Let me try searching on the internet.

I'm not sure if this will work with GTA 5, but you can try adding the game to your Steam library and launching it through steam, it should work even if you didn't purchase it from Steam (might need to get your cd key if the game asks for it).

On the main steam window click 'Add a game' in the bottom left, then 'Add a non-steam game', and browse for the game .exe, try gta5.exe or gta5launcher.exe, not sure which will work. Then right click the game in Steam and go properties > compatibility and force Proton. I use Proton-6.5-GE-2 and the game runs very well, stable high fps and keyboard/mouse/controller work fine simultaneously. I do have the Steam version of the game but I think that doesn't make a difference, not sure. Don't know what causes the keyboard issue but this might fix it.

3 Likes

@ExistingDude Do you use Heroic Launcher?

Running game with proton-experimetal works

It doesn't freeze anymore with keyboard.

2 Likes

How will I do that?
Please do tell me step-by-step

Please do not ping devs with requests for 'lessons', or what is called 'spoon-feeding'. I am sure they have neither the time or inclination to do so.

There are plenty of resources for this. Youtubes and websites deal with this. There are also posts in Steam community for the same.

Be reasonable, @Austin - as the distro grows in popularity, requests like this will become more frequent, so must be squashed. I hope you understand that my comments are not personal but for the good of all. :slightly_smiling_face:

2 Likes

alright, but this was the answer to my whole day's work?

I looked very quickly and found a few for you.

Also, Add/Remove Software (pacmac) has options, including Glorious Eggroll (GE)

Search and you will find all this yourself and have the pleasure of self-help. As a noob to this myself, I try to do this first.

Just document all changes you make and test individually, so making rolling back changes far easier.

5 Likes