XSession resets when computer goes to sleep

Hi,

Since the last update I’ve been experiencing an “Xorg dump crash” and the session resets almost every time the computer goes to sleep. I’ve looked in the journal and what seems to be consistent in each such fail is the following Xorg dump:

Process 440513 (Xorg) of user 0 dumped core.

Stack trace of thread 440513:
#0  0x00007f47ddbbe83c n/a (libc.so.6 + 0x8e83c)
#1  0x00007f47ddb6e668 raise (libc.so.6 + 0x3e668)
#2  0x00007f47ddb564b8 abort (libc.so.6 + 0x264b8)
#3  0x000055e477d59600 OsAbort (Xorg + 0x153600)
#4  0x000055e477d5afeb FatalError (Xorg + 0x154feb)
#5  0x000055e477d61466 n/a (Xorg + 0x15b466)
#6  0x00007f47ddb6e710 n/a (libc.so.6 + 0x3e710)
#7  0x00007f47dc65c386 n/a (nvidia_drv.so + 0x5c386)
#8  0x00007f47dc64ad94 n/a (nvidia_drv.so + 0x4ad94)
#9  0x00007f47dc66d429 n/a (nvidia_drv.so + 0x6d429)
#10 0x00007f47dc66ece8 n/a (nvidia_drv.so + 0x6ece8)
#11 0x00007f47dc6ad289 n/a (nvidia_drv.so + 0xad289)
#12 0x00007f47dc682f1a n/a (nvidia_drv.so + 0x82f1a)
#13 0x00007f47dcab050d n/a (nvidia_drv.so + 0x4b050d)
ELF object binary architecture: AMD x86-64
░░ Subject: Process 440513 (Xorg) dumped core
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ Documentation: man:core(5)
░░
░░ Process 440513 (Xorg) crashed and dumped core.
░░
░░ This usually indicates a programming error in the crashing program and
░░ should be reported to its vendor as a bug.

It looks like an Nvidia driver issue. Has anyone experienced this? How can I reveret to the former driver?

Thanks.

my Configuration:

System:
Kernel: 6.6.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f9fe30ae-6a43-4fdc-96cc-fbaeb8cc55f8 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 81YU v: Lenovo Legion 7 15IMHg05
serial: <superuser required> Chassis: type: 10 v: Lenovo Legion 7 15IMHg05
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN
serial: <superuser required> UEFI: LENOVO v: E9CN60WW(V4.05)
date: 11/13/2020
Battery:
ID-1: BAT1 charge: 68.7 Wh (95.3%) condition: 72.1/80.0 Wh (90.1%)
volts: 17.1 min: 15.4 model: 0x43 0x65 0x6C 0x78 0x70 0x72 0x74 0x00 0x32
0x30 0x31 0x4C 0x31 0x39 0x43 0x34 0x50 0x32 type: Li-ion serial: <filter>
status: not charging cycles: 66
Device-1: hidpp_battery_23 model: Logitech MX Anywhere 3 serial: <filter>
charge: 55% rechargeable: yes status: discharging
CPU:
Info: model: Intel Core i7-10875H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 2 microcode: 0xF8
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 868 high: 901 min/max: 800/5100 scaling:
driver: intel_pstate governor: powersave cores: 1: 900 2: 900 3: 800 4: 900
5: 899 6: 900 7: 900 8: 900 9: 800 10: 800 11: 900 12: 800 13: 901 14: 899
15: 900 16: 800 bogomips: 73598
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Lenovo driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:9bc4
class-ID: 0300
Device-2: NVIDIA TU106BM [GeForce RTX 2070 Mobile] vendor: Lenovo
driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10; EOL~2026-12-xx) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 3 speed: 8 GT/s ports: active: none off: HDMI-A-1
empty: DP-1, DP-2, DP-3, eDP-2 bus-ID: 01:00.0 chip-ID: 10de:1f54
class-ID: 0300
Device-3: Syntek Integrated Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:3 chip-ID: 174f:2435
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915,nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
s-diag: 1052mm (41.43")
Monitor-1: HDMI-A-1 mapped: HDMI-1-0 note: disabled pos: left
model: AOC U2790B serial: <filter> built: 2020 res: 1920x1080 hz: 60 dpi: 82
gamma: 1.2 size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9
modes: max: 3840x2160 min: 640x480
Monitor-2: eDP-1 pos: primary,right model: BOE Display 0x08ea built: 2019
res: 1920x1080 hz: 144 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 1 drv: iris device: 3 drv: swrast surfaceless:
drv: nvidia x11: drv: iris inactive: gbm,wayland,device-2
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
device-ID: 8086:9bc4 memory: 30.33 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 4 device: 0 type: integrated-gpu name: Intel
UHD Graphics (CML GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:9bc4 surfaces: xcb,xlib device: 1 type: discrete-gpu
name: NVIDIA GeForce RTX 2070 with Max-Q Design driver: nvidia
v: 545.29.06 device-ID: 10de:1f54 surfaces: xcb,xlib device: 2 type: cpu
name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA TU106 High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
API: ALSA v: k6.6.2-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: 3000 bus-ID: 41:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp65s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:4 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.2
lmp-v: 11 status: discoverable: no pairing: no class-ID: 7c010c
Drives:
Local Storage: total: 953.87 GiB used: 102.08 GiB (10.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLB1T0HBLR-000L2 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 3L1QEXF7 temp: 43.9 C scheme: GPT
Partition:
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 102.07 GiB (10.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 12.6 MiB (4.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 102.07 GiB (10.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 102.07 GiB (10.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 102.07 GiB (10.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.05 GiB used: 170.4 MiB (0.5%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 56.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Processes: 374 Uptime: 9d 19h 56m wakeups: 16 Memory: total: 32 GiB
note: est. available: 31.06 GiB used: 10.29 GiB (33.1%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 1562 libs: 430 tools: octopi,paru Shell: fish
v: 3.6.1 default: Bash v: 5.2.21 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-06-04
Last full system update: 2023-11-28 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Please enclose your garuda-inxi and also any text copied from Terminal in this icon below:
Screenshot_20231203_234019

It will look like this. It makes easier for anyone to read all the long text

EDIT:

↻ icon means you need to reboot for the updates to apply.

1 Like

Have you tried another kernel, say the LTS?

# pacman -S linux-lts linux-lts-headers

2 Likes

Tried this, it didn’t help. Same problem exists!

Please edit your OP (Original Post) to enclose your crash dump & garuda-inxi in code blocks as was already requested of you. You can do this by pressing the pencil icon at the bottom of your post and then add three tildes (~~~) before and after your code.

Terse responses like this are of little help to those trying to assist you. We have no idea of your experience level, so you need to provide far more details.

So, if you installed the linux-lts kernel + headers, did you actually switch to using this kernel when you rebooted by selecting it in grub’s advanced menu?

If the LTS kernel was no help, did you try other kernels? If so, exactly which kernels did you test?

If not, why not? You should always test at least 3 kernels when troubleshooting. In addition, I would recommend testing the following + headers:

linux-hardened
linux-xanmod
linux-lqx

Does this happen when using either an X11 session or a Wayland session? You can switch session types at your login screen.

What is your level of experience using Linux?

Are you familiar with using Arch based distros?

Welcome to the Garuda forum. :wave:

Edit:

Does this happen if you switch to your Intel graphics card?

5 Likes

To Answer your questions:
I’ve been using linux for many years however I’m new to arch. Used debian based for desktop and CentOS for servers until now. Love Garuda BTW.
I’ve switched to LTS in the advanced menu.
I have not tried any other kernel yet.
I do not see an option to use wayland on my login screen, don’t know much about wayland accept that its a protocol, anyway I’m using X11.

Oh and I don’t seem to be able to edit my original post but I did get the message for next time :smile:

Thanks

I edited your crash dump so that it was formatted correctly. Please check your OP to see how to format code blocks correctly. You can do this by pressing the pencil icon at the bottom of your post to edit.

Did you try this ^^^

1 Like

Problem is that I have no pencil on my OP.
Its not my first time on boards.

I don’t really know the algorithm here but it seems I’m only able to edit posts that are not more then a day old. So I can edit (I have the pencil) on yesterday’s post but I can not edit any of my posts before that. Maybe its a permission issue?

As to your question, I’ve tried this with my Intel card and it works fine. Don’t have the issue. Later on I’ll try other kernels.

Thanks.

Then it’s an Nvidia driver or Nvidia config issue.

You may want to test the nvidia-drm.modeset=1 kernel parameter.

See my post on the link below for further details:

1 Like

Using a different kernel solved the issue

Glad to hear things are working better now, but could you please be more specific.

Exactly which kernel resolved your problem?

1 Like

Sure.

At first it workd with

linux-hardened

But now it also works with

linux-lts

I may have done something wrong before. It still does not work with

linux-zen.

I am not sure if you did anything wrong. Generally I’ve found the 2 kernels least likely to have regressions backported to them are the hardened and the LTS kernels.

Thanks for posting that info.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.