XSession resets when computer goes to sleep, yet again

In continuation to my original post.

I’ve updated Garuda again last week. The problem returned, this time with the LTS kernel. So now I had the problem in all kernels.

I found a working solution and wanted to share it with you here.

I turns out that the ‘nvidia’ driver does not save the nvram parmeters before suspension/hibernation. This causes the error mentioned in the previous post. To fix this you need to do the following, I found that all these services existed on my machine but were not activated:

sudo systemctl enable nvidia-suspend.service
sudo systemctl enable nvidia-hibernate.service
sudo systemctl enable nvidia-resume.service

then:

cd /lib/modeprobe.d
sudo nano systemd.conf

Add following line at the end of the file:

options nvidia NVreg_PreserveVideoMemoryAllocations=1

After these steps I rebooted. Since then, for the last few days, the problem has gone away.
Hope it helps.

5 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.