Wifi problems RTL8723BE

Hi everybody, I'm a first time user of Garuda and so far, I love the distribution but I can't get my WiFi working. I'd rather not switch distros as I like garuda but I do need to be able to use the wifi. The problem is it doesn't even scan for any wifi networks in the area. I have added multiple different routers via network manager and still none of them will connect. It comes up with this "The access point /org/freedesktop/NetworkManager/AccessPoint/3 was not in the scan list."

I have gone on arch linux wifi troubleshooting and typed in lspci -k and it says this is my wifiadapter "RTL8723BE PCIe Wireless Network Adapter"

I have even download yay and downloaded drivers through the terminal for both a wifi adapter I have and the onboard wireless and still to no avail. I must have done something wrong somewhere. Can someone please help me and talk me through the process starting from scratch? I am relatively new to all this so I'm assuming I have made a mistake somewhere. I would be glad to provide more information.Thanks in advance.

Did you check either of the threads which mention this chipset?


Hi Jonathan, I have tried really everything in the second post, I have checked to see if my wifi module is blocked, it is neither hard blocked or soft blocked. I have downloaded and swapped to new kernels and still it doesn't work, I have even downloaded what I think is the correct kernel but that also hasn't helped. I'm just a bit baffled at this point. I have a wifi adapter with a disk but because Garuda is arch based, I have struggled to download the kernel as I couldn't find a linux guide. So I'm basically at stalemate now. Is there any information I can give u which would help diagnose this problem? Thanks.

Which driver is in use?


How do I check that Jonathan?

It's in the thread. inxi -Faz is a useful command here.


Thank you Jonathan- here is the information I think you're looking for. Sorry I am new to all this!

Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard
driver: r8169 v: kernel port: 4000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac:
Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Hewlett-Packard
driver: rtl8723be v: kernel port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:b723 class-ID: 0280
IF: wlo1 state: down mac:

Have you tried disabling MAC Address randomization as I suggested for this adapter in the thread @jonathon linked for you.

This is a very problem prone adapter, and changes to the kernel often affect how well it works.

I would suggest testing the following kernels:


Be sure to test at least all those alternate kernels.

I would also highly suggest testing different Garuda live environments. Test the LXQT-Kwin and Xfce live disks to see if your wifi works correctly there.

Also, be sure to check that your bios is up to date.

Please perform all suggestions and report on the results.


I will perform all these suggestions in the next couple of days. Thank you both so much for your support and assistance and hopefully I will have solved this problem in the next few days.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.