WiFi not working (RTL8723BE)

Wifi is not working since the first installation of Garuda.
I tried to build driver rtlwifi_new repo, but that seems to be deprecated and doesn't work on new kernels versions.

And, Here I found that certain wifi drivers support are provided on kernel side, and RTL8723BE falls under that list.
I'm unable to find any proper solution for this.
Some assistance will be highly appreciated :slight_smile:

╰─λ rfkill list
0: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no
[🔴] × inxi -Fxxxza
System:    Kernel: 5.12.1-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=55e42994-0093-4206-876f-ddc3c21fb95d 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId serial: <filter> Chassis: 
type: 10 serial: <filter> 
Mobo: HP model: 81EC v: 61.59 serial: <filter> UEFI: Insyde v: F.48 date: 12/17/2019 
Battery:   ID-1: BAT1 charge: 29.4 Wh (100.0%) condition: 29.4/41.6 Wh (70.6%) volts: 16.7 min: 14.6 
model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter> status: Full 
CPU:       Info: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake family: 6 
model-id: 4E (78) stepping: 3 microcode: E2 cache: L2: 3 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19200 
Speed: 2703 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 2703 2: 2658 3: 2700 4: 2700 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds mitigation: Microcode 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard driver: i915 v: kernel 
bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300 
Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] 
vendor: Hewlett-Packard driver: radeon v: kernel alternate: amdgpu bus-ID: 01:00.0 
chip-ID: 1002:6660 class-ID: 0380 
Device-3: Chicony HP Truevision HD type: USB driver: uvcvideo bus-ID: 1-5:6 chip-ID: 04f2:b50d 
class-ID: 0e02 serial: <filter> 
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: ati,intel,radeon 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 21.1.0 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel 
v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403 
Sound Server-1: ALSA v: k5.12.1-zen2-1-zen running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: no 
Sound Server-4: PipeWire v: 0.3.27 running: yes 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 
v: kernel port: 4000 bus-ID: 02:00.0 chip-ID: 10ec:8136 class-ID: 0200 
IF: enp2s0 state: down mac: <filter> 
Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Hewlett-Packard driver: N/A 
modules: rtl8723be port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:b723 class-ID: 0280 
IF-ID-1: enp0s20f0u3 state: unknown speed: N/A duplex: N/A mac: <filter> 
Bluetooth: Device-1: Xiaomi Mi/Redmi series (RNDIS + ADB) type: USB driver: rndis_host v: kernel 
bus-ID: 1-3:7 chip-ID: 2717:ff88 class-ID: 0a00 serial: <filter> 
Device-2: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 1-4:5 
chip-ID: 0bda:b008 class-ID: e001 serial: <filter> 
Report: ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no 
software: yes address: <filter> 
Drives:    Local Storage: total: 1.13 TiB used: 67.28 GiB (5.8%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT240BX500SSD1 size: 223.57 GiB block-size: 
physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: R013
scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter>
rev: RSM4 scheme: MBR
Partition: ID-1: / raw-size: 84.71 GiB size: 84.71 GiB (100.00%) used: 22.18 GiB (26.2%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 55.9 MiB (58.2%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 84.71 GiB size: 84.71 GiB (100.00%) used: 22.18 GiB (26.2%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
ID-4: /var/log raw-size: 84.71 GiB size: 84.71 GiB (100.00%) used: 22.18 GiB (26.2%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
ID-5: /var/tmp raw-size: 84.71 GiB size: 84.71 GiB (100.00%) used: 22.18 GiB (26.2%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 1.91 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
Sensors:   System Temperatures: cpu: 51.5 C mobo: 29.8 C gpu: radeon temp: 52.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 214 Uptime: 31m wakeups: 1 Memory: 7.66 GiB used: 3.87 GiB (50.5%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1986 lib: 385
Shell: fish v: 3.2.2 running-in: konsole inxi: 3.3.04

:slight_smile:

1 Like

Does that mean your wifi was working on the live boot disk?

Have you tested other kernels yet? I would start with the LTS kernel.

Have you read the Arch Wiki entry regarding your adapter?

Are you dual booting with Windows?

Is your bios up to date?

If you have tried all the above with no luck then power down your system and remove the battery and power plug.

Plug the laptop back into AC power outlet. Do not put the laptop battery back yet. Restart the laptop and then reset your bios back to the factory default.

5 Likes

There has been no response from the OP in over a month. The thread is now deemed abandoned. I am locking the thread.

If the OP wishes the thread reopened please PM a mod other than myself as I am currently not accepting PM's.

2 Likes