RTL8723BE - Wifi not detected

Dear Expert,

I was using linux mint 20 but wifi was not working there. I recently installed garuda linux and same issue i am facing here as well. Could anyone please tell me how to fix this problem ?

Only wired connection works fine.
Many thanks in advance,
Deepak

If u have a broadcom card install broadcom-sta

Intel is usually preinstalled

In most distros

Other than fsf endorsed ones

If you have a broadcom wireless card and installed broadcom-sta

You have to reboot after installing it

I dont know about atheros as i dont have an atheros laptop

U can know what wireless card you have by doing lspci


The network controller brand is what you are looking for

Hope it helped .

This is screenshot of lspci
Screenshot_13

Does the laptop have a wireless card it doesnt look like it does

Maybe your screenshot isnt covering the full commabd output

No it is covering full command output.

I forgot to tell that sometime wifi works, if i restart again and again it , sometime i have seen it works for short time.

Before linux mint 20, i was using linux 18 and wifi was working fine on linux 18.
but when i installed linux 20 i started facing problem with wifi.
and one more thing: Bluetooth tethering was working fine on linux mint 20 but in garuda linux it works for few mins only after that i restart again my laptop.

Does it work flawlessly in windows if not it is probably a hardware issue

Yes, it was working fine on window 10, i never faced wifi issue on window.

Then idk dude

Should I install idk ?
sorry i couldn't understand

Idk means i dont know

Check the output of

inxi -Nxxxz

and look for your wifi adapter chipset. Then, search the AUR for a similar adapter. For example, for an RTL8888EFG you can try:

yay -Ss 8888

Look at the package name and the description. If you find a package that matches your adapter then you can try installing it.

Thank you for your reply.
this is output of inxi -Nxxxz

╭─deepak at deepak-hp15notebookpc in ⌁
╰─λ inxi -Nxxxz
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 
           bus ID: 08:00.0 chip ID: 10ec:8136 class ID: 0200 

and if i try this yay -Ss 810 .
i see a similar adapter:

chaotic-aur/r8101-dkms 1.035.03-1 (83.3 KiB 595.3 KiB) 
    RTL810xE Fast Ethernet Driver (DKMS)

OK, so the wifi adapter isn't showing up at all.

Do you have a wifi adapter?

Is it enabled in the BIOS?

Did you replace the HP wifi card with a non-HP card that is blocked by the BIOS?

1 Like

As @jonathon mentioned you need to check if your device is soft/hard blocked.

Run this command and post:

rfkill list

I would suggest installing the linux-lts and linux-mainline kernels to see if your wifi is detected.

You can install a new kernel with sudo pacman -S name_of_kernel. You must substitute the name of the kernel you wish to install in the command.

If that doesn't work I would suggest unplugging/removing all battery or power cords and reset your bios back to the factory default.

Without more information that's all I can suggest.I can't read your picture as I'm only on my cell phone.

Please post as text:

inxi -Fxxxza

No more pics please

Is your bios up to date?

2 Likes

Today wifi worked fine for few hrs but after sometime it didn't detect wifi.

here is output of rfkill list

╰─λ rfkill list
7: phy2: Wireless LAN
        Soft blocked: no
        Hard blocked: no
8: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

let me try to install kernels you suggested

and this is output of inxi -Fxxza

╭─deepak at deepak-hp15notebookpc in ⌁
╰─λ inxi -Fxxxza
System:    Kernel: 5.10.14-119-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
           root=UUID=4cf16ba0-c600-4313-bd21-f757aba5e5a8 rw [email protected] quiet splash rd.udev.log_priority=3 
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 resume=UUID=22e76798-065d-41d5-9458-0f89c0a09758 
           loglevel=3 
           Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP 15 Notebook PC v: 098F120000000000000600087 serial: <filter> 
           Chassis: type: 10 serial: <filter> 
           Mobo: Hewlett-Packard model: 2212 v: 86.49 serial: <filter> UEFI [Legacy]: Insyde v: F.36 date: 12/18/2014 
Battery:   ID-1: BAT1 charge: 23.8 Wh condition: 23.8/23.8 Wh (100%) volts: 16.9/14.8 model: 13-14 OA04041 type: Li-ion 
           serial: <filter> status: Full 
CPU:       Info: Dual Core model: Intel Core i3-4005U bits: 64 type: MT MCP arch: Haswell family: 6 model-id: 45 (69) 
           stepping: 1 microcode: 26 L2 cache: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 13580 
           Speed: 1692 MHz min/max: 800/1700 MHz Core speeds (MHz): 1: 1692 2: 1695 3: 1693 4: 1693 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
           Type: l1tf mitigation: PTE Inversion 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0a16 class ID: 0300 
           Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] vendor: Hewlett-Packard driver: N/A 
           alternate: nouveau, nvidia_drm, nvidia bus ID: 09:00.0 chip ID: 10de:1140 class ID: 0302 
           Device-3: Chicony HP Truevision HD camera type: USB driver: uvcvideo bus ID: 1-1.5:4 chip ID: 04f2:b40e 
           class ID: 0e02 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: modesetting alternate: fbdev,intel,vesa 
           display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6") diag: 394mm (15.5") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 20.3.4 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           chip ID: 8086:0a0c class ID: 0403 
           Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:9c20 class ID: 0403 
           Sound Server: ALSA v: k5.10.14-119-tkg-bmq 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel port: 5000 
           bus ID: 08:00.0 chip ID: 10ec:8136 class ID: 0200 
           IF: enp8s0 state: down mac: <filter> 
           Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Hewlett-Packard driver: rtl8723be v: kernel 
           modules: wl port: 3000 bus ID: 0a:00.0 chip ID: 10ec:b723 class ID: 0280 
           IF: wlo1 state: up mac: <filter> 
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus ID: 1-1.4:3 chip ID: 0bda:b001 class ID: e001 
           serial: <filter> 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 931.51 GiB used: 15.36 GiB (1.6%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10JPVX-60JC3T0 size: 931.51 GiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 1A01 
Partition: ID-1: / raw size: 923.21 GiB size: 923.21 GiB (100.00%) used: 15.36 GiB (1.7%) fs: btrfs dev: /dev/sda1 
           maj-min: 8:1 
           ID-2: /home raw size: 923.21 GiB size: 923.21 GiB (100.00%) used: 15.36 GiB (1.7%) fs: btrfs dev: /dev/sda1 
           maj-min: 8:1 
           ID-3: /var/log raw size: 923.21 GiB size: 923.21 GiB (100.00%) used: 15.36 GiB (1.7%) fs: btrfs dev: /dev/sda1 
           maj-min: 8:1 
           ID-4: /var/tmp raw size: 923.21 GiB size: 923.21 GiB (100.00%) used: 15.36 GiB (1.7%) fs: btrfs dev: /dev/sda1 
           maj-min: 8:1 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: partition size: 8.3 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2 maj-min: 8:2 
           ID-2: swap-2 type: zram size: 966.2 MiB used: 4.2 MiB (0.4%) priority: 32767 dev: /dev/zram0 
           ID-3: swap-3 type: zram size: 966.2 MiB used: 4.2 MiB (0.4%) priority: 32767 dev: /dev/zram1 
           ID-4: swap-4 type: zram size: 966.2 MiB used: 4.4 MiB (0.5%) priority: 32767 dev: /dev/zram2 
           ID-5: swap-5 type: zram size: 966.2 MiB used: 3.9 MiB (0.4%) priority: 32767 dev: /dev/zram3 
Sensors:   System Temperatures: cpu: 50.0 C mobo: 50.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 203 Uptime: 6m wakeups: 1 Memory: 3.77 GiB used: 2.85 GiB (75.4%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 Packages: pacman: 1266 lib: 311 Shell: fish v: 3.1.2 running in: konsole inxi: 3.3.00 
╭─deepak at deepak-hp15notebookpc in ⌁

Apparently your wifi card is up and running.

Also not sure why that didn't show up before in your inxi -N output - what did you change?

2 Likes

I think I tried to Swap kernels at garuda advanced boot menu option.
I was selecting some random kernel yesterday night.

1 Like

From your above output. There is something drastically wrong if your system is loading the Broadcom WL driver for a Realtek chipset. I would look in the Garuda Hardware manager app and uninstall any Broadcom WL driver listed there.

You can run this command to temporarily unload the wl module:

sudo modprobe -r wl; sudo modprobe -r rtl8723be; sleep 3; sudo modprobe rtl8723be; sleep 3; sudo systemctl restart NetworkManager

I would also disable MAC Address randomization. This should be an easily selectable option in the Garuda network utility (or search online for directions).

Unfortunately, that is one of the more problematic Realtek adapters that you own. I've probably answered a hundred or more help requests on that adapter. Fortunately, it is becoming more well supported as the driver matures on the newer kernels. It still has a fair share of issues though, as its not a great adapter (but reliability is improving for it).

3 Likes

Thread is deemed abandoned.

Thread is now closed.

PM a mod if you are the OP and wish the issue reopened.