Wifi adapter not found

garuda-inxi

  Kernel: 6.4.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=4bc705c8-f846-48f0-884f-0f33ad5facc3 rw rootflags=subvol=@
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 ibt=off
  Desktop: GNOME v: 43.5 tk: GTK v: 3.24.37 wm: gnome-shell dm: GDM v: 44.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 81FS v: Lenovo E41-25
    serial: <superuser required> Chassis: type: 10 v: Lenovo E41-25
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <superuser required>
    UEFI: LENOVO v: 7UCN28WW(V2.02) date: 11/14/2019
Battery:
  ID-1: BAT1 charge: 16.8 Wh (44.2%) condition: 38.0/48.0 Wh (79.1%)
    volts: 10.7 min: 10.8 model: LG PABAS0241231 type: Li-ion serial: <filter>
    status: discharging cycles: 221
CPU:
  Info: model: AMD PRO A6-7350B R5 5 COMPUTE CORES 2C+3G bits: 64 type: MCP
    arch: Excavator level: v3 note: check built: 2015 process: GF 28nm
    family: 0x15 (21) model-id: 0x70 (112) stepping: 0 microcode: 0x6006705
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 192 KiB
    desc: d-2x32 KiB; i-2x64 KiB L2: 2 MiB desc: 2x1024 KiB
  Speed (MHz): avg: 1598 high: 1800 min/max: 1400/3000 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1397 2: 1800
    bogomips: 11978
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Lenovo
    driver: amdgpu v: kernel arch: GCN-3 code: Volcanic Islands
    process: TSMC 28nm built: 2014-19 ports: active: eDP-1
    empty: DP-1,HDMI-A-1 bus-ID: 00:01.0 chip-ID: 1002:98e4 class-ID: 0300
  Device-2: IMC Networks EasyCamera type: USB driver: uvcvideo bus-ID: 2-1:2
    chip-ID: 13d3:a745 class-ID: 0e02 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.8 with: Xwayland v: 23.1.1
    compositor: gnome-shell driver: gpu: amdgpu display-ID: 0
  Monitor-1: eDP-1 model: AU Optronics 0x2e3c built: 2013 res: 1366x768
    dpi: 112 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
    ratio: 16:9 modes: max: 1366x768 min: 640x480
  API: EGL/GBM Message: No known Wayland EGL/GBM data sources.
Audio:
  Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:01.1
    chip-ID: 1002:15b3 class-ID: 0403
  Device-2: AMD Family 15h Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:09.2 chip-ID: 1022:157a class-ID: 0403
  API: ALSA v: k6.4.12-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Lenovo driver: N/A modules: ath10k_pci pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
  IF-ID-1: enp0s16u2 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth:
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-1.4:3
    chip-ID: 0cf3:e500 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
  Device-2: OPPO RMX1941 type: USB driver: rndis_host v: kernel
    bus-ID: 2-2:28 chip-ID: 22d9:276a class-ID: 0a00 serial: <filter>
Drives:
  Local Storage: total: 931.51 GiB used: 5.92 GiB (0.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 0E scheme: GPT
Partition:
  ID-1: / raw-size: 139.39 GiB size: 139.39 GiB (100.00%)
    used: 5.88 GiB (4.2%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 35.9 MiB (7.0%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 139.39 GiB size: 139.39 GiB (100.00%)
    used: 5.88 GiB (4.2%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
  ID-4: /var/log raw-size: 139.39 GiB size: 139.39 GiB (100.00%)
    used: 5.88 GiB (4.2%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
  ID-5: /var/tmp raw-size: 139.39 GiB size: 139.39 GiB (100.00%)
    used: 5.88 GiB (4.2%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.72 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 72.4 C mobo: N/A gpu: amdgpu temp: 72.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 207 Uptime: 39m wakeups: 1 Memory: 3.72 GiB
  used: 1.88 GiB (50.6%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1104
  libs: 340 tools: pamac,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.26
Garuda (2.6.16-1):
  System install date:     2023-09-03
  Last full system update: 2023-09-03
  Is partially upgraded:   Yes
  Relevant software:       snapper NetworkManager dracut(custom) mkinitcpio
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:

I found it!

Now if you want it to actually work:thinking: now that’s another thing.

A lot of issues with this adaptor in the forum, so do some searching and update the thread to tell us what you have tried. So far this topic has no information.

This looks like a good place to start:

Be sure to disable the Windows “fast startup” feature, which can hold down the network card.

By the way, you are not going to get anywhere until you get this straightened out:

Run garuda-update and reboot.

5 Likes

Try using lts kernel first,

sudo pacman -S linux-lts linux-lts-headers

choose the lts kernel from grub advanced menu while booting. If it doesn’t help
Use forum search next,

If your problem is different from the issues in the threads on forum or you have already tried all possible solutions mentioned in these threads. Then please inform us of what you have already tried and how your issue differs from the one in the thread.

5 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.