Problem with network (Qualcomm Atheros QCA9377)

Hello, After install Garuda and restart him system notification show me notification that cannot configure wlp2s0 and I can't connect with my Wi-Fi. I try dr46agonized Garuda and KDE Plasma, that problem is on both Garuda's. In the pictures below I show that notification and logs from systemctl NetworkManager. My network card is Qualcomm Atheros QCA9377

How can I fix this problem?

logout then login see if you can connect to wifi

I try 10 times. Unfortunately, it's still the same. Once connect, but if I restart this error still appears

Try running this command in the terminal:

bash -c "nmcli networking off; sudo systemctl stop NetworkManager; sudo ip link set wlp2s0 down; sudo rmmod -vf ath10k_pci; sudo rmmod -vf ath10k_core; sleep 5; sudo modprobe -v ath10k_core; sudo modprobe -v ath10k_pci; sudo ip link set wlp2s0 up; sudo systemctl start NetworkManager; nmcli networking on"

See if that improves things. Please post the output of those commands as text.

If that does not help then I would try one of the live ISO's that use connman instead of network manager to narrow the issue down somewhat. Try LX QT-Kwin from a live boot environment and report if you can connect properly using connman as a troubleshooting measure.

I quite like the LX QT-Kwin edition. If it works properly for you then you might even want to install that version (especially if your hardware is low spec).

It also would be nice to know the following output (as text not pics):

inxi -SMa; hwinfo --netcard --bluetooth | grep -Ei "(hotplug|speed|model|status|cmd|file|detected|driver:)" | grep -v "Config S"

Welcome to the forum.

2 Likes

Ok. This commands I execute on dr46agonized Garuda.

First thing I do is execute systemctl NetworkManager log:

NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
             └─NetworkManager-ovs.conf
     Active: active (running) since Mon 2020-12-07 11:49:54 CET; 1min 9s ago
       Docs: man:NetworkManager(8)
   Main PID: 447 (NetworkManager)
      Tasks: 3 (limit: 16661)
     Memory: 15.6M
        CPU: 489ms
     CGroup: /system.slice/NetworkManager.service
             └─447 /usr/bin/NetworkManager --no-daemon

Dec 07 11:50:57 kuclaw NetworkManager[447]: <info>  [1607338257.0486] manager: rfkill: Wi-Fi hardware radio set disabled
Dec 07 11:50:57 kuclaw NetworkManager[447]: <info>  [1607338257.0486] device (wlp2s0): state change: disconnected -> unavailable (reason 'none', sys-iface-state: 'managed')
Dec 07 11:50:57 kuclaw NetworkManager[447]: <info>  [1607338257.0496] audit: op="radio-control" arg="wireless-enabled" pid=1124 uid=1000 result="success"
Dec 07 11:50:57 kuclaw NetworkManager[447]: <info>  [1607338257.0497] device (p2p-dev-wlp2s0): state change: disconnected -> unavailable (reason 'supplicant-failed', sys-iface-state: 'managed')
Dec 07 11:50:57 kuclaw NetworkManager[447]: <info>  [1607338257.0527] manager: rfkill: Wi-Fi now disabled by radio killswitch
Dec 07 11:50:58 kuclaw NetworkManager[447]: <info>  [1607338258.6716] manager: rfkill: Wi-Fi hardware radio set enabled
Dec 07 11:50:58 kuclaw NetworkManager[447]: <warn>  [1607338258.8036] platform-linux: do-change-link[2]: failure changing link: failure 16 (Device or resource busy)
Dec 07 11:50:58 kuclaw NetworkManager[447]: <info>  [1607338258.8039] audit: op="radio-control" arg="wireless-enabled" pid=1124 uid=1000 result="success"
Dec 07 11:50:58 kuclaw NetworkManager[447]: <info>  [1607338258.8046] manager: rfkill: Wi-Fi now enabled by radio killswitch
Dec 07 11:50:58 kuclaw NetworkManager[447]: <warn>  [1607338258.9379] platform-linux: do-change-link[2]: failure changing link: failure 16 (Device or resource busy)

Logs from bash -c "nmcli networking off; sudo systemctl stop NetworkManager; sudo ip link set wlp2s0 down; sudo rmmod -vf ath10k_pci; sudo rmmod -vf ath10k_core; sleep 5; sudo modprobe -v ath10k_core; sudo modprobe -v ath10k_pci; sudo ip link set wlp2s0 up; sudo systemctl start NetworkManager; nmcli networking on":

insmod /lib/modules/5.9.11-zen2-1-zen/kernel/drivers/net/wireless/ath/ath10k/ath10k_core.ko.xz 
insmod /lib/modules/5.9.11-zen2-1-zen/kernel/drivers/net/wireless/ath/ath10k/ath10k_pci.ko.xz 
Cannot find device "wlp2s0"

Logs from inxi -SMa; hwinfo --netcard --bluetooth | grep -Ei "(hotplug|speed|model|status|cmd|file|detected|driver:)" | grep -v "Config S":

 System:    Host: kuclaw Kernel: 5.9.11-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=a816df4c-53d6-49ff-9f70-91731d9530bc rw 
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 resume=UUID=c6a708a6-d351-4b7a-9de5-fc2ed82ec4c6 loglevel=3 
           Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Laptop System: LENOVO product: 81N6 v: Lenovo IdeaPad C340-14API serial: <superuser/root required> Chassis: 
           type: 10 v: Lenovo IdeaPad C340-14API serial: <superuser/root required> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0R32891 WIN serial: <superuser/root required> UEFI: LENOVO v: AGCN27WW(V1.10) 
           date: 07/08/2020 
  Model: "Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter"
  Driver: "ath10k_pci"
    Driver Status: ath10k_pci is active
    Driver Activation Cmd: "modprobe ath10k_pci"
  Model: "Qualcomm Atheros Bluetooth Device"
  Hotplug: USB
  Driver: "btusb"
  Speed: 12 Mbps
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"

Now I didn't try LX QT-Kwin. If I try I write that is the problem is solved.

Well the problem will be solved if you like LXQT and want to install it. Lxqt is rather minimalist and is more suitable for older hardware. As your hardware is not that old that may not be a desktop that intests you.

If it works on Lxqt it tells us through a process of elimination which networking components are more likely to be causing your issue. It is more of a troubleshooting step than a solution. However, I guess if you like Lxqt and don't mind installing and using that desktop then your problem would be solved as far as your networking issue goes. :smile:

2 Likes

Please post:

rfkill list
lsmod | sort
3 Likes

I just checked the LX QT-Kwin, unfortunately the problem with this version is the same. Only after installation I could log into my Wi-Fi network, after rebooting I couldn't.

Below I place a window from connman, after rebooting.

After the first reboot I had a bug, unfortunately I don't have it saved, but something was related to the bus, I solved it by systemctl enable connman. Unfortunately, with subsequent reboots you still can't see the network.

To execute rfkill list lsmod | sort I must recover dr46agonized Garuda

I'm surprised because I tried Manjaro and Endeavouros, which are also archives and there the internet worked for me without any problems, so this is rather a software problem.

Before restoring the dr46agonized, I will save systemctl status connman from LX QT-Kwin with rfkill list and lsmod | sort.

I post rfkill list lsmod | sort from dr46agonized

rfkill list


0: ideapad_wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: ideapad_bluetooth: Bluetooth
        Soft blocked: yes
        Hard blocked: no
2: hci0: Bluetooth
        Soft blocked: yes
        Hard blocked: no
3: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

lsmod | sort

ac                     16384  0
acpi_cpufreq           28672  0
aesni_intel           372736  3
af_alg                 32768  6 algif_hash,algif_skcipher
agpgart                53248  5 intel_agp,intel_gtt,ttm,nouveau,drm
algif_hash             16384  1
algif_skcipher         16384  1
amdgpu               6922240  55
ath10k_core           651264  1 ath10k_pci
ath10k_pci             69632  0
ath                    36864  1 ath10k_core
atkbd                  36864  0
battery                20480  0
blake2b_generic        20480  0
bluetooth             774144  41 btrtl,btintel,btbcm,bnep,btusb,rfcomm
bmc150_accel_core      40960  2 bmc150_accel_spi,bmc150_accel_i2c
bmc150_accel_i2c       16384  0
bmc150_accel_spi       16384  0
bnep                   28672  2
btbcm                  16384  1 btusb
btintel                32768  1 btusb
btrfs                1597440  1
btrtl                  28672  1 btusb
btusb                  69632  0
ccp                   122880  1 kvm_amd
cec                    81920  2 drm_kms_helper,i915
cfg80211              925696  3 ath,mac80211,ath10k_core
cmac                   16384  2
cqhci                  32768  1 sdhci_pci
crc16                  16384  1 bluetooth
crc32c_generic         16384  0
crc32c_intel           24576  2
crc32_pclmul           16384  0
crct10dif_pclmul       16384  1
cryptd                 28672  3 crypto_simd,ghash_clmulni_intel
crypto_simd            16384  1 aesni_intel
crypto_user            16384  0
drm                   643072  21 gpu_sched,drm_kms_helper,amdgpu,radeon,i915,ttm,nouveau
drm_kms_helper        282624  4 amdgpu,radeon,i915,nouveau
ecc                    36864  1 ecdh_generic
ecdh_generic           16384  1 bluetooth
edac_mce_amd           32768  0
enclosure              16384  1 ses
evdev                  24576  20
fat                    90112  1 vfat
fb_sys_fops            16384  1 drm_kms_helper
fuse                  143360  5
ghash_clmulni_intel    16384  0
glue_helper            16384  1 aesni_intel
gpu_sched              40960  1 amdgpu
hid                   151552  11 i2c_hid,wacom,usbhid,hid_multitouch,hid_sensor_hub,hid_generic,hid_logitech_dj,hid_logitech_hidpp
hid_generic            16384  0
hid_logitech_dj        28672  0
hid_logitech_hidpp     53248  0
hid_multitouch         32768  0
hid_sensor_accel_3d    20480  1
hid_sensor_hub         24576  3 hid_sensor_trigger,hid_sensor_iio_common,hid_sensor_accel_3d
hid_sensor_iio_common    20480  2 hid_sensor_trigger,hid_sensor_accel_3d
hid_sensor_trigger     20480  2 hid_sensor_accel_3d
i2c_algo_bit           16384  4 amdgpu,radeon,i915,nouveau
i2c_hid                36864  0
i2c_piix4              28672  0
i8042                  36864  1 ideapad_laptop
i915                 2871296  0
ideapad_laptop         24576  0
industrialio           94208  6 industrialio_triggered_buffer,hid_sensor_trigger,kfifo_buf,hid_sensor_accel_3d,bmc150_accel_core
industrialio_triggered_buffer    16384  2 hid_sensor_trigger,bmc150_accel_core
input_leds             16384  0
intel_agp              24576  0
intel_gtt              24576  2 intel_agp,i915
ip_tables              32768  0
irqbypass              16384  1 kvm
joydev                 28672  0
k10temp                20480  0
kfifo_buf              16384  1 industrialio_triggered_buffer
kvm                   937984  1 kvm_amd
kvm_amd               122880  0
ledtrig_audio          16384  1 snd_hda_codec_generic
libarc4                16384  1 mac80211
libcrc32c              16384  1 btrfs
libps2                 24576  1 atkbd
mac80211             1110016  1 ath10k_core
mac_hid                16384  0
mc                     69632  4 videodev,videobuf2_v4l2,uvcvideo,videobuf2_common
mmc_core              200704  3 sdhci,cqhci,sdhci_pci
Module                  Size  Used by
mousedev               24576  0
msr                    16384  0
mxm_wmi                16384  1 nouveau
nls_cp437              20480  1
nls_iso8859_1          16384  1
nouveau              2490368  0
pinctrl_amd            32768  3
radeon               1761280  0
raid6_pq              122880  1 btrfs
rapl                   16384  0
rc_core                61440  1 cec
rfcomm                 94208  12
rfkill                 32768  8 bluetooth,ideapad_laptop,cfg80211
rng_core               20480  2 ccp,tpm
scsi_transport_sas     49152  1 ses
sdhci                  86016  1 sdhci_pci
sdhci_pci              65536  0
serio                  28672  4 serio_raw,atkbd,i8042
serio_raw              20480  0
ses                    20480  0
snd                   118784  18 snd_hda_codec_generic,snd_hda_codec_conexant,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_pcm
snd_hda_codec         180224  4 snd_hda_codec_generic,snd_hda_codec_conexant,snd_hda_codec_hdmi,snd_hda_intel
snd_hda_codec_conexant    28672  1
snd_hda_codec_generic   110592  1 snd_hda_codec_conexant
snd_hda_codec_hdmi     81920  1
snd_hda_core          114688  5 snd_hda_codec_generic,snd_hda_codec_conexant,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_hda_intel          57344  5
snd_hwdep              16384  1 snd_hda_codec
snd_intel_dspcfg       24576  1 snd_hda_intel
snd_pci_acp3x          20480  0
snd_pcm               163840  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_rn_pci_acp3x       20480  0
snd_timer              45056  1 snd_pcm
soundcore              16384  1 snd
sp5100_tco             20480  0
sparse_keymap          16384  1 ideapad_laptop
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
tpm                    77824  3 tpm_tis,tpm_crb,tpm_tis_core
tpm_crb                24576  0
tpm_tis                16384  0
tpm_tis_core           32768  1 tpm_tis
ttm                   126976  3 amdgpu,radeon,nouveau
uas                    32768  0
uinput                 24576  0
usbhid                 65536  2 wacom,hid_logitech_dj
usb_storage            86016  2 uas
uvcvideo              118784  0
vfat                   24576  1
videobuf2_common       65536  2 videobuf2_v4l2,uvcvideo
videobuf2_memops       20480  1 videobuf2_vmalloc
videobuf2_v4l2         32768  1 uvcvideo
videobuf2_vmalloc      20480  1 uvcvideo
videodev              290816  3 videobuf2_v4l2,uvcvideo,videobuf2_common
wacom                 126976  0
wmi                    36864  4 wmi_bmof,ideapad_laptop,mxm_wmi,nouveau
wmi_bmof               16384  0
xhci_hcd              303104  1 xhci_pci
xhci_pci               20480  0
xhci_pci_renesas       20480  1 xhci_pci
xor                    24576  1 btrfs
x_tables               57344  1 ip_tables
zram                   36864  4

Now if I restore Garuda from my backup my computer connect with Wi-Fi 4 or 5 times in row, but after next reboot problem still appear. I don't know what is this. Maybe sequence of run services.

Are you sure you haven't set restrictions in your router as to which IP addresses (or ranges) or MAC addresses are permitted on your network. This seems doubtful from the intermittent nature of your problem.

Just to be sure I'd check that you have the most recent firmware installed for your router. I would also consider resetting your router to the factory default configuration. Also, be sure you reboot your router whenever you have connectivity issues.

Another thing you might want to test is that MAC Address randomization is disabled. It is simply a matter of creating a configuration file to do this.

See:

Be sure to reboot your computer and your router after creating the required conf file.

Another thing you could test is in Network managers wifi properties try setting a "static IP address" for your connection. This sometimes helps.

Once you have MAC Address randomization disabled in Network Manager you could also try setting your device to be whitelisted in your router via its MAC Address. This is usually called "MAC Address association" or some similar term in your routers configuration.

You could also test disabling your routers wifi security feature very briefly to see if you can connect properly with it disabled. Be sure to reboot the router after making this change. Never leave your wifi network unprotected for any length of time, this is simply a very short term trouble shooting measure.

Please do not disregard these suggestions because Windows or some other distro works properly with your router. It can still be your router settings affecting this issue because Garuda's networking components may be configured in a different manner than others.

Garuda tends to use more cutting edge network components than other distros which could be causing your issue.

This may take a while to work through the possibilities of what may be causing this. I will need more outputs (which I will post later).

Record all the changes you make and report in detail on the results please.

2 Likes

I try to turn off MAC randomization and this didn't help. Once I connect with Wi-Fi and when I check status of connection I have "no connection". When I disconnect with my router I have checked syatus of NetworkManager and it shows me:

NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
             └─NetworkManager-ovs.conf
     Active: active (running) since Tue 2020-12-08 08:41:42 CET; 2min 56s ago
       Docs: man:NetworkManager(8)
   Main PID: 445 (NetworkManager)
      Tasks: 3 (limit: 16661)
     Memory: 21.1M
        CPU: 482ms
â—Ź NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
             └─NetworkManager-ovs.conf
     Active: active (running) since Tue 2020-12-08 08:45:06 CET; 4s ago
       Docs: man:NetworkManager(8)
   Main PID: 10557 (NetworkManager)
      Tasks: 4 (limit: 16661)
     Memory: 2.8M
        CPU: 143ms
     CGroup: /system.slice/NetworkManager.service
             └─10557 /usr/bin/NetworkManager --no-daemon

Dec 08 08:45:06 kuclaw NetworkManager[10557]: <info>  [1607413506.9470] manager: (lo): new Generic device (/org/freedesktop/NetworkManager/Devices/1)
Dec 08 08:45:06 kuclaw NetworkManager[10557]: <info>  [1607413506.9480] device (wlp2s0): driver supports Access Point (AP) mode
Dec 08 08:45:06 kuclaw NetworkManager[10557]: <info>  [1607413506.9495] manager: (wlp2s0): new 802.11 Wi-Fi device (/org/freedesktop/NetworkManager/Devices/2)
Dec 08 08:45:06 kuclaw NetworkManager[10557]: <info>  [1607413506.9519] device (wlp2s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Dec 08 08:45:07 kuclaw NetworkManager[10557]: <warn>  [1607413507.0834] platform-linux: do-change-link[2]: failure changing link: failure 16 (Device or resource busy)
Dec 08 08:45:07 kuclaw NetworkManager[10557]: <info>  [1607413507.0937] ovsdb: Could not connect: No such file or directory
Dec 08 08:45:07 kuclaw NetworkManager[10557]: <info>  [1607413507.0958] modem-manager: ModemManager available
Dec 08 08:45:07 kuclaw NetworkManager[10557]: <info>  [1607413507.0969] agent-manager: agent[951482eecaae22c6,:1.24/org.kde.plasma.networkmanagement/1000]: agent registered
Dec 08 08:45:07 kuclaw NetworkManager[10557]: <error> [1607413507.3609] device (wlp2s0): Couldn't initialize supplicant interface: GDBus.Error:fi.w1.wpa_supplicant1.UnknownError: wpa_supplicant couldn't grab this interface.
Dec 08 08:45:07 kuclaw NetworkManager[10557]: <info>  [1607413507.3610] manager: startup complete

I don't think so it is something with my router. I think is a software problem, because when I try to connect after some hours I can connect with Wi-Fi and I have the internet, but if I reset I don't have and show me some problems when I try to check status of NetworkManager. I think the NetworkManager can't hold stable connection with the router.

systemctl status NetworkManager can show me

â—Ź NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
             └─NetworkManager-ovs.conf
     Active: active (running) since Tue 2020-12-08 09:20:18 CET; 3min 19s ago
       Docs: man:NetworkManager(8)
   Main PID: 473 (NetworkManager)
      Tasks: 3 (limit: 16661)
     Memory: 17.3M
        CPU: 321ms
     CGroup: /system.slice/NetworkManager.service
             └─473 /usr/bin/NetworkManager --no-daemon

Dec 08 09:20:51 kuclaw NetworkManager[473]: <info>  [1607415651.9745] Config: added 'auth_alg' value 'OPEN'
Dec 08 09:20:51 kuclaw NetworkManager[473]: <info>  [1607415651.9745] Config: added 'psk' value '<hidden>'
Dec 08 09:20:52 kuclaw NetworkManager[473]: <info>  [1607415652.1522] device (wlp2s0): supplicant interface state: disconnected -> interface_disabled
Dec 08 09:20:52 kuclaw NetworkManager[473]: <info>  [1607415652.1523] device (p2p-dev-wlp2s0): supplicant management interface state: disconnected -> interface_disabled
Dec 08 09:21:17 kuclaw NetworkManager[473]: <warn>  [1607415677.5799] device (wlp2s0): Activation: (wifi) association took too long, failing activation
Dec 08 09:21:17 kuclaw NetworkManager[473]: <info>  [1607415677.5800] device (wlp2s0): state change: config -> failed (reason 'ssid-not-found', sys-iface-state: 'managed')
Dec 08 09:21:17 kuclaw NetworkManager[473]: <info>  [1607415677.5807] manager: NetworkManager state is now DISCONNECTED
Dec 08 09:21:17 kuclaw NetworkManager[473]: <warn>  [1607415677.5832] device (wlp2s0): Activation: failed for connection 'PlastCom_1088-5G'
Dec 08 09:21:17 kuclaw NetworkManager[473]: <info>  [1607415677.5839] device (wlp2s0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Dec 08 09:21:18 kuclaw NetworkManager[473]: <info>  [1607415678.5979] manager: startup complete

I have checked last status of NetworkManager after that when it try long connect to WiFi, and show me system notification that wlp2s0 couldn't be configured.

you can try disabling autologin

i think your issue is related to it

1 Like

I don't think so, I can't connect with WiFi. I don't have problems with popup to write my password.

Edit: I have disable autologin by default I installed

I try tethering and the internet is working, but I haven't always could connect with internet by ethernet, so that is temporary solution

No offense, but your intuition isn't really important here. If your networking knowledge and prowess was superior to others advising you then you wouldn't need to ask for assistance.

Why bother asking for help if you simply are going to disregard the advice offered to you. I went to great lengths to write up steps that would be able to eliminate the router from the equation.

I asked you to try setting up a static IP address, did you?

Please confirm the extistance of the conf file to disable MAC Address randomization by using:

cat /path/to/conf/file

Again, your intuition is not that relevant here, working through the steps I ask you to perform in the correct order is the important thing. If it was a Network Manager specific issue then your connection would have been working correctly when you tested the Garuda version using Connman (replacement for NM).

You also did not reset the router to factory or test the router without authentication. If you have a replacement router you could swap in, then these steps could be skipped.

Testing a static IP is rather important as well as knowing your default name servers.

Please provide a written summation when you have performed the steps I have outlined previously.

Thank you.

3 Likes

I'm sorry, I didn't mean to attack you, I wanted to tell you what I think about it, because I'm afraid I could do something wrong and expose the computer and the network to danger from outside. I didn't mean anything wrong with it. I would prefer to test the software solutions first and then, if that doesn't help, then do some other steps to solve the problem.

First I installed again the latest version of Garuda Dr46agonized (from 05.12.2020) and then I set the static IP, at first everything worked, but after about 10 reboots back there was a problem with connecting to my network, but also as before there was no Wi-FI network, then I turned off the MAC address draw and after finding my Wi-Fi network it did not want to connect, and when the connection time was exceeded, suddenly all networks in my area were no longer visible.

I turned off the MAC address draw as follows:

[device]
wifi.scan-rand-mac-address=no

In which file location did you place those settings. That is not a command, but the contents of a configuration file.

Have you at least performed a reboot of your router?

A reset to the factory default settings on the router would be preferable.

Just because other machines are connecting properly through the router does not mean it can not be the router.

I have experienced situations where other machines were connecting normally through the router, but one Linux machine was not. Rebooting the router made no difference, but resetting it to the factory default fixed things up. That would not seem logical, but it happens.

Exactly the same way when I ask people to replace their Ethernet cable and they insist it can't be the cable because it works fine in Windows. Seems logical, but that assumption is often wrong. Windows and Linux are not the same.

Please post:

cat /etc/resolv.conf

I format Garuda (I don't set static IP and set off MAC randomization) after reset my router to default settings. I think it helps me. I try about 10-15 times restart and shut down system and the result is 2 or 3 times show the problem with wlp2s0, but if I reset computer problem disappear, so it's much better than before, because before even reset did not help when there was a problem with wlp2s0. I must reset many times to show me networks, now all it takes is one reset or two. And then if I disconnect with my network I lost all networks in my surroundings, now it takes about 5 seconds and show me find networks. I'm curious to see how it will be in the future if this problem with networks will notoriously appear, or how it will be like now sporadic cases, and how it will be enough to reset the computer.

I had almost the same problem today (banging my head for finding the reason...). After an update... of course!
My wifi was successfully connected, but no DNS lookup was ever possible.

I was lucky I had found an old Arch bug report, which pointed me to the proper direction.

Long story short, it was solved (properly I suppose) enabling systemd-resolved.service

sudo systemctl enable --now systemd-resolved.service

I don't know why the update AI failed to fix this properly, as claimed by dev's answer in the bug report. But we still have a lot to add to our knowledge... @tbg

It seems also strange how I could successfully connect to DNS/internet before, since I find the same relevant error messages in previous boots.

$ journalctl -b-6 -g dbus-org.freedesktop.resolve1 --no-hostname --no-pager

-- Journal begins at Fri 2020-12-11 21:48:02 EET, ends at Sat 2021-01-09 16:08:36 EET. --
Ιαν 08 02:31:02 dbus-daemon[391]: [system] Activating via systemd: service name='org.freedesktop.resolve1' unit='dbus-org.freedesktop.resolve1.service' requested by ':1.2' (uid=0 pid=392 comm="/usr/bin/NetworkManager --no-daemon ")
Ιαν 08 02:31:02 dbus-daemon[391]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.resolve1.service': Unit dbus-org.freedesktop.resolve1.service not found.
3 Likes