WiFi Not Detecting Anything

That’s a rather buggy wifi adapter, search the forum for many posted fixes.

Sometimes adding a kernel boot parameter can help with your issue.

The following command will add a GRUB kernel boot parameter to /etc/default/grub:

sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ pcie_aspm=off "/g' -i /etc/default/grub

After adding the boot parameter(s) and saving your changes, run:

sudo update-grub 

Reboot, and test your connection for improvement.