WiFi Not Detecting Anything

Kernel: 6.4.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c9fed118-d15b-463b-9235-1015372679a1 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=a8a7931a-d6f4-48db-b826-e07bb1369396 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Dell product: Inspiron 5505 v: 1.5.4
serial: <superuser required> Chassis: type: 10 v: 1.5.4
serial: <superuser required>
Mobo: Dell model: 0YX59Y v: A01 serial: <superuser required> UEFI: Dell
v: 1.5.4 date: 06/10/2021
ID-1: BAT0 charge: 30.5 Wh (100.0%) condition: 30.5/39.8 Wh (76.7%)
volts: 12.5 min: 11.2 model: SWD-ATL3.560 DELL 5NDNH11 type: Li-poly
serial: <filter> status: full
Info: model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 type: MCP
arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600104
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
desc: 2x4 MiB
Speed (MHz): avg: 3011 high: 3993 min/max: 1400/2375 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 1397 2: 3271
3: 3993 4: 1576 5: 3840 6: 3993 bogomips: 28448
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Renoir vendor: Dell driver: amdgpu v: kernel arch: GCN-5
code: Vega process: GF 14nm built: 2017-20 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 03:00.0
chip-ID: 1002:1636 class-ID: 0300 temp: 66.0 C
Device-2: Realtek Integrated_Webcam_HD driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2:3 chip-ID: 0bda:565a
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x097d built: 2020
res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
API: OpenGL v: 4.6 Mesa 23.1.4 renderer: AMD Radeon Graphics (renoir LLVM
15.0.7 DRM 3.52 6.4.4-zen1-1-zen) direct-render: Yes
Device-1: AMD Renoir Radeon High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 03:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Dell
driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x, snd_pci_acp5x,
snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
snd_sof_amd_renoir, snd_sof_amd_rembrandt pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Dell driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.6
chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.4.4-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.75 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
vendor: Dell driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:003e class-ID: 0280
IF: wlp2s0 state: down mac: <filter>
IF-ID-1: enp3s0f3u1 state: unknown speed: -1 duplex: half mac: <filter>
Device-1: Samsung GT-I9070 (network tethering USB debugging enabled)
driver: rndis_host v: kernel type: USB rev: 2.1 speed: 480 Mb/s lanes: 1
mode: 2.0 bus-ID: 1-1:7 chip-ID: 04e8:6864 class-ID: 0a00 serial: <filter>
Device-2: Qualcomm Atheros driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-3:4 chip-ID: 0cf3:e007
class-ID: e001
Report: ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 242.19 GiB used: 57.39 GiB (23.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: BC511 NVMe 256GB
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 11004101 temp: 41.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Generic model: SD MMC MS PRO
size: 3.72 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.0
spd: 480 Mb/s lanes: 1 mode: 2.0 tech: SSD serial: <filter> fw-rev: 1.00
scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 57.39 GiB (25.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 588 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 57.39 GiB (25.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 57.39 GiB (25.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 57.39 GiB (25.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.13 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p3 maj-min: 259:3
System Temperatures: cpu: 57.0 C mobo: 40.0 C gpu: amdgpu temp: 67.0 C
Fan Speeds (RPM): cpu: 3586
Processes: 267 Uptime: 11m wakeups: 399 Memory: total: 8 GiB note: est.
available: 7.13 GiB used: 2.91 GiB (40.8%) Init: systemd v: 253
default: graphical tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7
Packages: pm: pacman pkgs: 1951 libs: 537 tools: octopi,paru Shell: fish
v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.28
Garuda (2.6.16-1):
System install date:     2023-07-20
Last full system update: 2023-07-24
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

Hello all,

I've been having the most frustrating issue I've ever experienced when using linux since I switched over to Garuda. I really don't wanna distro hop again but it seems unique to this distribution as it never happened before and I only just made the switch.

The the issue is that every now and then, garuda seems to just 'switch off' my laptop's network card. It refuses to locate and connect to any networks and when looking through the arch wiki I tried the steps to manually reconnect at the terminal but when I did an ip link it returned the info that my wifi card was down. Attempting to set it to up resulted in a Timed Out error.

The happened once more 2 days ago but after tearing my hair out and restarting my machine 9 seperate times and trying multiple different potential fixes, the wifi just suddenly started working again with no indication as to how.

I've tried everything I tried back then and more now, it's been 16 restarts and more repeated attempts of the same methods than I care to admit and it still isn't even detecting the myriad of networks around me...

Any help in this issue would be greatly appreciated,

  • Nova

That’s a rather buggy wifi adapter, search the forum for many posted fixes.

Sometimes adding a kernel boot parameter can help with your issue.

The following command will add a GRUB kernel boot parameter to /etc/default/grub:

sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ pcie_aspm=off "/g' -i /etc/default/grub

After adding the boot parameter(s) and saving your changes, run:

sudo update-grub 

Reboot, and test your connection for improvement.


Looking through the forums, seems a lot of people have issues with this. I would look over this post of how to get it running correctly:

The kernel boot parameter listed there might help get you started from what I’ve seen before in older posts of this wifi device. Might take additional tweaking to get it to work at full speed though.

edit: tbg beat me to it :rofl:


This has indeed worked out for me, at least the wifi is working for now. It being tempermental and all I can't tell if it just decided this reboot was a good one or if it was actually the fix.

In any case I appreciate the help, the new parameter is in my grub config and updated so hopefully the issue won't pop up again, if it does I'll try the second parameter they suggested in that post.

Thanks again!


Glad that helped, and welcome to the Garuda community. :wave:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.