Wakes from suspend after 10 min

I've recently purchased a new Asus ROG laptop and installed Garuda on it. I noticed that it wakes up on it's own after suspend. I've searched everything on the internet and found that disabling certain ACPI (XHCI and TXHC) helps - but the laptop still wakes up and ACPI devices get enabled back.

This is my ACPI wakeup devices:

cat /proc/acpi/wakeup | grep enabled
PEG1      S4    *enabled   pci:0000:00:01.0
PEG0      S4    *enabled   pci:0000:00:06.0
RP06      S4    *enabled   pci:0000:00:1c.0
RP07      S4    *enabled   pci:0000:00:1c.6
XHCI      S3    *enabled   pci:0000:00:14.0
TXHC      S3    *enabled   pci:0000:00:0d.0
TDM0      S4    *enabled   pci:0000:00:0d.2
TRP0      S4    *enabled   pci:0000:00:07.0
AWAC      S4    *enabled   platform:ACPI000E:00

powertop shows that there's a 3-3 usb device that is enabled, I tried disabling it like this:

echo 'disabled' | sudo tee '/sys/bus/usb/devices/3-3/power/wakeup'

yet the laptop still wakes up on it's own the USB device becomes enabled again. Below I'll give some lsusb and lspci output:

lsusb -s 3:3
Bus 003 Device 003: ID 0408:30c3 Quanta Computer, Inc. USB2.0 HD UVC WebCam
lspci -nnk | grep 0000:00:14.0
0000:00:14.0 USB controller [0c03]: Intel Corporation Alder Lake PCH USB 3.2 xHCI Host Controller [8086:51ed] (rev 01)

I've also tried creating a systemd service to disable ACPI/USB ports on system launch, and it's disabled on boot, but later something turns it back on and it keeps waking up from suspend on it's own.

some journalctl output:

╰─λ journalctl -b | grep 'wake'
juuli 26 21:15:15 Asus kernel: rtc_cmos rtc_cmos: RTC can wake from S4
juuli 26 21:15:21 Asus bluetoothd[882]: src/device.c:device_set_wake_support() Unable to set wake_support without RPA resolution
juuli 26 21:15:30 Asus dbus-daemon[883]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.39' (uid=0 pid=4117 comm="sudo tee /proc/acpi/wakeup")
juuli 26 21:15:31 Asus dbus-daemon[883]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.40' (uid=0 pid=4360 comm="sudo tee /proc/acpi/wakeup")
juuli 26 21:15:32 Asus dbus-daemon[883]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.41' (uid=0 pid=4394 comm="sudo tee /sys/bus/usb/devices/3-3/power/wakeup")
juuli 26 21:28:23 Asus dbus-daemon[883]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.145' (uid=0 pid=60324 comm="sudo tee /sys/bus/usb/devices/3-3/power/wakeup")
juuli 26 21:28:27 Asus sudo[60324]:    v1rtl : TTY=pts/0 ; PWD=/home/v1rtl ; USER=root ; COMMAND=/usr/bin/tee /sys/bus/usb/devices/3-3/power/wakeup
juuli 26 21:46:39 Asus NetworkManager[987]: <info>  [1690397199.7116] manager: sleep: wake requested (sleeping: yes  enabled: yes)
juuli 26 21:46:40 Asus bluetoothd[882]: src/device.c:device_set_wake_support() Unable to set wake_support without RPA resolution

garuda-inxi output:

Kernel: 6.1.38-2-lts arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
root=UUID=2e425827-3595-47ea-adad-49c927aa87d7 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
xchi_hcd.quirks=270336 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: ROG Zephyrus G16 GU603VV_GU603VV
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: GU603VV v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: GU603VV.301 date: 01/12/2023
ID-1: BAT0 charge: 64.3 Wh (71.0%) condition: 90.5/90.0 Wh (100.6%)
power: 55.1 W volts: 15.5 min: 15.9 model: AS3GWAF3KC GA50358 type: Unknown
serial: <filter> status: discharging
Info: model: 13th Gen Intel Core i9-13900H bits: 64 type: MST AMCP
arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
process: Intel 7 (10nm) family: 6 model-id: 0xBA (186) stepping: 2
microcode: 0x4112
Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 1699 high: 3000 min/max: 400/5200:5400:4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 775 4: 3000
5: 800 6: 3000 7: 791 8: 3000 9: 793 10: 800 11: 2581 12: 3000 13: 1900
14: 1680 15: 1659 16: 1900 17: 1841 18: 1687 19: 1323 20: 1856
bogomips: 119840
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Raptor Lake-P [Iris Xe Graphics] vendor: ASUSTeK
driver: i915 v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+
ports: active: eDP-1 empty: DP-1,DP-2 bus-ID: 0000:00:02.0
chip-ID: 8086:a7a0 class-ID: 0300
Device-2: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile] vendor: ASUSTeK
driver: nvidia v: 535.86.05 alternate: nouveau,nvidia_drm non-free: 535.xx+
status: current (as of 2023-07) arch: Lovelace code: AD1xx
process: TSMC n4 (5nm) built: 2022-23+ ports: active: none
empty: DP-3,HDMI-A-1,eDP-2 bus-ID: 0000:01:00.0 chip-ID: 10de:28e0
class-ID: 0300
Device-3: Quanta USB2.0 HD UVC WebCam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:3 chip-ID: 0408:30c3
class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 2560x1600 s-dpi: 96 s-size: 677x423mm (26.65x16.65")
s-diag: 798mm (31.43")
Monitor-1: eDP-1 model: TL160ADMP03-0 built: 2022 res: 2560x1600 hz: 240
dpi: 188 gamma: 1.2 size: 345x215mm (13.58x8.46") diag: 407mm (16")
ratio: 16:10 modes: 2560x1600
API: OpenGL v: 4.6 Mesa 23.1.3 renderer: Mesa Intel Graphics (RPL-P)
direct-render: Yes
Device-1: Intel vendor: ASUSTeK driver: snd_hda_intel v: kernel
alternate: snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:51ca
class-ID: 0403
Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 0000:01:00.1 chip-ID: 10de:22be class-ID: 0403
API: ALSA v: k6.1.38-2-lts status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 0.3.74 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel driver: iwlwifi v: kernel port: N/A bus-ID: 0000:00:14.3
chip-ID: 8086:51f1 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus-ID: 0000:39:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp57s0 state: down mac: <filter>
Device-1: Intel driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 8087:0033 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
driver: vmd v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:a77f rev:
class-ID: 0104
Local Storage: total: 953.87 GiB used: 285.71 GiB (30.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2400 MTFDKBA1T0QFM
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: V3MA003 temp: 39.9 C
scheme: GPT
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 285.71 GiB (30.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 285.71 GiB (30.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 285.71 GiB (30.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 285.71 GiB (30.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 30.97 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: N/A mobo: N/A
Fan Speeds (RPM): cpu: 3300
Processes: 407 Uptime: 10m wakeups: 2 Memory: total: 32 GiB note: est.
available: 30.97 GiB used: 4.95 GiB (16.0%) Init: systemd v: 253
default: graphical tool: systemctl Compilers: gcc: 13.1.1 Packages:
pm: pacman pkgs: 1916 libs: 555 tools: octopi,paru Shell: fish v: 3.6.1
running-in: konsole inxi: 3.3.28
Garuda (2.6.16-1):
System install date:     2023-06-20
Last full system update: 2023-07-25
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Check in your UEFI/BIOS menu for options related to PCIe power management, such as ASPM or ACPI, which can be disabled. Sometimes setting like these will be tucked away in "advanced" settings submenus.


I don't have any settings in advanced BIOS related to power management.

I have these:

  • ASUS Cloud Recovery
  • ASUS System Diagnostics
  • ErP [Disabled]
  • ArmouryCrate Control Interface Support [Enabled]
  • Hyper-Threading [Enabled]
  • Intel Virtualization Technology [Enabled]
  • Intel AES-NI [Enabled]
  • VT-d [Enabled]
  • Display Mode [Dynamic]
  • Auto-install app service mechanism [Toggle Off]
  • Active Efficient-cores [All]
  • ASUS EZ Flash 3 Utility
  • Intel Rapid Storage Technology
  • SMART Settings
  • Network Stack Configuration
  • USB Configuration
  • Graphics Configuration
  • VMD Setup Menu
  • Animation Logo Configuration

my BIOS version is 301

Try setting the nvme.noacpi=1 kernel parameter. It is typically used for optimizing battery life, but what it actually does is work around ACPI wackiness so it might be worth a shot.


I have had similar issues with a Desktop PC.
For me, I had a router that was configured to send a wake up command to my PC whenever a client tries to contact its IP Address.
So, does this only occur when you're at home?

1 Like

it didn't help. computer still wakes up on its own.

I also tried disabling VMD controller (was advised on Asus Linux discord) but it didn't help either

it happens with WiFi disabled as well

Lets try this kernel parameter instead:


Do you have anything connected to the laptop? Monitors, USB devices, Bluetooth pairings... It may be helpful to disconnect everything and confirm the issue is not related to a specific device.

If it is being caused by a connected device, you may be able to use udev to lift the curse, as described in this article: Power management/Wakeup triggers - ArchWiki


How are you disabling your wifi?

Have you tried unplugging all USB devices prior to suspension?

You might want to try the pcie_aspm=off kernel parameter as a test.

You can also try disabling Network Manager’s WiFi power saving features with the following command:

echo -e "[connection]\nwifi.powersave = 0" | sudo tee /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

A setting of “0” will totally disable power saving features in the WiFi adapter.

A setting of “2” or “1” will be less aggressive, but still leave power saving enabled.

If changing this default does not improve your issue, then you can delete the newly created configuration file /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf.


I have a Bluetooth mouse, and I tried turning of BT and turning it off, and the waking up issue still occurs. So it's not related to BT.

to double confirm: I used this mouse on another laptop with Manjaro Linux - it never occured that the laptop woke up on it's own.

unfortunately it didn't help :confused:

I ran sudo update-grub, rebooted, put to sleep right after I logged in and it woke up in 2 minutes.

unfortunately disabling powersave had no effect, still wakes up on it's own :frowning:

You have ignored answering my prior questions. This is unlikely to get you further help as my available time for providing support is limited, and having to ask things repeatedly disinclines myself towards offering further assistance.

To double inquire:

Exactly how are you disabling your bluetooth and wifi?

Also be sure to disable WOL (wake on lan) in your BIOS.

If you can positively identify the device responsible for waking your computer, you may be able to disable it by writing a service to shut it down using its hardware ID. Your logs seem to point to USB device 3-3 waking the computer.

lsusb -s 3:3
Bus 003 Device 003: ID 0408:30c3 Quanta Computer, Inc. USB2.0 HD UVC WebCam

You could try disabling this device using its hardware ID in a service:

Have you tried using a non bluetooth mouse yet?

A wired mouse would be best to test out for troubleshooting purposes.

Have you tried alternate kernels yet?

Be sure to test at least the lts, mainline, and linux kernels.

I believe your BIOS version should be 308 (not 301), you should update your BIOS.

A definitive troubleshooting test would be to disconnect anything that did not come preinstalled by your laptop manufacturer. This includes any USB devices including, mouse, keyboard, phone, USB hubs (etc), and any external monitor or other device externally connected to your laptop.

Does this happen with the battery installed/removed?

Does this happen when running only on battery with the charger disconnected?

Disable ArmouryCrate as it has been known to interfere with the sleep function on some Asus laptops.

Please respond to every question/suggestion in full if you desire further assistance.

Good luck.


I'm sorry, I was asking this question on another forum so forgot to duplicate some of the answers - yes I tried unplugging everything (including power cable), disabled Bluetooth, disabled WiFi, turned the mouse off completely and kept BT on - under all cases it woke up on it's own at some point.

I disable wifi and BT through KDE Settings.

I do not have a WOL setting in BIOS.

I tried disabling the device, when I put it to sleep and it wakes up the device is back on, as well as XCHI and TXHC ACPI wakeup triggers.

I don't own a non BT mouse.

I have tried latest linux (latest 6.4.7), linux-lts and linux-g14 kernels. I will try the mainline one.

I don't have my phone connected to the laptop, nor any extra monitors or other devices at all. Only a BT mouse, and even with it being disconnected, the issue still occurs.

I didn't try to remove the battery since the laptop bottom is bolted on.

It happened both on AC power and on battery.

Thank you for the list of recommendations and I again apologize for inconsistent communication from my side, I will try to disable ArmouryCrate in BIOS now.

And I hope I won't have to update BIOS since it's very risky but if I have to I'll respond here if it would help.


I've updated BIOS to 308, it didn't have any impact on the issue. Neither did disabling ArmouryCrate.

I've tried mainline kernel - it still happens.

Will try other workarounds later tomorrow.

Also here's a log of journalctl 3 minutes after a wake up on mainline, in case it helps:

Excerpt from your log:

Stopping Suspend fix for ath11k_pci…
aug 01 00:49:03 Asus systemd[1]: root-suspend-fix.service: Deactivated successfully.
aug 01 00:49:03 Asus systemd[1]: Stopped Suspend fix for ath11k_pci.
aug 01 00:49:03 Asus kernel: usb 3-3: new full-speed USB device number 2 using xhci_hcd
aug 01 00:49:03 Asus NetworkManager[838]: [1690840143.2224] device (wlo1): state change: unmanaged → unavailable (reason ‘managed’, sys-iface-state: ‘external’)
aug 01 00:49:03 Asus kernel: r8169 0000:39:00.0 enp57s0: Link is Down
aug 01 00:49:03 Asus NetworkManager[838]: [1690840143.2654] device (wlo1): set-hw-addr: set MAC address to 7E:42:F9:00:F9:FA (scanning)
aug 01 00:49:03 Asus kernel: iwlwifi 0000:00:14.3: WRT: Invalid buffer destination
aug 01 00:49:03 Asus kernel: usb 3-3: New USB device found, idVendor=0b05, idProduct=19b6, bcdDevice= 4.16
aug 01 00:49:03 Asus kernel: usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
aug 01 00:49:03 Asus kernel: usb 3-3: Product: N-KEY Device
aug 01 00:49:03 Asus kernel: usb 3-3: Manufacturer: ASUSTek Computer Inc.
aug 01 00:49:03 Asus kernel: asus 0003:0B05:19B6.0004: Asus initialise N-KEY Device
aug 01 00:49:03 Asus kernel: input: ASUSTek Computer Inc. N-KEY Device as /devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3:1.0/0003:0B05:19B6.0004/input/input34
aug 01 00:49:03 Asus kernel: asus 0003:0B05:19B6.0004:

What is this log output about below:

Stopping Suspend fix for ath11k_pci…
aug 01 00:49:03 Asus systemd[1]: root-suspend-fix.service: Deactivated successfully.

Why would you have a service running to stop the ath11k_pci driver. That is not your wifi driver. The ath11k driver is for Atheros adapters. Your adapter is an Intel model that uses the iwlwifi driver. Did you do a copy paste solution found online for an Atheros adapter and use it for your Intel adapter? That is unlikely to work if that is what you’ve done.

Please post the contents of the root-suspend-fix.service that you are using.


Yes, I copy-pasted it as I was trying other approaches as well, hoping that it could help. This service runs modprobe -r ath11k_pci on start and modprobe ath11k_pci on stop. I'll remove it now but if it helps here's the whole service code:

Description=Suspend fix for ath11k_pci

ExecStart=-modprobe -r ath11k_pci
ExecStop=-modprobe ath11k_pci


options iwlwifi bt_coex_active=0


I recall pasting this line into a text fille named, "iwlwifi.conf"

...and dropping it into /etc/modprobe.d

That was a couple years ago on a laptop. Hope this helps.


it had no effect on my setup unfortunately :confused:

This is not very precise information. Did this behavior start after an update, or has it been your laptop’s behavior since Garuda was first installed?

You need to narrow this down for us to make any kind of progress here. I would like for you to make a live boot disk to determine what is creating this issue. Download a Garuda KDE image and boot from it. Do not have your BT mouse connected when you boot this live environment. Let the computer go to sleep, or place it into suspension from KDE. See if the computer wakes on its own with no BT device connected in the live environment. If it still wakes from sleep, then I would like you to put your computer to sleep using a terminal command instead. Please let us know what happens in the live environment by invoking sleep using different methods and if the result is the same.