System waking up on it's own and then suspending back randomly


Before I made a post on the same issue and I was re-installing Garuda Linux, and the suspend worked fine on a live USB with latest firmware. But after I re-installed it on my system, the problem came back. I've tried multiple things, nothing worked so far.

The main author of the Asus Linux blog/community recommended me to try s0ix self-test tool and this is the output I got:

Seems like there are a few errors but I couldn't find anything that would explain it.

Cirrus amplifier patch

I use a custom initrd entry for the Cirrus amplifier patch because on Asus laptops it's not properly loaded. I load the patch as an initrd entry like this:

# /etc/default/grub

I use this SSDT patch and I generate the cpio file as described in the Asus Linux cirrus amp guide:

iasl -tc ssdt_csc3551.dsl
mkdir -p kernel/firmware/acpi
cp ssdt_csc3551.aml kernel/firmware/acpi
find kernel | cpio -H newc --create > patched_cirrus_acpi.cpio
sudo cp patched_cirrus_acpi.cpio /boot/patched_cirrus_acpi.cpio

But removing it and and updating GRUB didn't make the issue go away. It wakes up on it's own in both cases.

Different kernels and firmware

The issue persists across these kernels:

  • linux-zen 6.4.12 with linux-firmware version 20230804.7be2766d-2 with both the patch loaded and not loaded
  • linux-next-git 6.5.0-rc7-next-20230825-1-next-git-12910-g626932085009 with linux-firmware-git
  • on linux-lts 6.1.48 with linux-firmware-git
  • on linux-mainline 6.5.0-rc6
  • on linux 6.4.12

it takes it longer to wake up on it's own after suspend about 15-30 minutes on all kernels except zen. On zen it wakes up after 2-5 min.

ACPI wakeup triggers

I've also checked which devices have wakeup triggers enabled again:

λ cat /proc/acpi/wakeup | grep enabled
PEG1      S4    *enabled   pci:0000:00:01.0
PEG0      S4    *enabled   pci:0000:00:06.0
RP06      S4    *enabled   pci:0000:00:1c.0
RP07      S4    *enabled   pci:0000:00:1c.6
PXSX      S4    *enabled   pci:0000:39:00.0
XHCI      S3    *enabled   pci:0000:00:14.0
TXHC      S3    *enabled   pci:0000:00:0d.0
TDM0      S4    *enabled   pci:0000:00:0d.2
TRP0      S4    *enabled   pci:0000:00:07.0
AWAC      S4    *enabled   platform:ACPI000E:00

and then checked the device names via lspci -nnk | grep ...:

0000:00:01.0 PCI bridge [0604]: Intel Corporation Device [8086:a70d]

0000:00:06.0 PCI bridge [0604]: Intel Corporation Device [8086:a74d]

0000:00:1c.0 PCI bridge [0604]: Intel Corporation Device [8086:51bd] (rev 01)

0000:00:1c.6 PCI bridge [0604]: Intel Corporation Device [8086:51be] (rev 01)

0000:39:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)

0000:00:14.0 USB controller [0c03]: Intel Corporation Alder Lake PCH USB 3.2 xHCI Host Controller [8086:51ed] (rev 01)

0000:00:0d.0 USB controller [0c03]: Intel Corporation Device [8086:a71e]

0000:00:07.0 PCI bridge [0604]: Intel Corporation Device [8086:a76e]

I've disabled all of them, then the computer woke up again, even though all the triggers were disabled.


Here's dmesg: Garuda's PrivateBin

and journalctl -b outputs: Garuda's PrivateBin

both are made while using Linux 6.1.48 LTS + git version of linux-firmware.

Previous attemps

From the previous thread I acknowledged that:

  • disabling ACPI wake up triggers doesn't have any effect
  • disabling USB 3-3 device (which is a webcam) doesn't have any effect (all others are already disabled)
  • switching the kernel doesn't help, it happens on every 6.1+ kernel (haven't tested older ones)
  • switching linux-firmware doesn't help
  • the issue is not related to Bluetooth - it happens with it both enabled and disabled (I toggle it from KDE settings)
  • the issue is not related to Wi-Fi, it happens with it both enabled and disabled
  • Adding options iwlwifi bt_coex_active=0 to /etc/modprobe.d/iwlwifi.conf doesn't have any effect either.
  • Updating BIOS from 301 to 308 didn't do any effect as well
  • there's no WoL setting in BIOS so I didn't do anything with it.
  • acpi.ec_no_wakeups kernel parameter has no effect on the issue.


Kernel: 6.1.48-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
root=UUID=31891f4d-4b7f-4e61-a0da-e72715325014 rw rootflags=subvol=@
acpi.ec_no_wakeups quiet quiet rd.udev.log_priority=3
vt.global_cursor_default=0 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: ROG Zephyrus G16 GU603VV_GU603VV
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: GU603VV v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: GU603VV.308 date: 04/21/2023
ID-1: BAT0 charge: 59.3 Wh (69.0%) condition: 85.9/90.0 Wh (95.5%)
power: 18.9 W volts: 15.7 min: 15.9 model: AS3GWAF3KC GA50358 type: Unknown
serial: <filter> status: discharging
Info: model: 13th Gen Intel Core i9-13900H bits: 64 type: MST AMCP
arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
process: Intel 7 (10nm) family: 6 model-id: 0xBA (186) stepping: 2
microcode: 0x4119
Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 1769 high: 3000 min/max: 400/5200:5400:4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 787 2: 3000 3: 978
4: 3000 5: 1044 6: 3000 7: 1043 8: 3000 9: 1001 10: 3000 11: 1128 12: 3000
13: 896 14: 898 15: 861 16: 886 17: 988 18: 3000 19: 878 20: 3000
bogomips: 119840
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Raptor Lake-P [Iris Xe Graphics] vendor: ASUSTeK
driver: i915 v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+
ports: active: eDP-1 empty: DP-1,DP-2 bus-ID: 0000:00:02.0
chip-ID: 8086:a7a0 class-ID: 0300
Device-2: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile] vendor: ASUSTeK
driver: nvidia v: 535.104.05 alternate: nouveau,nvidia_drm non-free: 535.xx+
status: current (as of 2023-08) arch: Lovelace code: AD1xx
process: TSMC n4 (5nm) built: 2022-23+ ports: active: none
empty: DP-3,HDMI-A-1,eDP-2 bus-ID: 0000:01:00.0 chip-ID: 10de:28e0
class-ID: 0300
Device-3: Quanta USB2.0 HD UVC WebCam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:3 chip-ID: 0408:30c3
class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 2560x1600 s-dpi: 96 s-size: 677x423mm (26.65x16.65")
s-diag: 798mm (31.43")
Monitor-1: eDP-1 model: TL160ADMP03-0 built: 2022 res: 2560x1600 hz: 240
dpi: 188 gamma: 1.2 size: 345x215mm (13.58x8.46") diag: 407mm (16")
ratio: 16:10 modes: 2560x1600
API: OpenGL v: 4.6 Mesa 23.1.6 renderer: Mesa Intel Graphics (RPL-P)
direct-render: Yes
Device-1: Intel vendor: ASUSTeK driver: snd_hda_intel v: kernel
alternate: snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:51ca
class-ID: 0403
Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 0000:01:00.1 chip-ID: 10de:22be class-ID: 0403
API: ALSA v: k6.1.48-1-lts status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.78 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel driver: iwlwifi v: kernel port: N/A bus-ID: 0000:00:14.3
chip-ID: 8086:51f1 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus-ID: 0000:39:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp57s0 state: down mac: <filter>
Device-1: Intel driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 8087:0033 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.3 lmp-v: 12
status: discoverable: no pairing: no
Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
driver: vmd v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:a77f rev:
class-ID: 0104
Local Storage: total: 953.87 GiB used: 22.83 GiB (2.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2400 MTFDKBA1T0QFM
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: V3MA003 temp: 31.9 C
scheme: GPT
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 22.83 GiB (2.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 22.83 GiB (2.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 22.83 GiB (2.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 22.83 GiB (2.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 30.97 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 20 dev: /dev/zram0
System Temperatures: cpu: N/A mobo: N/A
Fan Speeds (rpm): cpu: 2200
Processes: 373 Uptime: 23m wakeups: 3 Memory: total: 32 GiB note: est.
available: 30.97 GiB used: 4.32 GiB (13.9%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1558 libs: 480 tools: octopi,paru Shell: fish v: 3.6.1
running-in: konsole inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-08-27
Last full system update: 2023-08-29
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

I hope I provided as much information as I could, if there's more required I could send it down the thread.

Try completely uninstalling the Nvidia drivers, and booting with just Nouveau to test if the issue persists.

Like this?

sudo pacman -Rdd nvidia-dkms
sudo pacman -S nvidia-open-dkms

I believe nvidia-utils also needs to be uninstalled.

That package is something else.

No need to install anything to use the Nouveau driver, it is built into the kernel. It gets blacklisted when you install Nvidia drivers, but uninstalling Nvidia should be all that is needed for removing the blacklist.


got it, thanks for clarification. I will uninstall anything with nvidia then.

Unfortunately it had no effect either :frowning: , it still woke up eventually

here's a journalctl log: Garuda's PrivateBin

To confirm that nouveau is loaded:

λ lspci -nnk | grep -iA2 vga

0000:00:02.0 VGA compatible controller [0300]: Intel Corporation Raptor Lake-P [Iris Xe Graphics] [8086:a7a0] (rev 04)
DeviceName: Onboard - Video
Subsystem: ASUSTeK Computer Inc. Raptor Lake-P [Iris Xe Graphics] [1043:185d]
0000:01:00.0 VGA compatible controller [0300]: NVIDIA Corporation AD107M [GeForce RTX 4060 Max-Q / Mobile] [10de:28e0] (rev a1)
Subsystem: ASUSTeK Computer Inc. AD107M [GeForce RTX 4060 Max-Q / Mobile] [1043:185d]
Kernel modules: nouveau

No worries, that was kind of a long shot but it's one more thing we can rule out.

Let's test the 5.15 kernel if you don't mind. You'll have to let it build because there isn't a pre-built binary at the moment.

paru linux-lts515 linux-lts515-headers

Press Q to exit out of the PKGBUILD, then give it some time to install. I guess we don't have to worry too much about your computer going to suspend while it builds! :stuck_out_tongue_winking_eye:

Okay I will compile it.

Btw I've tried disabling VMD Controller in BIOS settings (I was recommended to do so on Asus Linux Discord) - had no effect either

I’m hitting

[FAILED] failed to start Load/Save Screen Btt Brightness of backlight:nvidia_0.
[FAILED] Failed to start Load/Save Screen Backlight Brightness of backlight:nvidia_0.

and it gets stuck there, I was booting from linux515-lts

try disabling some of the ‘wake from suspend’ options in the BIOS to prevent any peripherals from waking the system up except the keyboard or power button.


I don’t have any such options in BIOS. See Wakes from suspend after 10 min - #3 by talentlessguy

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.