Unable to write mp4 video file to Flash drive

Everything else works fine, I can create folders copy paste .mkv files, even some mp4 files that were already on flash drive can be tranfered to system and back to Flash drive. But I have 2 video files that are mp4 format, whenever I copy them it shows error

could not write to /run/media/user/flashdrive/video-file.mp4

I just made a switch from windows, I'm completely new to linux, also I can't find anything on Google or this forum related to the error...
Please assist me...

Welcome,
does user, user, exist?
The name of flash drive is flashdrive?

Please post in- and all output of your terminal.

╭─sgs@i3 in ~ 
 ╰─λ cd /mnt/sdd1/Video

 ╭─sgs@i3 in /mnt/sdd1/Video 
 ╰─λ cp Funny\ Ketchup\ Commercial-5C5ctjRYslw.mp4 /run/media/sgs/Ventoy/

 ╭─sgs@i3 in /mnt/sdd1/Video took 5ms
 ╰─λ 
1 Like

Read

please
and post

inxi -Fza

as text!

Even if you personally think it is unnecessary.

By the way, this is the Garuda forum, not the how to copy files forum.

1 Like

╭─imrtls00@Sameer in ~ took 2ms
[:red_circle:] × cd /home/imrtls00/Videos

╭─imrtls00@Sameer in ~/Videos
╰─λ cp Ertugrul_Ghazi_Urdu__Episode_48_Season_4(720p).mp4
cp: missing destination file operand after 'Ertugrul_Ghazi_Urdu__Episode_48_Season_4(720p).mp4'
Try 'cp --help' for more information.

╭─imrtls00@Sameer in ~/Videos took 1ms
[:red_circle:] ×

Path to /run/.... is missing

1 Like

╭─imrtls00@Sameer in ~/Videos took 2s
╰─λ cp Ertugrul_Ghazi_Urdu__Episode_48_Season_4(720p).mp4 /run/media/imrtls00/Videos
cp: cannot create regular file '/run/media/imrtls00/Videos': Permission denied

Like this?

2 Likes

Check owner from directory Videos

man chown

https://wiki.archlinux.org/title/File_permissions_and_attributes

2 Likes

I used Dolphin and provided permission to owner, group and others...
Still same "Permission denied"

How did you do this?

1 Like
  1. Opened the video folder in Dolphin (file explorer)
  2. Right click the file, > Root Actions > Change Permissions.

You should not need to do that, what is the flash drive formatted to, How big are the files

2 Likes
 ╭─sgs@i3 in ~ 
 ╰─λ ls /run/media/imrtls00/Videos

You know root action in dolphin, but you can't copy files?

But why you change from terminal to dolphin?

1 Like

I don't know the terminal commands yet. So I tried Dolphin, and checked all items and found this root action.

This command returned this

.rwxrwxrwx 365M imrtls00  9 Jul 06:47  Ertugrul_Ghazi_Urdu_|_Episode_49|_Season_4(720p).mp4
.rwxrwxrwx 369M imrtls00 10 Jul 05:02  Ertugrul_Ghazi_Urdu_|_Episode_50|_Season_4(720p).mp4

From this it means that everyone have all permissions...?

Filesystem is vfat

Each file is around 500MB

Hi there welcome to the community.

First of all, your command location is wrong. Your command should be

cp Ertugrul_Ghazi_Urdu__Episode_48_Season_4(720p).mp4 <path to directory>

To see path of directory, you have to open terminal in pendrive and use command

pwd

(Which stands for Print working directory, btw)

Also, if this is only 2 files, and everything else is fine, then I am afraid that the files might be corrupt or something. But that'll confirmed only if you try to copy to somewhere else say desktop, and it still doesn't work. Like, test this command

cp Ertugrul_Ghazi_Urdu__Episode_48_Season_4(720p).mp4 ~/Desktop
3 Likes

I tried to make a zip file then copied, the zip file was copied to flash drive but can't be extracted in the flash drive. I extracted the same .zip in videos, it worked fine.

And the files can be copied to another locations like desktop. Also they're not corupt as I can play the video start to end.

That's quite weird, tbh.

Try creating a new folder in videos directory, and then copying it to flash drive.

3 Likes

I'm new and can't share screenshots, tried new folder but same thing.
I'm giving up on this now...